aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-29 02:08:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-29 02:08:47 +0000
commit76e84c5694e034365fe552b8d942fea534fd47da (patch)
tree11aff309a37090857fc14e10cfe70ee1b514a1c4 /net-im
parent747f49f45efb0b5e0005fb9afd6c92f793f1e4b2 (diff)
downloadports-76e84c5694e034365fe552b8d942fea534fd47da.tar.gz
ports-76e84c5694e034365fe552b8d942fea534fd47da.zip
fix msn 100% cpu loading problem
Obtained from: centericq mailing list Approved by: maintainer
Notes
Notes: svn path=/head/; revision=114981
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile1
-rw-r--r--net-im/centericq/files/patch-msnhook.cc16
2 files changed, 14 insertions, 3 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index b181de91bd78..e7b920a5cc41 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,6 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.10.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index 0bbda9b195eb..6f1486372147 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -1,6 +1,16 @@
---- src/hooks/msnhook.cc.orig Sun Mar 7 21:44:41 2004
-+++ src/hooks/msnhook.cc Fri Apr 2 10:23:03 2004
-@@ -408,11 +408,11 @@
+--- src/hooks/msnhook.cc.orig Thu Jul 1 03:42:16 2004
++++ src/hooks/msnhook.cc Thu Jul 29 10:02:57 2004
+@@ -155,6 +155,9 @@
+ int hsock = 0;
+ MSN::Connection *c;
+
++ FD_ZERO(&rs);
++ FD_ZERO(&ws);
++ FD_ZERO(&es);
+ getsockets(rs, ws, es, hsock);
+ tv.tv_sec = tv.tv_usec = 0;
+
+@@ -451,11 +454,11 @@
void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
string oldnick = c->getnick();