aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-15 23:39:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-15 23:39:30 +0000
commit09d5bc188f9d50fea5d9a6cb3373a60095b29496 (patch)
tree575635d99b1b0ff7316136152f6d997956b5ce99 /net-im
parent1d398fd23115fce20a95e0f8b4e7d57c1a009446 (diff)
downloadports-09d5bc188f9d50fea5d9a6cb3373a60095b29496.tar.gz
ports-09d5bc188f9d50fea5d9a6cb3373a60095b29496.zip
Command-line twitter client for sixel supported terminal.
WWW: https://github.com/isaki68k/sayaka PR: 200867 Submitted by: sue@iwmt.org
Notes
Notes: svn path=/head/; revision=389766
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/sayaka/Makefile47
-rw-r--r--net-im/sayaka/distinfo2
-rw-r--r--net-im/sayaka/files/patch-sayaka.sh30
-rw-r--r--net-im/sayaka/pkg-descr3
5 files changed, 83 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 261520b8d8bf..41945c4bff91 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -146,6 +146,7 @@
SUBDIR += rubygem-lita
SUBDIR += rubygem-termtter
SUBDIR += rubygem-tinder
+ SUBDIR += sayaka
SUBDIR += sendxmpp
SUBDIR += sigram
SUBDIR += skype
diff --git a/net-im/sayaka/Makefile b/net-im/sayaka/Makefile
new file mode 100644
index 000000000000..75ede0d48c16
--- /dev/null
+++ b/net-im/sayaka/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= sayaka
+PORTVERSION= 3.0.9
+CATEGORIES= net-im
+
+MAINTAINER= sue@iwmt.org
+COMMENT= Command-line twitter client for SIXEL-supported terminal
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ img2sixel:${PORTSDIR}/graphics/libsixel
+
+USE_GITHUB= yes
+GH_ACCOUNT= isaki68k
+
+PLIST_FILES= bin/sayaka
+
+USE_PHP= curl filter hash json mbstring pcntl pdo pdo_sqlite sqlite3
+WANT_PHP_CLI= yes
+
+PORTDOCS= README.md
+PORTDATA= OAuth.php \
+ TwistOAuth.php \
+ colormap16.png \
+ colormap8.png \
+ config.php \
+ sayaka.php \
+ subr.php \
+ twitteroauth.php
+
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@@DATADIR@@|${DATADIR}|g' ${WRKSRC}/sayaka.sh
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sayaka.sh ${STAGEDIR}${PREFIX}/bin/sayaka
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+.for f in ${PORTDATA}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${STAGEDIR}${DATADIR}
+.endfor
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/net-im/sayaka/distinfo b/net-im/sayaka/distinfo
new file mode 100644
index 000000000000..b89eaf120ef5
--- /dev/null
+++ b/net-im/sayaka/distinfo
@@ -0,0 +1,2 @@
+SHA256 (isaki68k-sayaka-3.0.9_GH0.tar.gz) = 0b5673b1e8e28a884c0efe1f6e09bfc2a715f20cba592dad93b5f4bae8ca9865
+SIZE (isaki68k-sayaka-3.0.9_GH0.tar.gz) = 40350
diff --git a/net-im/sayaka/files/patch-sayaka.sh b/net-im/sayaka/files/patch-sayaka.sh
new file mode 100644
index 000000000000..cfe7c536c4c0
--- /dev/null
+++ b/net-im/sayaka/files/patch-sayaka.sh
@@ -0,0 +1,30 @@
+--- sayaka.sh.orig 2015-06-14 09:43:42 UTC
++++ sayaka.sh
+@@ -27,9 +27,26 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+
+-SAYAKA_HOME=${HOME}/.sayaka
++: ${SAYAKA_HOME:=${HOME}/.sayaka}
+ #SAYAKA_HOME=.
+
++DATADIR=@@DATADIR@@
++
++die() {
++ echo "$@"
++ exit 1
++}
++
++mklinks() {
++ mkdir $SAYAKA_HOME || die "Can't create ${SAYAKA_HOME}."
++ cd $SAYAKA_HOME
++ for f in ${DATADIR}/*.php ${DATADIR}/*.png; do
++ ln -s $f .
++ done
++}
++
++[ -d $SAYAKA_HOME ] || mklinks
++
+ cd $SAYAKA_HOME
+
+ cmd=$1
diff --git a/net-im/sayaka/pkg-descr b/net-im/sayaka/pkg-descr
new file mode 100644
index 000000000000..5e6edc73184b
--- /dev/null
+++ b/net-im/sayaka/pkg-descr
@@ -0,0 +1,3 @@
+Command-line twitter client for sixel supported terminal.
+
+WWW: https://github.com/isaki68k/sayaka