aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /net-im
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Notes
Notes: svn path=/head/; revision=313460
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin-sipe/Makefile19
-rw-r--r--net-im/zephyr/Makefile10
2 files changed, 11 insertions, 18 deletions
diff --git a/net-im/pidgin-sipe/Makefile b/net-im/pidgin-sipe/Makefile
index e19113968700..bb0b633301fe 100644
--- a/net-im/pidgin-sipe/Makefile
+++ b/net-im/pidgin-sipe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pidgin-sipe
-# Date created: 7 May 2009
-# Whom: John Prather
-#
+# Created by: John Prather
# $FreeBSD$
-#
PORTNAME= pidgin-sipe
PORTVERSION= 1.13.1
@@ -28,19 +24,20 @@ PORTDOCS= AUTHORS ChangeLog COPYING HACKING INSTALL NEWS README TODO VERSION
CFLAGS+= "-I/${LOCALBASE}/include"
LIBS+= "-L/${LOCALBASE}/lib"
-OPTIONS= OSC2005 "Message timeout for OCS2005" off \
- KRB5 "With Kerberos5" off
+OPTIONS_DEFINE= OCS2005 KRB5 DOCS NLS
+OSC2005_DESC= Message timeout for OCS2005
+KRB5_DESC= With Kerberos5
CONFIGURE_ARGS+= --enable-purple \
--disable-telepathy
.include <bsd.port.options.mk>
-.if defined(WITH_OSC2005)
+.if ${PORT_OPTIONS:MOSC2005}
CONFIGURE_ARGS+= --enable-ocs2005-message-hack
.endif
-.if defined(WITHOUT_KRB5)
+.if ${PORT_OPTIONS:MKRB5}
CONFIGURE_ARGS+= --without-krb5
.endif
@@ -48,7 +45,7 @@ CONFIGURE_ENV+= LIBS="${LIBS}" \
COM_ERR_CFLAGS="-I/usr/include" \
COM_ERR_LIBS="-L/usr/lib -lcom_err"
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for docs in ${PORTDOCS}
@@ -56,7 +53,7 @@ post-install:
.endfor
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
diff --git a/net-im/zephyr/Makefile b/net-im/zephyr/Makefile
index 112f473a8f13..e0aa06e409d0 100644
--- a/net-im/zephyr/Makefile
+++ b/net-im/zephyr/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: zephyr
-# Date created: 12 November 2009
-# Whom: Ben Kaduk <kaduk@mit.edu>
-#
+# Created by: Ben Kaduk <kaduk@mit.edu>
# $FreeBSD$
-#
PORTNAME= zephyr
DISTVERSION= 3.0.1
@@ -25,11 +21,11 @@ USE_ICONV= yes
MAN1= zephyr.1 zaway.1 zctl.1 zleave.1 zlocate.1 znol.1 zwrite.1 zwgc.1
MAN8= zhm.8 zephyrd.8 zstat.8 zshutdown_notify.8
-OPTIONS= HEIMDAL "Use Heimdal Kerberos for ss/com_err" off
+OPTIONS_DEFINE= HEIMDAL
.include <bsd.port.options.mk>
-.if defined(WITH_HEIMDAL)
+.if ${PORT_OPTIONS:MHEIMDAL}
BROKEN= bad depobj
LIB_DEPENDS+= ss.1:${PORTSDIR}/security/heimdal
.if defined(HEIMDAL_HOME)