aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-10 23:27:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-10 23:27:03 +0000
commit5d8173ac16103d02f17692cd34dcb590b3c3f999 (patch)
tree08156a1d2d14fab1130f7b53d22b2eec793bd8b7 /net-im
parent5c803374bdbabfe3bdb7c4d16b75f5bd190a8237 (diff)
downloadports-5d8173ac16103d02f17692cd34dcb590b3c3f999.tar.gz
ports-5d8173ac16103d02f17692cd34dcb590b3c3f999.zip
- Update to 0.11
- Switch to qt4 - Drop gentoo patches no longer supported PR: based on 120324 Submitted by: Dmitry Sivachenko <demon@freebsd.org> Approved by: shaun (maintainer)
Notes
Notes: svn path=/head/; revision=216677
Diffstat (limited to 'net-im')
-rw-r--r--net-im/psi/Makefile45
-rw-r--r--net-im/psi/Makefile.gentoo184
-rw-r--r--net-im/psi/distinfo15
-rw-r--r--net-im/psi/files/gentoopatch-src_psiaccount.cpp38
-rw-r--r--net-im/psi/files/patch-configure29
-rw-r--r--net-im/psi/files/patch-third-party-qca-cyrus-sasl.cpp10
-rw-r--r--net-im/psi/files/patch-third-party-qca-gnupg.cpp10
-rw-r--r--net-im/psi/files/patch-third-party-qca-ossl.cpp10
-rw-r--r--net-im/psi/pkg-plist104
9 files changed, 99 insertions, 346 deletions
diff --git a/net-im/psi/Makefile b/net-im/psi/Makefile
index 46c31d479b05..bdfeff0aebb9 100644
--- a/net-im/psi/Makefile
+++ b/net-im/psi/Makefile
@@ -6,53 +6,34 @@
#
PORTNAME= psi
-PORTVERSION= 0.10
-PORTREVISION= 2
+DISTVERSION= 0.11
CATEGORIES= net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= shaun@FreeBSD.org
-COMMENT?= A Qt-based Jabber client
+COMMENT= A Qt-based Jabber client
-BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-LIB_DEPENDS= qca.1:${PORTSDIR}/devel/qca
-RUN_DEPENDS= ${LOCALBASE}/lib/plugins/crypto/libqca-tls.so:${PORTSDIR}/security/qca-tls
+LIB_DEPENDS= qca.2:${PORTSDIR}/devel/qca
HAS_CONFIGURE= yes
USE_BZIP2= yes
-USE_QT_VER= 3
+USE_QT_VER= 4
+QT_COMPONENTS= corelib dbus gui iconengines imageformats qt3support \
+ inputmethods moc network rcc script svg uic xml
-CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++ \
+
+CONFIGURE_ENV= QMAKESPEC=${LOCALBASE}/share/qt4/mkspecs/freebsd-g++ \
PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
PTHREAD_LDFLAGS=${PTHREAD_LIBS} \
KDEDIR=${LOCALBASE}
CONFIGURE_ARGS= --prefix=${PREFIX} --qtdir=${LOCALBASE} \
- --with-qca-inc=${LOCALBASE}/include/plugins/qca \
+ --with-qca-inc=${LOCALBASE}/include/QtCrypto \
--with-qca-lib=${LOCALBASE}/lib \
--disable-growl --disable-dnotify --disable-ghbnr
MAKE_ARGS+= QTDIR=${QT_PREFIX} \
- QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-
-PORTDOCS= README ChangeLog
-
-OPTIONS?= GENTOO_EXTRAS "Build with unofficial Gentoo patches" off
-
-PLIST_SUB= GENTOO="@comment "
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_GENTOO_EXTRAS)
-. include "Makefile.gentoo"
-.endif
+ QMAKESPEC=${LOCALBASE}/share/qt4/mkspecs/freebsd-g++
post-install:
${STRIP_CMD} ${PREFIX}/bin/psi
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
-
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>
diff --git a/net-im/psi/Makefile.gentoo b/net-im/psi/Makefile.gentoo
deleted file mode 100644
index 1db480228995..000000000000
--- a/net-im/psi/Makefile.gentoo
+++ /dev/null
@@ -1,184 +0,0 @@
-# New ports collection makefile for: psi
-# Date created: Wed Feb 15 20:27:23 CET 2006
-# Whom: stephan@spaceboyz.net
-#
-# $FreeBSD$
-#
-
-MASTER_SITES+= http://vivid.dat.pl/psi/:vivid \
- http://mirror.inerd.com/FreeBSD/distfiles/psi-gentoo/:inerd \
- http://csociety-ftp.ecn.purdue.edu/pub/gentoo-portage/net-im/psi/files/:portage \
- ${MASTER_SITE_GENTOO:C/gentoo\/%SUBDIR%\//gentoo-portage\/net-im\/psi\/files\/:portage/g}
-
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} gentoo-psi-0.10.tar.bz2:vivid psi-indicator.png:portage psi-reverse_trayicon2.patch:inerd
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} gentoo-psi-0.10.tar.bz2
-GENTOO_PATCHES= ${WRKDIR}/0.10
-PKGNAMESUFFIX= -gentoo
-
-PATCH_DEPENDS+= gpatch:${PORTSDIR}/devel/patch
-GPATCH= ${LOCALBASE}/bin/gpatch
-
-PLIST_SUB= GENTOO=""
-
-post-patch::
- # from http://norman.rasmussen.co.za/darcs/psi-muc/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-muc_support.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-muc_support-update-20051123.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-muc_support-update-20060114.patch
-
- # roster-nr
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-fix_popup_richtext.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-roster-nr-0.9.14.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-status_indicator++_add-on_roster-nr.patch
- # indicator icon
- ${CP} ${DISTDIR}/psi-indicator.png ${WRKSRC}/iconsets/roster/default/indicator.png
-
- # from http://www.cs.kuleuven.ac.be/~remko/psi/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/jep8-avatars_iris.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/jep8-avatars_psi.diff
-
- # from http://machekku.uaznia.net/jabber/psi/patches/
- ${REINPLACE_CMD} 's#<includehint>fortuneslistbox.h</includehint>##' ${GENTOO_PATCHES}/psi-machekku-smart_reply_and_forward-0.5_psi-gentoo.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-smart_reply_and_forward-0.5_psi-gentoo.diff
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/psi-machekku-keep_message_in_auto_away_status.diff
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/psi-machekku-quote_emoticons.diff
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/psi-machekku-emoticons_advanced_toggle.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-enable_thread_in_messages.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-linkify_fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-autostatus_while_dnd.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-visual_styles_manifest.diff
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/psi-machekku-tool_window_minimize_fix_for_windows.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-new_character_counter.diff
-
- # from ftp://ftp.patryk.one.pl/pub/psi/skazi/patches/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-options_resize-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-settoggles-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-line_in_options-mod.diff
- ${GPATCH} -d ${WRKSRC} -p0 < ${GENTOO_PATCHES}/psi-empty_group-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-no_online_status-mod.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-status_history-add-psi-gentoo.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-icon_buttons_big_return-mod.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-linkify-mod-rev-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-save_profile-mod.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-url_emoticon-mod.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-thin_borders-mod.diff
-
- # from http://www.uaznia.net/psi-daisy/patches/
- ${GPATCH} -d ${WRKSRC} -p0 < ${GENTOO_PATCHES}/filetransfer.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-emots-mod.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi_michalj_statusicon_in_chatdlg_titlebar.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi_michalj_custom_rostericons_in_tooltips.diff
-
- # from ftp://ftp.patryk.one.pl/pub/psi/patches/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-psz-chatdlg_typed_msgs_history.diff
-
- # from http://kg.alternatywa.info/psi/patche/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-status-timeout-kfix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-kg-spoof.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-kg-individual_status_add.diff
-
- # from pld-linux.org
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-certs.patch
-
- # upstream patches from psi-flyspray
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-fix_groupsortingstyle_toggles.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-multiple_account_groups.diff
-
- # from http://psi-pedrito.go.pl/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/pedrito-null-key-string-fix.diff
- ${GPATCH} -d ${WRKSRC} -p0 < ${GENTOO_PATCHES}/pedrito-avatars-printf-off.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/pedrito-linkify_and_wrap-client.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/pedrito-group_menuitem_for_notinlist.diff
-
- # from psi-devel mailing list
- ${GPATCH} -d ${WRKSRC} -p0 < ${GENTOO_PATCHES}/psi-history_lug.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-history-deletion-bugfix.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/checkboxes-sound-options.diff
-
- # from http://mircea.bardac.net/psi/patches/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-cli-v2.diff
-
- # from ubuntu
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-trayicon_ubuntu_fix.patch
-
- # from http://home.unclassified.de/files/psi/patches/
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/statusdlg-enterkey.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/fix-min-window-notify.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/hide-no-resource-from-contextmenu.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/custom-sound-popup.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/offline-contact-animation.diff
-
- # from bugs.gentoo.org
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-add-status-history.patch
-
- # from http://rydz.homedns.org
- ${GPATCH} -d ${WRKSRC} -p2 < ${GENTOO_PATCHES}/psi-filetransfer-finish-popup-qsorix.patch
-
- # from http://k.uaznia.net/jabber/psi/patches/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/a-psi-k-emergency_away_status_button.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-evil_message_support.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-auto_responder.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-auto_responder_gui.patch
-
- # from http://www.cs.kuleuven.ac.be/~remko/psi/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/rosteritems_iris.diff
- # this one was chagned because of muc support
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/rosteritems_psi_with_muc.diff
-
- # from http://delx.cjb.net/psi/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-nicknames.patch
-
- # from http://norman.rasmussen.co.za/darcs/psi-rc/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/norman-rc.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/norman-darcs-20051129.diff
- # from http://machekku.uaznia.net/jabber/psi/patches/
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-machekku-rc_multiline_status_fix.diff
- # from http://norman.rasmussen.co.za/darcs/psi-rc/
- ${REINPLACE_CMD} -e 's#src/rc.cpp#rc.cpp#' ${GENTOO_PATCHES}/psi-dynamic-priority-rc-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-dynamic-priority-rc-fix.diff
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/norman-darcs-20051231.patch
-
- # created for psi-gentoo and roster-nr
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-smile_icon_emoticonset.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-enable_avatars.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-transport_icons_and_avatars.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-client_avatars_icons.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-emoticons_advanced_toggle-add-roster-nr.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-chatdlg_messages_colors_distinguishes.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-messages_color_backgrounds_in_chat.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-sort-style-on-roster-nr.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-says_mod.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-muc_support_langpacks_fix.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-copy_jid_or_status_message_to_clipboard.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-timestamps_option_and_date_showing.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-avatars_graph_settings_filetypes.patch
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-auto_responder_by_message.patch
- # by nelchael
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-nelchael-exec_command.patch
- #${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-nelchael-xmms-status.patch
-
- ${GPATCH} -d ${WRKSRC} -p1 < ${GENTOO_PATCHES}/psi-gentoo-version.patch
-
- ${CP} ${DISTDIR}/psi-reverse_trayicon2.patch ${GENTOO_PATCHES}
- ${GPATCH} -d ${WRKSRC} -p0 < ${GENTOO_PATCHES}/psi-reverse_trayicon2.patch
-
- # Repair Makefile
- ${MV} ${WRKSRC}/src/psiaccount.cpp ${WRKSRC}/src/psiaccount.cpp.orig
- ${SED} -e 's/include"adhoc.h"/include"..\/adhoc.h"/' \
- -e 's/include"rc.h"/include"..\/rc.h"/' \
- -e 's/include"adhoc_fileserver.h"/include"..\/adhoc_fileserver.h"/' \
- ${WRKSRC}/src/psiaccount.cpp.orig > ${WRKSRC}/src/psiaccount.cpp
-
- cd ${WRKSRC} && ${PATCH} < ${FILESDIR}/gentoopatch-src_psiaccount.cpp
-
- # Move misplaced files
- ${MV} ${WRKSRC}/adhoc.cpp \
- ${WRKSRC}/adhoc.h \
- ${WRKSRC}/adhoc_fileserver.cpp \
- ${WRKSRC}/adhoc_fileserver.h \
- ${WRKSRC}/rc.cpp \
- ${WRKSRC}/rc.h \
- ${WRKSRC}/src/
-
- # Move pre-patched junk out of the way
- @${FIND} ${WRKSRC} \( -name '*~' -or -name '*.orig' \) -delete
diff --git a/net-im/psi/distinfo b/net-im/psi/distinfo
index a4deabba3831..f77a91498fcb 100644
--- a/net-im/psi/distinfo
+++ b/net-im/psi/distinfo
@@ -1,12 +1,3 @@
-MD5 (psi-0.10.tar.bz2) = f0fd4ccf077f7b24e236f71c22649b7b
-SHA256 (psi-0.10.tar.bz2) = e10a88586f8d7f29535510cf3a3857dc8ff2792e64db4207d62a935890a60ca1
-SIZE (psi-0.10.tar.bz2) = 1430929
-MD5 (gentoo-psi-0.10.tar.bz2) = 4aacc2de659a5a551e9b47382af83c35
-SHA256 (gentoo-psi-0.10.tar.bz2) = 1d499ecb693401a69600d48c62bc3cbd3f4eed7605729655959d13af981d72bd
-SIZE (gentoo-psi-0.10.tar.bz2) = 211538
-MD5 (psi-indicator.png) = 0d5cafd17325fc912c4855252d73378f
-SHA256 (psi-indicator.png) = a0e9adcd0409d23c9033170ceb8f22980ba6d5e14f19234630f9986bfb94bce2
-SIZE (psi-indicator.png) = 300
-MD5 (psi-reverse_trayicon2.patch) = c2528c15be8277434647506d791663d8
-SHA256 (psi-reverse_trayicon2.patch) = 2a690a7cda661884ce3424530ac6569a7fcb1e6c97342c120767a0d5058c403c
-SIZE (psi-reverse_trayicon2.patch) = 937
+MD5 (psi-0.11.tar.bz2) = 6ccc81783eece7959140951289cf5310
+SHA256 (psi-0.11.tar.bz2) = be37b7b8d86e965362512f47bf68af2b21d35e5c886a9e0eccf1c9bc519706b3
+SIZE (psi-0.11.tar.bz2) = 2000216
diff --git a/net-im/psi/files/gentoopatch-src_psiaccount.cpp b/net-im/psi/files/gentoopatch-src_psiaccount.cpp
deleted file mode 100644
index d18c53baa7ba..000000000000
--- a/net-im/psi/files/gentoopatch-src_psiaccount.cpp
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/psiaccount.cpp.orig Tue May 30 22:17:08 2006
-+++ src/psiaccount.cpp Tue May 30 19:40:01 2006
-@@ -3049,13 +3049,13 @@
-
- values["Sender.jid.full"] = jidSender.full();
- values["Sender.jid.bare"] = jidSender.bare();
-- values["Sender.nick"] = (uSender)? uSender->name() : "";
-- values["Sender.nick-jid"] = jidnick(jidSender.bare(), (uSender)? uSender->name() : "");
-+ values["Sender.nick"] = (uSender)? uSender->name() : (QString)"";
-+ values["Sender.nick-jid"] = jidnick(jidSender.bare(), (uSender)? uSender->name() : (QString)"");
-
- values["Me.jid.full"] = jidMe.resource().isEmpty()? jidMe.full() + "/" + d->client->resource() : jidMe.full();
- values["Me.jid.bare"] = jidMe.bare();
-- values["Me.nick"] = (uMe)? uMe->name() : "";;
-- values["Me.nick-jid"] = jidnick(jidMe.bare(), (uMe)? uMe->name() : "");
-+ values["Me.nick"] = (uMe)? uMe->name() : (QString)"";;
-+ values["Me.nick-jid"] = jidnick(jidMe.bare(), (uMe)? uMe->name() : (QString)"");
-
- header = headerTemplate.expand(values);
- }
-@@ -3081,7 +3081,7 @@
-
- Template::ExpandData values;
-
-- values["fortune"] = (option.fortunes.count())? option.fortunes[rand()%option.fortunes.count()] : "";
-+ values["fortune"] = (option.fortunes.count())? option.fortunes[rand()%option.fortunes.count()] : (QString)"";
-
- signature = signatureTemplate.expand(values);
-
-@@ -3146,7 +3146,7 @@
- sepBody = "\n";
-
- // signature
-- QString signature = (option.useMessageSignature)? expandSignatureTemplate(option.messageSignature, option.autoMessageSignatureDelimiter,FALSE) : "";
-+ QString signature = (option.useMessageSignature)? expandSignatureTemplate(option.messageSignature, option.autoMessageSignatureDelimiter,FALSE) : (QString)"";
-
- // body/signature separator
- // we want to have one empty line between body and signature (at least two '\n');
diff --git a/net-im/psi/files/patch-configure b/net-im/psi/files/patch-configure
index f1a19a1bac28..95866a3106f5 100644
--- a/net-im/psi/files/patch-configure
+++ b/net-im/psi/files/patch-configure
@@ -9,32 +9,3 @@
*) show_usage; exit ;;
esac
done
-@@ -1055,9 +1057,13 @@
- "}\n";
-
- QString extra;
-+ QString pthread_cflags = getenv("PTHREAD_CFLAGS");
-+ QString pthread_ldflags = getenv("PTHREAD_LDFLAGS");
- if(!path.isEmpty())
- extra += QString("-L") + path + ' ';
- extra += QString("-l") + name;
-+ extra += ' ' + pthread_cflags + ' ' + pthread_ldflags + ' ';
-+
- if(!doCompileAndLink(str, extra))
- return false;
- return true;
-@@ -1287,14 +1293,6 @@
- echo
- exit 1;
- fi
--cat >Makefile.tmp <<EOT
--export QTDIR = $QTDIR
--export PATH = $QTDIR/bin:$PATH
--EOT
--cat Makefile >> Makefile.tmp
--rm -f Makefile
--cp -f Makefile.tmp Makefile
--rm -f Makefile.tmp
-
- echo
- echo "Good, your configure finished. Now run 'make'."
diff --git a/net-im/psi/files/patch-third-party-qca-cyrus-sasl.cpp b/net-im/psi/files/patch-third-party-qca-cyrus-sasl.cpp
new file mode 100644
index 000000000000..844a17a47907
--- /dev/null
+++ b/net-im/psi/files/patch-third-party-qca-cyrus-sasl.cpp
@@ -0,0 +1,10 @@
+--- third-party/qca/qca-cyrus-sasl/qca-cyrus-sasl.cpp.orig 2007-10-14 18:00:57.000000000 +0400
++++ third-party/qca/qca-cyrus-sasl/qca-cyrus-sasl.cpp 2008-02-06 18:08:20.000000000 +0300
+@@ -20,6 +20,7 @@
+ */
+
+ #include <QtCrypto>
++#include <qcaprovider.h>
+ #include <QDebug>
+ #include <QtCore/qplugin.h>
+
diff --git a/net-im/psi/files/patch-third-party-qca-gnupg.cpp b/net-im/psi/files/patch-third-party-qca-gnupg.cpp
new file mode 100644
index 000000000000..f682a1837e40
--- /dev/null
+++ b/net-im/psi/files/patch-third-party-qca-gnupg.cpp
@@ -0,0 +1,10 @@
+--- third-party/qca/qca-gnupg/qca-gnupg.cpp.orig 2008-02-06 18:10:33.000000000 +0300
++++ third-party/qca/qca-gnupg/qca-gnupg.cpp 2008-02-06 18:10:39.000000000 +0300
+@@ -17,6 +17,7 @@
+ */
+
+ #include <QtCrypto>
++#include <qcaprovider.h>
+ #include <QtPlugin>
+
+ #ifdef Q_OS_MAC
diff --git a/net-im/psi/files/patch-third-party-qca-ossl.cpp b/net-im/psi/files/patch-third-party-qca-ossl.cpp
new file mode 100644
index 000000000000..7626150c0b3d
--- /dev/null
+++ b/net-im/psi/files/patch-third-party-qca-ossl.cpp
@@ -0,0 +1,10 @@
+--- third-party/qca/qca-ossl/qca-ossl.cpp.orig 2007-10-14 18:00:57.000000000 +0400
++++ third-party/qca/qca-ossl/qca-ossl.cpp 2008-02-06 18:09:55.000000000 +0300
+@@ -19,6 +19,7 @@
+ */
+
+ #include <QtCrypto>
++#include <qcaprovider.h>
+
+ #include <QDebug>
+ #include <QtCore/qplugin.h>
diff --git a/net-im/psi/pkg-plist b/net-im/psi/pkg-plist
index 87fc2c7f015f..94e4e8b6a9cf 100644
--- a/net-im/psi/pkg-plist
+++ b/net-im/psi/pkg-plist
@@ -1,9 +1,15 @@
bin/psi
+share/applications/psi.desktop
+share/icons/hicolor/128x128/apps/psi.png
+share/icons/hicolor/16x16/apps/psi.png
+share/icons/hicolor/32x32/apps/psi.png
+share/icons/hicolor/48x48/apps/psi.png
+share/icons/hicolor/64x64/apps/psi.png
%%DATADIR%%/COPYING
%%DATADIR%%/README
%%DATADIR%%/certs/README
-%%DATADIR%%/certs/rootcert.xml
-%%DATADIR%%/iconsets/emoticons/README
+%%DATADIR%%/certs/rootcerts.pem
+%%DATADIR%%/certs/startcom_ca.crt
%%DATADIR%%/iconsets/emoticons/default/angry.png
%%DATADIR%%/iconsets/emoticons/default/bat.png
%%DATADIR%%/iconsets/emoticons/default/beer.png
@@ -53,29 +59,28 @@ bin/psi
%%DATADIR%%/iconsets/roster/crystal-yahoo.jisp
%%DATADIR%%/iconsets/roster/default/ask.png
%%DATADIR%%/iconsets/roster/default/away.png
-%%DATADIR%%/iconsets/roster/default/chat.png
-%%DATADIR%%/iconsets/roster/default/connect.png
+%%DATADIR%%/iconsets/roster/default/chat.fading.png
+%%DATADIR%%/iconsets/roster/default/chatty.png
%%DATADIR%%/iconsets/roster/default/dnd.png
-%%DATADIR%%/iconsets/roster/default/ffc.png
-%%DATADIR%%/iconsets/roster/default/file.png
+%%DATADIR%%/iconsets/roster/default/file.fading.png
%%DATADIR%%/iconsets/roster/default/groupclose.png
-%%DATADIR%%/iconsets/roster/default/groupempty.png
%%DATADIR%%/iconsets/roster/default/groupopen.png
%%DATADIR%%/iconsets/roster/default/headline.png
%%DATADIR%%/iconsets/roster/default/icondef.xml
%%DATADIR%%/iconsets/roster/default/invisible.png
-%%DATADIR%%/iconsets/roster/default/message.png
+%%DATADIR%%/iconsets/roster/default/message.fading.png
%%DATADIR%%/iconsets/roster/default/noauth.png
%%DATADIR%%/iconsets/roster/default/offline.png
+%%DATADIR%%/iconsets/roster/default/online.dimming.png
%%DATADIR%%/iconsets/roster/default/online.png
%%DATADIR%%/iconsets/roster/default/perr.png
%%DATADIR%%/iconsets/roster/default/system.png
%%DATADIR%%/iconsets/roster/default/xa.png
%%DATADIR%%/iconsets/system/README
%%DATADIR%%/iconsets/system/default/account.png
+%%DATADIR%%/iconsets/system/default/add.png
%%DATADIR%%/iconsets/system/default/advanced.png
%%DATADIR%%/iconsets/system/default/appearance.png
-%%DATADIR%%/iconsets/system/default/add.png
%%DATADIR%%/iconsets/system/default/arrow_down.png
%%DATADIR%%/iconsets/system/default/arrow_left.png
%%DATADIR%%/iconsets/system/default/arrow_right.png
@@ -86,25 +91,28 @@ bin/psi
%%DATADIR%%/iconsets/system/default/chatclear.png
%%DATADIR%%/iconsets/system/default/close.png
%%DATADIR%%/iconsets/system/default/closetab.png
+%%DATADIR%%/iconsets/system/default/command.png
+%%DATADIR%%/iconsets/system/default/configure-room.png
%%DATADIR%%/iconsets/system/default/configure_toolbars.png
-%%DATADIR%%/iconsets/system/default/download.png
%%DATADIR%%/iconsets/system/default/disco.png
-%%DATADIR%%/iconsets/system/default/eye_blue.png
+%%DATADIR%%/iconsets/system/default/download.png
%%DATADIR%%/iconsets/system/default/events.png
+%%DATADIR%%/iconsets/system/default/eye_blue.png
%%DATADIR%%/iconsets/system/default/filemanager.png
%%DATADIR%%/iconsets/system/default/groupchat.png
%%DATADIR%%/iconsets/system/default/help.png
%%DATADIR%%/iconsets/system/default/history.png
-%%DATADIR%%/iconsets/system/default/icon_16.png
-%%DATADIR%%/iconsets/system/default/icon_32.png
-%%DATADIR%%/iconsets/system/default/icon_48.png
-%%DATADIR%%/iconsets/system/default/icon_mac.png
%%DATADIR%%/iconsets/system/default/icondef.xml
%%DATADIR%%/iconsets/system/default/info.png
%%DATADIR%%/iconsets/system/default/jabber.png
%%DATADIR%%/iconsets/system/default/key.png
%%DATADIR%%/iconsets/system/default/key_bad.png
%%DATADIR%%/iconsets/system/default/key_unknown.png
+%%DATADIR%%/iconsets/system/default/logo_128.png
+%%DATADIR%%/iconsets/system/default/logo_16.png
+%%DATADIR%%/iconsets/system/default/logo_32.png
+%%DATADIR%%/iconsets/system/default/logo_48.png
+%%DATADIR%%/iconsets/system/default/logo_64.png
%%DATADIR%%/iconsets/system/default/ok.png
%%DATADIR%%/iconsets/system/default/options.png
%%DATADIR%%/iconsets/system/default/pgp.png
@@ -112,44 +120,50 @@ bin/psi
%%DATADIR%%/iconsets/system/default/play_sounds.png
%%DATADIR%%/iconsets/system/default/psilogo.png
%%DATADIR%%/iconsets/system/default/psimain.png
+%%DATADIR%%/iconsets/system/default/publish_tune.png
%%DATADIR%%/iconsets/system/default/quit.png
%%DATADIR%%/iconsets/system/default/register.png
%%DATADIR%%/iconsets/system/default/reload.png
%%DATADIR%%/iconsets/system/default/remove.png
%%DATADIR%%/iconsets/system/default/search.png
-%%DATADIR%%/iconsets/system/default/send.png
%%DATADIR%%/iconsets/system/default/self.png
+%%DATADIR%%/iconsets/system/default/send.png
+%%DATADIR%%/iconsets/system/default/shortcuts.png
%%DATADIR%%/iconsets/system/default/show_away.png
%%DATADIR%%/iconsets/system/default/show_hidden.png
%%DATADIR%%/iconsets/system/default/show_offline.png
-%%DATADIR%%/iconsets/system/default/start-chat.png
-%%DATADIR%%/iconsets/system/default/status.png
%%DATADIR%%/iconsets/system/default/smile.png
%%DATADIR%%/iconsets/system/default/ssl_no.png
%%DATADIR%%/iconsets/system/default/ssl_yes.png
+%%DATADIR%%/iconsets/system/default/start-chat.png
+%%DATADIR%%/iconsets/system/default/status.png
%%DATADIR%%/iconsets/system/default/stop.png
%%DATADIR%%/iconsets/system/default/time.png
%%DATADIR%%/iconsets/system/default/tip.png
%%DATADIR%%/iconsets/system/default/upload.png
%%DATADIR%%/iconsets/system/default/url.png
%%DATADIR%%/iconsets/system/default/vcard.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/add_image.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/add_text.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/bring_forwards.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/bring_to_front.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/draw_circles.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/draw_ellipses.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/draw_lines.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/draw_paths.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/draw_rectangles.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/erase.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/group.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/rotate.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/scale.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/scroll.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/select.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/send_backwards.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/send_to_back.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/translate.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/ungroup.png
+%%DATADIR%%/iconsets/system/default/whiteboarding/whiteboard.png
%%DATADIR%%/iconsets/system/default/xml.png
-%%DATADIR%%/iconsets/system/default/clients/aim.png
-%%DATADIR%%/iconsets/system/default/clients/exodus.png
-%%DATADIR%%/iconsets/system/default/clients/gabber.png
-%%DATADIR%%/iconsets/system/default/clients/gadu.png
-%%DATADIR%%/iconsets/system/default/clients/gaim.png
-%%DATADIR%%/iconsets/system/default/clients/gossip.png
-%%DATADIR%%/iconsets/system/default/clients/icq.png
-%%DATADIR%%/iconsets/system/default/clients/jajc.png
-%%DATADIR%%/iconsets/system/default/clients/kopete.png
-%%DATADIR%%/iconsets/system/default/clients/msn.png
-%%DATADIR%%/iconsets/system/default/clients/nitro.png
-%%DATADIR%%/iconsets/system/default/clients/pandion.png
-%%DATADIR%%/iconsets/system/default/clients/tkabber.png
-%%DATADIR%%/iconsets/system/default/clients/trillian.png
-%%DATADIR%%/iconsets/system/default/clients/unknown.png
-%%DATADIR%%/iconsets/system/default/clients/yahoo.png
%%DATADIR%%/sound/chat1.wav
%%DATADIR%%/sound/chat2.wav
%%DATADIR%%/sound/ft_complete.wav
@@ -157,24 +171,8 @@ bin/psi
%%DATADIR%%/sound/offline.wav
%%DATADIR%%/sound/online.wav
%%DATADIR%%/sound/send.wav
-%%GENTOO%%%%DATADIR%%/iconsets/roster/default/indicator.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/clients/wpk.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/clients/gajim.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/clients/konnekt.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/clients/tlen.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/bookmark.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/muc_affil_editor.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/muc_destroy_room.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/edittrash.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/edit.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/emergencyStatusNo.png
-%%GENTOO%%%%DATADIR%%/iconsets/system/default/emergencyStatusYes.png
-share/applications/psi.desktop
-share/icons/hicolor/16x16/apps/psi.png
-share/icons/hicolor/32x32/apps/psi.png
-share/icons/hicolor/48x48/apps/psi.png
@dirrm %%DATADIR%%/sound
-@dirrm %%DATADIR%%/iconsets/system/default/clients
+@dirrm %%DATADIR%%/iconsets/system/default/whiteboarding
@dirrm %%DATADIR%%/iconsets/system/default
@dirrm %%DATADIR%%/iconsets/system
@dirrm %%DATADIR%%/iconsets/roster/default
@@ -191,5 +189,9 @@ share/icons/hicolor/48x48/apps/psi.png
@dirrmtry share/icons/hicolor/32x32
@dirrmtry share/icons/hicolor/48x48/apps
@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
@dirrmtry share/icons/hicolor
@dirrmtry share/icons