aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-10 17:33:31 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-10-10 17:33:31 +0000
commit382e9b638ce468002ed0fecbba5d20fdb14d35bb (patch)
tree0af4f6575205cd5fb4564681dbfccc545024971a /net-im
parent279d68be7fa1b999b8a06854353f325e5e05fec7 (diff)
downloadports-382e9b638ce468002ed0fecbba5d20fdb14d35bb.tar.gz
ports-382e9b638ce468002ed0fecbba5d20fdb14d35bb.zip
* Update to 0.71 [1]
* Add optional Mozilla NSS support Submitted by: Matthew Luckie <mjl@luckie.org.nz> [1]
Notes
Notes: svn path=/head/; revision=90807
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Makefile27
-rw-r--r--net-im/gaim/distinfo3
-rw-r--r--net-im/gaim/files/patch-configure29
-rw-r--r--net-im/gaim/files/patch-src::protocols::oscar.c36
-rw-r--r--net-im/gaim/pkg-plist3
5 files changed, 60 insertions, 38 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
index ed62759b1de7..6cf53359ceb5 100644
--- a/net-im/gaim/Makefile
+++ b/net-im/gaim/Makefile
@@ -5,18 +5,11 @@
#
PORTNAME= gaim
-PORTVERSION= 0.70
-PORTREVISION= 2
+PORTVERSION= 0.71
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-.if defined(WITH_JPPATCH)
-PATCH_SITES= http://www.cc.rim.or.jp/~yaz/
-PATCHFILES= gaim-0.70_jp.patch.gz
-PATCH_DIST_STRIP= -p1
-.endif
-
MAINTAINER?= marcus@FreeBSD.org
COMMENT= Gtk+-2.0 open-source 'clone' of AOL's Instant Messenger client
@@ -28,7 +21,7 @@ USE_PERL5= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-static=yes --enable-nss=no
+CONFIGURE_ARGS= --enable-static=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
@@ -36,6 +29,10 @@ MAN1= gaim.1 gaim-remote.1
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libnss3.so)
+WITH_NSS= yes
+.endif
+
.if exists(${LOCALBASE}/lib/libgnutls.so)
WITH_GNUTLS= yes
.endif
@@ -46,6 +43,16 @@ LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
CONFIGURE_ARGS+= --disable-gnutls
.endif
+.if defined(WITH_NSS)
+LIB_DEPENDS+= nss3:${PORTSDIR}/security/nss
+CONFIGURE_ARGS+= --with-nspr-includes=${LOCALBASE}/include/nspr \
+ --with-nspr-libs=${LOCALBASE}/lib \
+ --with-nss-includes=${LOCALBASE}/include/nss/nss \
+ --with-nss-libs=${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+= --enable-nss=no
+.endif
+
.if ${PERL_LEVEL} < 500800
CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= PERL:="@comment "
@@ -87,7 +94,7 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
@${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
@${ECHO_MSG} " WITH_GNUTLS Enable TLS encryption support"
- @${ECHO_MSG} " WITH_JPPATCH Enable Japanese character support"
+ @${ECHO_MSG} " WITH_NSS Enable Mozilla NSS encryption support"
@${ECHO_MSG} " TCL_VER Use Tcl/Tk (version)"
@${ECHO_MSG} ""
diff --git a/net-im/gaim/distinfo b/net-im/gaim/distinfo
index bcc3bb13c32b..d3fc23a1bea8 100644
--- a/net-im/gaim/distinfo
+++ b/net-im/gaim/distinfo
@@ -1,2 +1 @@
-MD5 (gaim-0.70.tar.bz2) = 13ea95aa040ac5a58c3384709e495329
-MD5 (gaim-0.70_jp.patch.gz) = 4bc71e35202426870bf37aaf9ee054bf
+MD5 (gaim-0.71.tar.bz2) = 89d1aeabdfcb16df479031b08ad5fb99
diff --git a/net-im/gaim/files/patch-configure b/net-im/gaim/files/patch-configure
index b00f81cb44f4..7ae55f0c90bd 100644
--- a/net-im/gaim/files/patch-configure
+++ b/net-im/gaim/files/patch-configure
@@ -1,11 +1,24 @@
---- configure.orig Mon Sep 29 12:41:50 2003
-+++ configure Mon Sep 29 12:43:14 2003
-@@ -15962,7 +15962,7 @@
+--- configure.orig Thu Oct 9 20:05:15 2003
++++ configure Fri Oct 10 13:22:18 2003
+@@ -16164,7 +16164,7 @@
- if test "x$prefix" != "xNONE"; then
- prefix=`eval echo $prefix`
-- PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=$prefix"
-+ PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=%%LOCALBASE%%"
- fi
+ if test "x$prefix" != "xNONE"; then
+ prefix=`eval echo $prefix`
+- PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=$prefix"
++ PERL_MM_PARAMS="INSTALLDIRS=vendor PREFIX=%%LOCALBASE%%"
+ fi
+@@ -16915,10 +16915,10 @@
+
+ enable_nss="no"
+ else
+- nsprlibs="-ldl $with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
++ nsprlibs="$with_nspr_libs/libplc4.a $with_nspr_libs/libplds4.a $with_nspr_libs/libnspr4.a $PTHREAD_LIB"
+ fi
+ else
+- nsprlibs="-ldl -lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
++ nsprlibs="-lplc4 -lplds4 -lnspr4 $PTHREAD_LIB"
+ fi
+
+ echo "$as_me:$LINENO: checking for Mozilla nspr libraries" >&5
diff --git a/net-im/gaim/files/patch-src::protocols::oscar.c b/net-im/gaim/files/patch-src::protocols::oscar.c
index 308431d99239..17c6017ccaed 100644
--- a/net-im/gaim/files/patch-src::protocols::oscar.c
+++ b/net-im/gaim/files/patch-src::protocols::oscar.c
@@ -1,19 +1,19 @@
---- src/protocols/oscar/oscar.c.orig Thu Oct 2 15:40:55 2003
-+++ src/protocols/oscar/oscar.c Thu Oct 2 15:59:38 2003
-@@ -5462,11 +5462,11 @@
- free(tstr);
+--- src/protocols/oscar/oscar.c.orig Sat Oct 11 00:10:06 2003
++++ src/protocols/oscar/oscar.c Sat Oct 11 00:13:51 2003
+@@ -5391,11 +5391,11 @@
+ }
- if (bi->ipaddr) {
-- char *tstr = g_strdup_printf("%hhd.%hhd.%hhd.%hhd",
-- (bi->ipaddr & 0xff000000) >> 24,
-- (bi->ipaddr & 0x00ff0000) >> 16,
-- (bi->ipaddr & 0x0000ff00) >> 8,
-- (bi->ipaddr & 0x000000ff));
-+ char *tstr = g_strdup_printf("%hhu.%hhu.%hhu.%hhu",
-+ (char)(bi->ipaddr >> 24),
-+ (char)(bi->ipaddr >> 16),
-+ (char)(bi->ipaddr >> 8),
-+ (char)bi->ipaddr);
- tmp = yay;
- yay = g_strconcat(tmp, _("<b>IP Address:</b> "), tstr, "\n", NULL);
- free(tmp);
+ if ((bi != NULL) && (bi->ipaddr)) {
+- char *tstr = g_strdup_printf("%hhd.%hhd.%hhd.%hhd",
+- (bi->ipaddr & 0xff000000) >> 24,
+- (bi->ipaddr & 0x00ff0000) >> 16,
+- (bi->ipaddr & 0x0000ff00) >> 8,
+- (bi->ipaddr & 0x000000ff));
++ char *tstr = g_strdup_printf("%hhu.%hhu.%hhu.%hhu",
++ (char)(bi->ipaddr >> 24),
++ (char)(bi->ipaddr >> 16),
++ (char)(bi->ipaddr >> 8),
++ (char)bi->ipaddr);
+ tmp = ret;
+ ret = g_strconcat(tmp, _("<b>IP Address:</b> "), tstr, "\n", NULL);
+ g_free(tmp);
diff --git a/net-im/gaim/pkg-plist b/net-im/gaim/pkg-plist
index 491564ddf6c2..b6a84c4127f2 100644
--- a/net-im/gaim/pkg-plist
+++ b/net-im/gaim/pkg-plist
@@ -20,6 +20,9 @@ lib/gaim/libyahoo.so
lib/gaim/libzephyr.so
lib/gaim/notify.so
lib/gaim/spellchk.so
+lib/gaim/ssl-gnutls.so
+lib/gaim/ssl-nss.so
+lib/gaim/ssl.so
lib/gaim/statenotify.so
%%TCL:%%lib/gaim/tcl.so
lib/gaim/ticker.so