aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-26 20:24:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-26 20:24:27 +0000
commit6d624d9479b97d0b76dff02675889628519bf7ce (patch)
tree9ff368d36454c214b0307ee9d6f0a08ca60ec891 /net-im
parenta938f268e73a1f5f02321cc0a795a516ffd66a27 (diff)
downloadports-6d624d9479b97d0b76dff02675889628519bf7ce.tar.gz
ports-6d624d9479b97d0b76dff02675889628519bf7ce.zip
* Add optional GnuTLS support
* Add optional Tcl support PR: 57262 Submitted by: mi (based on)
Notes
Notes: svn path=/head/; revision=89478
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Makefile41
-rw-r--r--net-im/gaim/pkg-plist1
2 files changed, 36 insertions, 6 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
index 0a2dd3e60b00..e389e77ce9b0 100644
--- a/net-im/gaim/Makefile
+++ b/net-im/gaim/Makefile
@@ -34,6 +34,16 @@ MAN1= gaim.1 gaim-remote.1
.include <bsd.port.pre.mk>
+.if exists(${LOCALBASE}/lib/libgnutls.so)
+WITH_GNUTLS= yes
+.endif
+
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.else
+CONFIGURE_ARGS+= --disable-gnutls
+.endif
+
.if ${PERL_LEVEL} < 500800
CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= PERL:="@comment "
@@ -47,6 +57,21 @@ LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
CONFIGURE_ARGS+= --disable-gtkspell
.endif
+.if defined(TCL_VER)
+_TCL_DVER= ${TCL_VER:S/.//}
+_TCL_VER= ${_TCL_DVER:C/(.)/\1./}
+.if ${_TCL_VER} != 8.3
+. error Currently GAIM can only use Tcl/Tk 8.3
+.endif
+LIB_DEPENDS+= tk${_TCL_DVER}:${PORTSDIR}/x11-toolkits/tk${_TCL_DVER}
+CONFIGURE_ARGS+=--with-tclconfig=${LOCALBASE}/lib/tcl${_TCL_VER} \
+ --with-tkconfig=${LOCALBASE}/lib/tk${_TCL_VER}
+CFLAGS+= -I${LOCALBASE}/include/tk${_TCL_VER} -I${LOCALBASE}/include/tcl${_TCL_VER}
+PLIST_SUB+= TCL:=""
+.else
+PLIST_SUB+= TCL:="@comment "
+.endif
+
.ifndef(WITHOUT_AUDIO)
LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao \
audiofile.0:${PORTSDIR}/audio/libaudiofile
@@ -57,14 +82,18 @@ CONFIGURE_ARGS+= --disable-audio
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Gaim has the following tunable option(s):"
- @${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
- @${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
+ @${ECHO_MSG} " WITHOUT_GTKSPELL Turns off spell checking"
+ @${ECHO_MSG} " WITHOUT_AUDIO Disable audio support"
+ @${ECHO_MSG} " WITH_GNUTLS Enable TLS encryption support"
+ @${ECHO_MSG} " TCL_VER Use Tcl/Tk (version)"
@${ECHO_MSG} ""
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthreads|${PTHREAD_LIBS:S/"//g}|g; \
- s|-lpthread|${PTHREAD_LIBS:S/"//g}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-lpthreads|${PTHREAD_LIBS:S/"//g}|g' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g' \
+ -e 's|TCL_VERSION found but 8.3 required|TCL_VERSION found but ${_TCL_VER} required|g' \
+ -e 's|TCL_MINOR_VERSION" -ne 3|TCL_MINOR_VERSION" -ne ${_TCL_VER:E}|' \
+ ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/net-im/gaim/pkg-plist b/net-im/gaim/pkg-plist
index 077c2c7bbced..491564ddf6c2 100644
--- a/net-im/gaim/pkg-plist
+++ b/net-im/gaim/pkg-plist
@@ -21,6 +21,7 @@ lib/gaim/libzephyr.so
lib/gaim/notify.so
lib/gaim/spellchk.so
lib/gaim/statenotify.so
+%%TCL:%%lib/gaim/tcl.so
lib/gaim/ticker.so
lib/gaim/timestamp.so
lib/libgaim-remote.a