aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-10-10 12:59:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-10-10 12:59:36 +0000
commit744ecfac3352a5a89c9b0731e7782ef6aa337244 (patch)
tree066489f219d8ac0b5e6eb955366a5d1dd8bb53a7 /net-im
parent3e9a36d879aec1af280d740a5090d0a51d99b062 (diff)
downloadports-744ecfac3352a5a89c9b0731e7782ef6aa337244.tar.gz
ports-744ecfac3352a5a89c9b0731e7782ef6aa337244.zip
CC, CXX, CFLAGS, PTHREAD_CFLAGS and PTHREAD_LIBS may contain `/' in
them when using a non-default compiler/linker, so do not use `/' as delimiter for s///. (I picked `|' instead)
Notes
Notes: svn path=/head/; revision=67737
Diffstat (limited to 'net-im')
-rw-r--r--net-im/konverse/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-im/konverse/Makefile b/net-im/konverse/Makefile
index 1b42f0d44ceb..36d6283801b3 100644
--- a/net-im/konverse/Makefile
+++ b/net-im/konverse/Makefile
@@ -25,10 +25,10 @@ CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
--with-qt-libraries=${QT_PREFIX}/lib
pre-patch:
- ${REINPLACE_CMD} -e 's/-lqt/-lqt-mt '${PTHREAD_LIBS}'/' \
+ ${REINPLACE_CMD} -e 's|-lqt|-lqt-mt ${PTHREAD_LIBS}|' \
-e 's/libqt\.\*/libqt-mt.*/' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's/\(LDADD.*\)-ldl/\1/' \
- -e 's/-lqt/'${PTHREAD_LIBS}'/' ${WRKSRC}/konverse/Makefile.in
+ -e 's|-lqt|${PTHREAD_LIBS}|' ${WRKSRC}/konverse/Makefile.in
${REINPLACE_CMD} -e 's/\(QDateTime.*\)timezone/\1local-\>tm_gmtoff/g' \
${WRKSRC}/konverse/jabbercore.cpp
.for f in konverse/rostertree.h konverse/dlgchat.h