aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2015-10-23 17:19:35 +0000
committerKris Moore <kmoore@FreeBSD.org>2015-10-23 17:19:35 +0000
commit6f930a4ab101c7dda64b6a13c1e06d59a535a9db (patch)
treeb65639ed9a26c962d70af9733c3253134b68b156 /net-im
parenta9911a9e23c2518e58d092cd8c0512f22a1394c8 (diff)
downloadports-6f930a4ab101c7dda64b6a13c1e06d59a535a9db.tar.gz
ports-6f930a4ab101c7dda64b6a13c1e06d59a535a9db.zip
TeamWords is unofficial cross-platform desktop client for Slack.
Notes
Notes: svn path=/head/; revision=400040
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/teamwords/Makefile38
-rw-r--r--net-im/teamwords/distinfo2
-rw-r--r--net-im/teamwords/files/teamwords.desktop.in11
-rw-r--r--net-im/teamwords/pkg-descr3
5 files changed, 55 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 2065e6d1d0cc..13539a6ac9d2 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -156,6 +156,7 @@
SUBDIR += skype
SUBDIR += skype-devel
SUBDIR += skype4
+ SUBDIR += teamwords
SUBDIR += telegram
SUBDIR += telegram-purple
SUBDIR += telepathy-butterfly
diff --git a/net-im/teamwords/Makefile b/net-im/teamwords/Makefile
new file mode 100644
index 000000000000..9bd67073418b
--- /dev/null
+++ b/net-im/teamwords/Makefile
@@ -0,0 +1,38 @@
+# Created by: Kris Moore <kmoore@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= teamwords
+PORTVERSION= 0.2.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net-im
+
+MAINTAINER= kmoore@FreeBSD.org
+COMMENT= Unofficial Qt Slack client
+
+LICENSE= LGPL3
+
+USE_LDCONFIG= yes
+USE_QT5= core gui network svg linguist \
+ buildtools x11extras
+USES= qmake tar:xz
+
+QMAKE_ARGS= CONFIG+="configure"
+
+USE_GITHUB= yes
+GH_ACCOUNT= MiT-Ufa
+GH_PROJECT= TeamWords
+PLIST_FILES= bin/teamwords \
+ share/applications/teamwords.desktop \
+ share/icons/teamwords.png
+SUB_FILES= teamwords.desktop
+
+.include <bsd.port.options.mk>
+
+do-install:
+ ${STRIP_CMD} ${WRKSRC}/teamwords
+ ${INSTALL} ${WRKSRC}/teamwords ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/${SUB_FILES} ${STAGEDIR}${PREFIX}/share/applications/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
+ ${INSTALL_DATA} ${WRKSRC}/images/png/Slack.png ${STAGEDIR}${PREFIX}/share/icons/teamwords.png
+
+.include <bsd.port.mk>
diff --git a/net-im/teamwords/distinfo b/net-im/teamwords/distinfo
new file mode 100644
index 000000000000..dccba636993e
--- /dev/null
+++ b/net-im/teamwords/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MiT-Ufa-TeamWords-v0.2.1_GH0.tar.xz) = d079cf46f254a159f2a6a7405eddfb38a0e27866285f93ff41c97662dcc193a7
+SIZE (MiT-Ufa-TeamWords-v0.2.1_GH0.tar.xz) = 3349113
diff --git a/net-im/teamwords/files/teamwords.desktop.in b/net-im/teamwords/files/teamwords.desktop.in
new file mode 100644
index 000000000000..4fb0267cc75a
--- /dev/null
+++ b/net-im/teamwords/files/teamwords.desktop.in
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=TeamWords
+GenericName=Slack Client
+Comment=A simple Qt5 based Slack Client
+Exec=%%PREFIX%%/bin/teamwords
+Icon=%%PREFIX%%/share/icons/teamwords.png
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-im/teamwords/pkg-descr b/net-im/teamwords/pkg-descr
new file mode 100644
index 000000000000..6c18b978e709
--- /dev/null
+++ b/net-im/teamwords/pkg-descr
@@ -0,0 +1,3 @@
+TeamWords is unofficial cross-platform desktop client for Slack.
+
+WWW: https://github.com/MiT-Ufa/TeamWords