aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2015-11-21 15:04:37 +0000
committerMartin Matuska <mm@FreeBSD.org>2015-11-21 15:04:37 +0000
commit75d3977da53b4803c30d4b4614a896a8eecedabc (patch)
treef04190173f352ea8da1a8a91d0f9ebedccea966f /net-im
parent08260f4eba076bf69e2e354c18ac4634754d8949 (diff)
downloadports-75d3977da53b4803c30d4b4614a896a8eecedabc.tar.gz
ports-75d3977da53b4803c30d4b4614a896a8eecedabc.zip
Always depend on gsasl and remove old commented options
Notes
Notes: svn path=/head/; revision=402162
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jabberd/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 3c6c39fbaa42..d4cc5e434f0a 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -13,12 +13,13 @@ COMMENT= Online presence and instant messaging server
LICENSE= GPLv2
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libgsasl.so:${PORTSDIR}/security/gsasl \
libidn.so:${PORTSDIR}/dns/libidn \
libudns.so:${PORTSDIR}/dns/udns
OPTIONS_DEFINE= MYSQL PGSQL LDAP BDB SQLITE PAM PIPE ANON FS DEBUG REQUIRES \
- DOCS SUPERSEDED EXPERIMENTAL GSASL
-OPTIONS_DEFAULT=MYSQL DEBUG GSASL
+ DOCS SUPERSEDED EXPERIMENTAL
+OPTIONS_DEFAULT=MYSQL DEBUG
OPTIONS_SUB= yes
GNU_CONFIGURE= yes
@@ -32,6 +33,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--sysconfdir=${PREFIX}/etc/jabberd \
--enable-ssl --enable-mio=kqueue \
--disable-tests \
+ --with-sasl=gsasl \
--with-extra-include-path="${LOCALBASE}/include ${EIP}" \
--with-extra-library-path="${LOCALBASE}/lib ${ELP}"
@@ -92,14 +94,6 @@ PIPE_DESC= Enable pipe (auth/reg)
ANON_CONFIGURE_ENABLE= anon
ANON_DESC= Enable anonymous (auth/reg)
-#CYRUS_CONFIGURE_ON= --with-sasl=cyrus
-#CYRUS_DESC= Use Cyrus SASL backend (not supported)
-#CYRUS_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
-
-GSASL_CONFIGURE_ON= --with-sasl=gsasl
-GSASL_DESC= Use GSASL backend
-GSASL_LIB_DEPENDS= libgsasl.so:${PORTSDIR}/security/gsasl
-
SUPERSEDED_CONFIGURE_ENABLE= superseded
SUPERSEDED_DESC= Enable superseded features (ns_TIME)