aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-21 07:27:25 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-21 07:27:25 +0000
commit0809873ca550139f07d8054918cb3503d62d2268 (patch)
tree430ed42521f0f89655952eb216b83310ba5b560a /net-im
parent1e4be5a0de04a1690adb96a89878524dfdaf7540 (diff)
downloadports-0809873ca550139f07d8054918cb3503d62d2268.tar.gz
ports-0809873ca550139f07d8054918cb3503d62d2268.zip
add ickle
ICQ2000 protocol implementation
Notes
Notes: svn path=/head/; revision=50322
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ickle/Makefile25
-rw-r--r--net-im/ickle/distinfo1
-rw-r--r--net-im/ickle/pkg-comment1
-rw-r--r--net-im/ickle/pkg-descr4
-rw-r--r--net-im/ickle/pkg-plist18
5 files changed, 49 insertions, 0 deletions
diff --git a/net-im/ickle/Makefile b/net-im/ickle/Makefile
new file mode 100644
index 000000000000..419a5c5029ec
--- /dev/null
+++ b/net-im/ickle/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: ickle
+# Date created: Nov 21, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ickle
+PORTVERSION= 0.1.2
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gtkmm:${PORTSDIR}/x11-toolkits/gtk--
+
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-sigc-prefix=${LOCALBASE} \
+ --with-gtkmm-prefix=${X11BASE}
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/ickle/distinfo b/net-im/ickle/distinfo
new file mode 100644
index 000000000000..e2058ae11de7
--- /dev/null
+++ b/net-im/ickle/distinfo
@@ -0,0 +1 @@
+MD5 (ickle-0.1.2.tar.gz) = 47d11c90e4b7ba9fbae3e5fe954932ba
diff --git a/net-im/ickle/pkg-comment b/net-im/ickle/pkg-comment
new file mode 100644
index 000000000000..6e5a9541da27
--- /dev/null
+++ b/net-im/ickle/pkg-comment
@@ -0,0 +1 @@
+ICQ2000 protocol implementation
diff --git a/net-im/ickle/pkg-descr b/net-im/ickle/pkg-descr
new file mode 100644
index 000000000000..96484c547d9e
--- /dev/null
+++ b/net-im/ickle/pkg-descr
@@ -0,0 +1,4 @@
+ickle is an open-source project implementing the ICQ2000 protocol. The aim
+is to bring the most useful features of ICQ2000 to non-windows platforms.
+
+WWW: http://ickle.sourceforge.net/
diff --git a/net-im/ickle/pkg-plist b/net-im/ickle/pkg-plist
new file mode 100644
index 000000000000..851b6845d452
--- /dev/null
+++ b/net-im/ickle/pkg-plist
@@ -0,0 +1,18 @@
+bin/ickle
+include/ickle/Client.h
+include/ickle/Contact.h
+include/ickle/ContactList.h
+include/ickle/SNAC.h
+include/ickle/TLV.h
+include/ickle/Xml.h
+include/ickle/buffer.h
+include/ickle/constants.h
+include/ickle/custom_marshal.h
+include/ickle/events.h
+include/ickle/exceptions.h
+include/ickle/socket.h
+lib/libicq2000.a
+lib/libicq2000.la
+lib/libicq2000.so
+lib/libicq2000.so.1
+@dirrm include/ickle