aboutsummaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>1998-06-28 03:22:37 +0000
committerMatthew Hunt <mph@FreeBSD.org>1998-06-28 03:22:37 +0000
commit79885184cf1c1c599a5eca52dc04617472c3a4e1 (patch)
tree46e9e89ee8f40388f4602f54e82d5c06dd8c0140 /net-im
parent838583705214c5c9054dda76aa18ff053267c104 (diff)
downloadports-79885184cf1c1c599a5eca52dc04617472c3a4e1.tar.gz
ports-79885184cf1c1c599a5eca52dc04617472c3a4e1.zip
Import of micq (26 June 1998), a free implementation of the ICQ
protocol. It is currently a partial implementation, and has a text interface only. As far as I can tell, Mirabilis' software is necessary to register with the ICQ network, so I could not test its functionality.
Notes
Notes: svn path=/head/; revision=11568
Diffstat (limited to 'net-im')
-rw-r--r--net-im/climm/Makefile28
-rw-r--r--net-im/climm/distinfo1
-rw-r--r--net-im/climm/files/patch-aa13
-rw-r--r--net-im/climm/pkg-comment1
-rw-r--r--net-im/climm/pkg-descr4
-rw-r--r--net-im/climm/pkg-plist6
-rw-r--r--net-im/micq/Makefile28
-rw-r--r--net-im/micq/distinfo1
-rw-r--r--net-im/micq/files/patch-aa13
-rw-r--r--net-im/micq/pkg-comment1
-rw-r--r--net-im/micq/pkg-descr4
-rw-r--r--net-im/micq/pkg-plist6
12 files changed, 106 insertions, 0 deletions
diff --git a/net-im/climm/Makefile b/net-im/climm/Makefile
new file mode 100644
index 000000000000..a7810d16f48e
--- /dev/null
+++ b/net-im/climm/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: micq
+# Version required: 26 June 1998
+# Date created: 27 June 1998
+# Whom: mph
+#
+# $Id$
+#
+
+DISTNAME= micq
+PKGNAME= micq-19980626
+CATEGORIES= net
+MASTER_SITES= ftp://micq.ml.org/pub/micq/Jun-26-98/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mph@freebsd.org
+
+WRKSRC= ${WRKDIR}/micq-0626-98
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/micq ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/micq
+.for file in README TODO WISHLIST commands.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/micq
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/climm/distinfo b/net-im/climm/distinfo
new file mode 100644
index 000000000000..2ac6c7955d02
--- /dev/null
+++ b/net-im/climm/distinfo
@@ -0,0 +1 @@
+MD5 (micq.tgz) = b4167097bd3e106537cda136cf972f35
diff --git a/net-im/climm/files/patch-aa b/net-im/climm/files/patch-aa
new file mode 100644
index 000000000000..88df1785536b
--- /dev/null
+++ b/net-im/climm/files/patch-aa
@@ -0,0 +1,13 @@
+--- Makefile.orig Sat Jun 27 13:25:53 1998
++++ Makefile Sat Jun 27 13:26:38 1998
+@@ -1,8 +1,8 @@
+ # Anyone who knows how to make Makefiles please help out.
+ # I have no clue but this appears to work fairly well
+ # be sure to use gmake
+-CC = gcc
+-CFLAGS = -Wall -DUNIX
++# CC = gcc
++CFLAGS += -DUNIX
+ # Uncomment the below line for humorous messages
+ #CFLAGS += -DFUNNY_MSGS
+ # uncomment the line below for debuging info
diff --git a/net-im/climm/pkg-comment b/net-im/climm/pkg-comment
new file mode 100644
index 000000000000..3b126f620404
--- /dev/null
+++ b/net-im/climm/pkg-comment
@@ -0,0 +1 @@
+Text-based ICQ implementation.
diff --git a/net-im/climm/pkg-descr b/net-im/climm/pkg-descr
new file mode 100644
index 000000000000..cce4ef3c3ac5
--- /dev/null
+++ b/net-im/climm/pkg-descr
@@ -0,0 +1,4 @@
+A text-based implementation of ICQ, independant of Mirabilis.
+Currently does not offer chat. Still appears rough: There's no
+command-line editing, and ANSI color codes are hardcoded in the
+program.
diff --git a/net-im/climm/pkg-plist b/net-im/climm/pkg-plist
new file mode 100644
index 000000000000..d35fab5efd8b
--- /dev/null
+++ b/net-im/climm/pkg-plist
@@ -0,0 +1,6 @@
+bin/micq
+share/doc/micq/README
+share/doc/micq/TODO
+share/doc/micq/WISHLIST
+share/doc/micq/commands.txt
+@dirrm share/doc/micq
diff --git a/net-im/micq/Makefile b/net-im/micq/Makefile
new file mode 100644
index 000000000000..a7810d16f48e
--- /dev/null
+++ b/net-im/micq/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: micq
+# Version required: 26 June 1998
+# Date created: 27 June 1998
+# Whom: mph
+#
+# $Id$
+#
+
+DISTNAME= micq
+PKGNAME= micq-19980626
+CATEGORIES= net
+MASTER_SITES= ftp://micq.ml.org/pub/micq/Jun-26-98/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mph@freebsd.org
+
+WRKSRC= ${WRKDIR}/micq-0626-98
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/micq ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/micq
+.for file in README TODO WISHLIST commands.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/micq
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/micq/distinfo b/net-im/micq/distinfo
new file mode 100644
index 000000000000..2ac6c7955d02
--- /dev/null
+++ b/net-im/micq/distinfo
@@ -0,0 +1 @@
+MD5 (micq.tgz) = b4167097bd3e106537cda136cf972f35
diff --git a/net-im/micq/files/patch-aa b/net-im/micq/files/patch-aa
new file mode 100644
index 000000000000..88df1785536b
--- /dev/null
+++ b/net-im/micq/files/patch-aa
@@ -0,0 +1,13 @@
+--- Makefile.orig Sat Jun 27 13:25:53 1998
++++ Makefile Sat Jun 27 13:26:38 1998
+@@ -1,8 +1,8 @@
+ # Anyone who knows how to make Makefiles please help out.
+ # I have no clue but this appears to work fairly well
+ # be sure to use gmake
+-CC = gcc
+-CFLAGS = -Wall -DUNIX
++# CC = gcc
++CFLAGS += -DUNIX
+ # Uncomment the below line for humorous messages
+ #CFLAGS += -DFUNNY_MSGS
+ # uncomment the line below for debuging info
diff --git a/net-im/micq/pkg-comment b/net-im/micq/pkg-comment
new file mode 100644
index 000000000000..3b126f620404
--- /dev/null
+++ b/net-im/micq/pkg-comment
@@ -0,0 +1 @@
+Text-based ICQ implementation.
diff --git a/net-im/micq/pkg-descr b/net-im/micq/pkg-descr
new file mode 100644
index 000000000000..cce4ef3c3ac5
--- /dev/null
+++ b/net-im/micq/pkg-descr
@@ -0,0 +1,4 @@
+A text-based implementation of ICQ, independant of Mirabilis.
+Currently does not offer chat. Still appears rough: There's no
+command-line editing, and ANSI color codes are hardcoded in the
+program.
diff --git a/net-im/micq/pkg-plist b/net-im/micq/pkg-plist
new file mode 100644
index 000000000000..d35fab5efd8b
--- /dev/null
+++ b/net-im/micq/pkg-plist
@@ -0,0 +1,6 @@
+bin/micq
+share/doc/micq/README
+share/doc/micq/TODO
+share/doc/micq/WISHLIST
+share/doc/micq/commands.txt
+@dirrm share/doc/micq