aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/NeTraMet/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2001-02-26 11:16:35 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2001-02-26 11:16:35 +0000
commit9d1cfbf70caa49fd984268a013351bcfc97c4929 (patch)
treee902b73ef8a7c105d31a370300f57e6597819c7d /net-mgmt/NeTraMet/Makefile
parente27be0e14ff8f2131933a8bfe5767aa38882bcf7 (diff)
downloadports-9d1cfbf70caa49fd984268a013351bcfc97c4929.tar.gz
ports-9d1cfbf70caa49fd984268a013351bcfc97c4929.zip
Add new port: net/NeTraMet.
PR: 25330 Submitted by: olgeni
Notes
Notes: svn path=/head/; revision=38784
Diffstat (limited to 'net-mgmt/NeTraMet/Makefile')
-rw-r--r--net-mgmt/NeTraMet/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-mgmt/NeTraMet/Makefile b/net-mgmt/NeTraMet/Makefile
new file mode 100644
index 000000000000..892b8fc72f7b
--- /dev/null
+++ b/net-mgmt/NeTraMet/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: NeTraMet
+# Date created: 24-Feb-2001
+# Whom: Jimmy Olgeni <olgeni@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NeTraMet
+PORTVERSION= 4.3
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.gla.ac.uk/pub/software/NeTraMet/
+DISTNAME= NeTraMet${PORTVERSION:S/.//}
+
+MAINTAINER= olgeni@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/NeTraMet${PORTVERSION:S/.//}
+
+USE_AUTOCONF= yes
+USE_GMAKE= yes
+
+.if defined(WITH_MOTIF)
+USE_MOTIF= yes
+CONFIGURE_ENV+= MOTIF_LIB="${MOTIFLIB}"
+PLIST_SUB= MOTIF=""
+.else
+PLIST_SUB= MOTIF="@comment "
+.endif
+
+post-patch:
+ ${PERL} -pi -e "s|"/etc/mib.txt"|${LOCALBASE}/share/NeTraMet/mibs/mib.txt|g;" ${WRKSRC}/src/snmplib/mib.c
+
+.include <bsd.port.mk>