aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/aggregate
diff options
context:
space:
mode:
authorDmitry Morozovsky <marck@FreeBSD.org>2009-02-23 12:17:08 +0000
committerDmitry Morozovsky <marck@FreeBSD.org>2009-02-23 12:17:08 +0000
commit277b37ae5434c34a30f79cfcda4b0dca69c00899 (patch)
treea609bfbfdd6b2c22d6d175f1e4331239c90ed2aa /net-mgmt/aggregate
parent6825d94346e9fd20d42373ba78243ea66e224220 (diff)
downloadports-277b37ae5434c34a30f79cfcda4b0dca69c00899.tar.gz
ports-277b37ae5434c34a30f79cfcda4b0dca69c00899.zip
Fix simultaneous use of -t and -p options.
While I'm here, get rid of simple pkg-plist, and remove stale distsite. Also, make portlint -C happy. PR: 131259 Approved by: maintainer timeout (3 weeks)
Notes
Notes: svn path=/head/; revision=228892
Diffstat (limited to 'net-mgmt/aggregate')
-rw-r--r--net-mgmt/aggregate/Makefile8
-rw-r--r--net-mgmt/aggregate/files/patch-aggregate.c24
-rw-r--r--net-mgmt/aggregate/pkg-plist2
3 files changed, 29 insertions, 5 deletions
diff --git a/net-mgmt/aggregate/Makefile b/net-mgmt/aggregate/Makefile
index 27fc8489d642..384c3e0c57f9 100644
--- a/net-mgmt/aggregate/Makefile
+++ b/net-mgmt/aggregate/Makefile
@@ -7,15 +7,17 @@
PORTNAME= aggregate
PORTVERSION= 1.6
+PORTREVISION= 1
CATEGORIES= net-mgmt
-MASTER_SITES= ftp://ftp.isc.org/isc/aggregate/ \
- http://software.automagic.org/aggregate/
+MASTER_SITES= ${MASTER_SITE_ISC}
+MASTER_SITE_SUBDIR= aggregate
MAINTAINER= jabley@automagic.org
COMMENT= Optimise a list of route prefixes to help make nice short filters
GNU_CONFIGURE= yes
-MAN1= aggregate.1 aggregate-ios.1
+PLIST_FILES= bin/aggregate bin/aggregate-ios
+MAN1= aggregate.1 aggregate-ios.1
.include <bsd.port.mk>
diff --git a/net-mgmt/aggregate/files/patch-aggregate.c b/net-mgmt/aggregate/files/patch-aggregate.c
new file mode 100644
index 000000000000..03fddbfbba08
--- /dev/null
+++ b/net-mgmt/aggregate/files/patch-aggregate.c
@@ -0,0 +1,24 @@
+Index: aggregate.c
+===================================================================
+--- aggregate.c (revision 919)
++++ aggregate.c (working copy)
+@@ -261,8 +261,18 @@
+ moanf(0, "[line %d] line too long; ignoring line", line);
+ continue;
+ }
++ if (buf[i] == '/') {
++ masklen = atoi(buf + i + 1);
++ if (masklen < 1 || masklen > max_prefix_length)
++ {
++ if (!quiet)
++ moanf(0, "[line %d] mask length %d out of range; ignoring line", \
++ line, masklen);
++ continue;
++ }
++ } else
++ masklen = default_prefix_length;
+ buf[i] = 0;
+- masklen = default_prefix_length;
+ } else {
+ i = 0;
+ while (buf[i] != '/' && i < MAX_buf) i++;
diff --git a/net-mgmt/aggregate/pkg-plist b/net-mgmt/aggregate/pkg-plist
deleted file mode 100644
index c64c92d4a007..000000000000
--- a/net-mgmt/aggregate/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/aggregate
-bin/aggregate-ios