aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/airport
diff options
context:
space:
mode:
authorNick Sayer <nsayer@FreeBSD.org>2001-05-04 23:39:47 +0000
committerNick Sayer <nsayer@FreeBSD.org>2001-05-04 23:39:47 +0000
commitdd2d5258d0476fd721847f3dcadd59be14659295 (patch)
tree4c60abb85fcdb8197a36db4a27eab1586bb93215 /net-mgmt/airport
parent33b31b6d5ec267822bbb7a0176b3521df8128819 (diff)
downloadports-dd2d5258d0476fd721847f3dcadd59be14659295.tar.gz
ports-dd2d5258d0476fd721847f3dcadd59be14659295.zip
Take a hint from the mindterm port -- JAR files go in
share/java. Everything else in share/doc. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=42264
Diffstat (limited to 'net-mgmt/airport')
-rw-r--r--net-mgmt/airport/Makefile9
-rw-r--r--net-mgmt/airport/files/airport4
-rw-r--r--net-mgmt/airport/pkg-plist17
3 files changed, 18 insertions, 12 deletions
diff --git a/net-mgmt/airport/Makefile b/net-mgmt/airport/Makefile
index c6f4f0040da1..ffb6585bcfa9 100644
--- a/net-mgmt/airport/Makefile
+++ b/net-mgmt/airport/Makefile
@@ -7,6 +7,7 @@
PORTNAME= airport
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= net java
MASTER_SITES= http://edge.mcs.drexel.edu/GICL/people/sevy/airport/
DISTFILES= configurator_${PORTVERSION:S/.//}${EXTRACT_SUFX}
@@ -30,8 +31,12 @@ NO_BUILD= yes
do-install:
@cd ${WRKSRC}; \
- ${MKDIR} ${PREFIX}/share/airport; \
- ${CP} -r ${WRKSRC}/* ${PREFIX}/share/airport; \
+ ${MKDIR} ${PREFIX}/share/doc/airport/helpdocs; \
+ ${MKDIR} ${PREFIX}/share/java; \
+ ${INSTALL_DATA} ${WRKSRC}/*jar ${PREFIX}/share/java; \
+ ${CP} ${WRKSRC}/AUTHORS ${PREFIX}/share/doc/airport; \
+ ${CP} ${WRKSRC}/COPYING ${PREFIX}/share/doc/airport; \
+ ${CP} -r ${WRKSRC}/helpdocs/* ${PREFIX}/share/doc/airport/helpdocs; \
${SED} \
-e s,%%PREFIX%%,${PREFIX},g \
-e s/%%JFC_VERSION%%/${JFC_VERSION}/ \
diff --git a/net-mgmt/airport/files/airport b/net-mgmt/airport/files/airport
index 5c8303d602b7..2ae406c629cb 100644
--- a/net-mgmt/airport/files/airport
+++ b/net-mgmt/airport/files/airport
@@ -1,9 +1,9 @@
#! /bin/sh
# Use this one for JDK 1.2 and beyond:
-# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/airport/AirportBaseStationConfig.jar
+# exec %%PREFIX%%/bin/javavm -jar %%PREFIX%%/share/java/AirportBaseStationConfig.jar
# Use this one for the default installation -- JDK 1.1.x + JFC:
-exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/airport/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
+exec %%PREFIX%%/bin/javavm -classpath "%%PREFIX%%/jdk%%JDK_VERSION%%/lib/classes.zip:%%PREFIX%%/share/java/classes/jfc-%%JFC_VERSION%%/swingall.jar:%%PREFIX%%/share/java/AirportBaseStationConfig.jar" AirportBaseStationConfigurator
exit 1
diff --git a/net-mgmt/airport/pkg-plist b/net-mgmt/airport/pkg-plist
index 68fe8b4f540f..cbfeb33023f9 100644
--- a/net-mgmt/airport/pkg-plist
+++ b/net-mgmt/airport/pkg-plist
@@ -1,9 +1,10 @@
bin/airport
-share/airport/AUTHORS
-share/airport/COPYING
-share/airport/AirportBaseStationConfig.jar
-share/airport/helpdocs/ReadMe.txt
-share/airport/helpdocs/mainscreen.jpg
-share/airport/helpdocs/manual.html
-@dirrm share/airport/helpdocs
-@dirrm share/airport
+share/java/AirportBaseStationConfig.jar
+share/doc/airport/AUTHORS
+share/doc/airport/COPYING
+share/doc/airport/helpdocs/ReadMe.txt
+share/doc/airport/helpdocs/mainscreen.jpg
+share/doc/airport/helpdocs/manual.html
+@dirrm share/doc/airport/helpdocs
+@dirrm share/doc/airport
+@unexec rmdir %D/share/java || true