aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/arpwatch-devel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1998-07-02 10:45:36 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1998-07-02 10:45:36 +0000
commit8689fd50e9a40ea0f88009b0903200591bd914da (patch)
treeb54526d78cd74fcc0ea2ad15535d79b1908488f4 /net-mgmt/arpwatch-devel
parentfadd832d67d46014583759182f1151f58405cad3 (diff)
downloadports-8689fd50e9a40ea0f88009b0903200591bd914da.tar.gz
ports-8689fd50e9a40ea0f88009b0903200591bd914da.zip
Portlint and strip binary file.
Notes
Notes: svn path=/head/; revision=11665
Diffstat (limited to 'net-mgmt/arpwatch-devel')
-rw-r--r--net-mgmt/arpwatch-devel/Makefile19
-rw-r--r--net-mgmt/arpwatch-devel/files/patch-ab22
2 files changed, 31 insertions, 10 deletions
diff --git a/net-mgmt/arpwatch-devel/Makefile b/net-mgmt/arpwatch-devel/Makefile
index b7315e111c2c..eba00932e012 100644
--- a/net-mgmt/arpwatch-devel/Makefile
+++ b/net-mgmt/arpwatch-devel/Makefile
@@ -3,7 +3,7 @@
# Date created: March 24 1997
# Whom: Brian Somers <brian@awfulhak.org>
#
-# $Id: Makefile,v 1.6 1997/07/01 02:04:53 brian Exp $
+# $Id: Makefile,v 1.7 1997/08/01 05:34:03 obrien Exp $
#
DISTNAME= arpwatch-2.0.2
@@ -16,21 +16,20 @@ MAINTAINER= brian@awfulhak.org
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --quiet
-MAKE_FLAGS= CCOPT="-O2 -DPATH_SENDMAIL=\\\"/usr/sbin/sendmail\\\""
+MAKE_FLAGS= CCOPT="${CFLAGS} -DPATH_SENDMAIL=\\\"/usr/sbin/sendmail\\\""
INSTALL_TARGET= install install-man
MAN8= arpwatch.8 arpsnmp.8
-
post-install:
- if [ ! -d ${PREFIX}/arpwatch ]; then \
- ${MKDIR} ${PREFIX}/arpwatch; \
- chmod 775 ${PREFIX}/arpwatch; \
- /usr/sbin/chown root.operator ${PREFIX}/arpwatch; \
+ if [ ! -d ${PREFIX}/arpwatch ]; then \
+ ${MKDIR} ${PREFIX}/arpwatch; \
+ chmod 775 ${PREFIX}/arpwatch; \
+ chown root.operator ${PREFIX}/arpwatch; \
fi
- touch ${PREFIX}/arpwatch/arp.dat
+ ${TOUCH} ${PREFIX}/arpwatch/arp.dat
chmod 644 ${PREFIX}/arpwatch/arp.dat
- for file in ethercodes.dat d.awk e.awk p.awk; do \
- ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/arpwatch/.; \
+ for file in ethercodes.dat d.awk e.awk p.awk; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/arpwatch/.; \
done
${INSTALL_SCRIPT} ${WRKSRC}/arp2ethers ${PREFIX}/arpwatch/.
${INSTALL_SCRIPT} ${FILESDIR}/arpwatch.sh ${PREFIX}/etc/rc.d/.
diff --git a/net-mgmt/arpwatch-devel/files/patch-ab b/net-mgmt/arpwatch-devel/files/patch-ab
new file mode 100644
index 000000000000..11a6bd73b2a2
--- /dev/null
+++ b/net-mgmt/arpwatch-devel/files/patch-ab
@@ -0,0 +1,22 @@
+--- Makefile.in.orig Fri Apr 25 11:02:01 1997
++++ Makefile.in Wed Jul 1 17:47:52 1998
+@@ -44,7 +44,7 @@
+ CC = @CC@
+ CCOPT = @V_CCOPT@
+ INCLS = -I. @V_INCLS@
+-DEFS = -DDEBUG @DEFS@ -DARPDIR=\"$(ARPDIR)\"
++DEFS = @DEFS@ -DARPDIR=\"$(ARPDIR)\"
+
+ # Standard CFLAGS
+ CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
+@@ -109,8 +109,8 @@
+ $(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
+
+ install: force
+- $(INSTALL) -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
+- $(INSTALL) -m 555 -o bin -g bin arpsnmp $(DESTDIR)$(BINDEST)
++ $(INSTALL) -s -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
++ $(INSTALL) -s -m 555 -o bin -g bin arpsnmp $(DESTDIR)$(BINDEST)
+
+ install-man: force
+ $(INSTALL) -m 444 -o bin -g bin $(srcdir)/arpwatch.8 \