aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/bgpq
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-15 13:08:49 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-15 13:08:49 +0000
commit6ac61f9d07f955720581db912b358b1526269d7e (patch)
tree941e0acef4251250ecdfe2cf4e0d93b8e1ec03e4 /net-mgmt/bgpq
parentbbd73ace1fdd533678d64a562613abc3a395389a (diff)
downloadports-6ac61f9d07f955720581db912b358b1526269d7e.tar.gz
ports-6ac61f9d07f955720581db912b358b1526269d7e.zip
unbreak net/bpgq by adding \n\ to end of printf() statements.
Informed maintainer.
Notes
Notes: svn path=/head/; revision=91320
Diffstat (limited to 'net-mgmt/bgpq')
-rw-r--r--net-mgmt/bgpq/Makefile9
-rw-r--r--net-mgmt/bgpq/files/patch-ro.c27
2 files changed, 29 insertions, 7 deletions
diff --git a/net-mgmt/bgpq/Makefile b/net-mgmt/bgpq/Makefile
index 6ec3a1f5dd92..ed08e61f870f 100644
--- a/net-mgmt/bgpq/Makefile
+++ b/net-mgmt/bgpq/Makefile
@@ -6,6 +6,7 @@
PORTNAME= bgpq
PORTVERSION= 1.0.7.6
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
@@ -19,10 +20,4 @@ HAS_CONFIGURE= yes
post-install:
${STRIP_CMD} ${PREFIX}/bin/bgpq
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/bgpq/files/patch-ro.c b/net-mgmt/bgpq/files/patch-ro.c
new file mode 100644
index 000000000000..5563b4976daf
--- /dev/null
+++ b/net-mgmt/bgpq/files/patch-ro.c
@@ -0,0 +1,27 @@
+--- ro.c.orig Wed Oct 15 06:07:13 2003
++++ ro.c Wed Oct 15 06:07:38 2003
+@@ -471,18 +471,18 @@
+ if(extrange) {
+ if(retval<100 || (retval>199 && retval<2000) || retval>2699) {
+ fprintf(f,"\
+-!=============================================================================
+-! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)
+-!=============================================================================
++!=============================================================================\n\
++! WARNING ! %s is out of extended access-list ranges (100-199 and 2000-2699)\n\
++!=============================================================================\n\
+ ",string);
+ exit(1);
+ };
+ } else {
+ if((retval>100 && retval<1300) || retval>1999) {
+ fprintf(f,"\
+-!=============================================================================
+-! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)
+-!=============================================================================
++!=============================================================================\n\
++! WARNING ! %s is out of standard access-list ranges (1-99 and 1300-1999)\n\
++!=============================================================================\n\
+ ",string);
+
+ exit(1);