aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/cdpd/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2007-02-06 14:25:41 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2007-02-06 14:25:41 +0000
commitdf1a452e459333d890711dcb588b95cc282b63e5 (patch)
tree68ec23f02b6fc643d917071a86f184bec0ecb7f6 /net-mgmt/cdpd/Makefile
parentafd1f07ae9c930e4dbc68bfba98acef698c93980 (diff)
downloadports-df1a452e459333d890711dcb588b95cc282b63e5.tar.gz
ports-df1a452e459333d890711dcb588b95cc282b63e5.zip
- rcNG'fy
- get rid of pkg-plist - grab
Notes
Notes: svn path=/head/; revision=184375
Diffstat (limited to 'net-mgmt/cdpd/Makefile')
-rw-r--r--net-mgmt/cdpd/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/net-mgmt/cdpd/Makefile b/net-mgmt/cdpd/Makefile
index 428221735b3c..adcee4b51f8e 100644
--- a/net-mgmt/cdpd/Makefile
+++ b/net-mgmt/cdpd/Makefile
@@ -6,18 +6,21 @@
PORTNAME= cdpd
PORTVERSION= 1.0.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.lexa.ru/pub/domestic/snar/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= CDPdaemon - sends Cisco Discovery Protocol announces over ethernet
+MAINTAINER= sem@FreeBSD.org
+COMMENT= A daemon to send Cisco Discovery Protocol announces over ethernet
BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
GNU_CONFIGURE= yes
CFLAGS+= `${LIBNET_CONFIG} --cflags`
+USE_RC_SUBR= cdpd
+PLIST_FILES= sbin/cdpd
+
MAN8= cdpd.8
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
@@ -26,4 +29,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG:T}|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cdpd ${PREFIX}/sbin
+ @${INSTALL_MAN} ${WRKSRC}/cdpd.8 ${MAN8PREFIX}/man/man8
+
.include <bsd.port.mk>