aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/collectd5/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-31 12:10:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-31 12:10:39 +0000
commit5da1c8af56f40f381b7716e2b3b36bcdb0434647 (patch)
tree5a8abc857f9e184c73b9562cc6cf76572886f9ba /net-mgmt/collectd5/Makefile
parent3f6bcbbd1484d0655c3c8a17b5a4c269dfec777a (diff)
downloadports-5da1c8af56f40f381b7716e2b3b36bcdb0434647.tar.gz
ports-5da1c8af56f40f381b7716e2b3b36bcdb0434647.zip
- Add disk plugin support
PR: 153643 Submitted by: Benjamin Lee <ben@b1c1l1.com> Approved by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=268483
Diffstat (limited to 'net-mgmt/collectd5/Makefile')
-rw-r--r--net-mgmt/collectd5/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 5a4eeb91cc91..0179458e680c 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= collectd
PORTVERSION= 4.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -26,6 +26,7 @@ OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
CURL "Input: CURL generic web statistics" Off \
DBI "Input: database abstraction library" Off \
+ DISK "Input: Disk performance statistics" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
@@ -74,7 +75,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-contextswitch \
--disable-cpufreq \
--disable-curl_json \
- --disable-disk \
--disable-entropy \
--disable-fscache \
--disable-gmond \
@@ -195,6 +195,14 @@ CONFIGURE_ARGS+=--disable-dbi
PLIST_SUB+= DBI="@comment "
.endif
+.if defined(WITH_DISK)
+CONFIGURE_ARGS+=--enable-disk
+PLIST_SUB+= DISK=""
+.else
+CONFIGURE_ARGS+=--disable-disk
+PLIST_SUB+= DISK="@comment "
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut