aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/driftnet
diff options
context:
space:
mode:
authorcvs2svn <cvs2svn@FreeBSD.org>2003-12-12 19:19:02 +0000
committercvs2svn <cvs2svn@FreeBSD.org>2003-12-12 19:19:02 +0000
commita0848d727648aa70f6a89c013203f2b82a4e972e (patch)
tree37ec8e378ec2d731e9ba9c15cd58724325a5637c /net-mgmt/driftnet
parentb6deb36621300a80aab2d23031a1a259f9b0ce01 (diff)
downloadports-a0848d727648aa70f6a89c013203f2b82a4e972e.tar.gz
ports-a0848d727648aa70f6a89c013203f2b82a4e972e.zip
This commit was manufactured by cvs2svn to create tag 'RELEASE_5_2_0'.release/5.2.0
Notes
Notes: svn path=/head/; revision=95679 svn path=/tags/RELEASE_5_2_0/; revision=95680; tag=release/5.2.0
Diffstat (limited to 'net-mgmt/driftnet')
-rw-r--r--net-mgmt/driftnet/Makefile33
-rw-r--r--net-mgmt/driftnet/distinfo1
-rw-r--r--net-mgmt/driftnet/files/patch-Makefile51
-rw-r--r--net-mgmt/driftnet/files/patch-driftnet.c22
-rw-r--r--net-mgmt/driftnet/pkg-descr14
-rw-r--r--net-mgmt/driftnet/pkg-plist1
6 files changed, 0 insertions, 122 deletions
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
deleted file mode 100644
index 0cc01c00b4ef..000000000000
--- a/net-mgmt/driftnet/Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
-# New ports collection makefile for: driftnet
-# Date created: 28 February 2002
-# Whom: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
-#
-# $FreeBSD$
-#
-
-PORTNAME= driftnet
-PORTVERSION= 0.1.6
-CATEGORIES= net
-MASTER_SITES= http://www.ex-parrot.com/~chris/driftnet/ \
- http://www.vanheusden.com/mirrors/
-
-MAINTAINER= corecode@corecode.ath.cx
-COMMENT= A Tool to grab images out of (your) TCP connections
-
-LIB_DEPENDS= ungif.5:${PORTSDIR}/graphics/libungif \
- jpeg.9:${PORTSDIR}/graphics/jpeg
-
-USE_GNOME= gtk12
-USE_X_PREFIX= yes
-USE_GMAKE= yes
-
-ALL_TARGET= default
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
-
-MAN1= driftnet.1
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/driftnet ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/driftnet.1 ${MAN1PREFIX}/man/man1/
-
-.include <bsd.port.mk>
diff --git a/net-mgmt/driftnet/distinfo b/net-mgmt/driftnet/distinfo
deleted file mode 100644
index a9ef576a668f..000000000000
--- a/net-mgmt/driftnet/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (driftnet-0.1.6.tar.gz) = 8e11d77770452f97bb3c23f510489815
diff --git a/net-mgmt/driftnet/files/patch-Makefile b/net-mgmt/driftnet/files/patch-Makefile
deleted file mode 100644
index 1701d03937cf..000000000000
--- a/net-mgmt/driftnet/files/patch-Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
---- Makefile.orig Tue Jul 9 12:26:41 2002
-+++ Makefile Sat Sep 28 22:19:21 2002
-@@ -16,23 +16,23 @@
- #CC = gcc
-
- # Basic compiler, linker flags; should not need any changes.
--CFLAGS += -g -Wall
--LDFLAGS += -g
-+#CFLAGS += -g -Wall
-+#LDFLAGS += -g
-
- # You might need these if libpcap is installed somewhere random.
--CFLAGS += -I/usr/include/pcap
-+#CFLAGS += -I/usr/include/pcap
- #LDFLAGS += -L/path/to/libpcap.so
-
- # Required on Linux to get BSDish definitions of the TCP/IP structs.
--CFLAGS += -D_BSD_SOURCE
-+#CFLAGS += -D_BSD_SOURCE
-
- # We always need the pcap and pthread libraries.
--LDLIBS += -lpcap -lpthread
-+LDLIBS += -lpcap ${PTHREAD_LIBS}
-
- # Optional C compiler and linker flags. Typical driftnet builds have support
- # for displaying captured images in an X window, and need the following flags:
--CFLAGS += `gtk-config --cflags`
--LDLIBS += -ljpeg -lungif `gtk-config --libs`
-+CFLAGS += ${PTHREAD_CFLAGS} `${GTK_CONFIG} --cflags`
-+LDLIBS += -ljpeg -lungif `${GTK_CONFIG} --libs`
-
- # Alternatively, you can build a version of driftnet which can only be used
- # in `adjunct' mode as the back end for some other image-processing program. To
-@@ -43,7 +43,7 @@
- # On systems with a C99 compiler, driftnet will use <stdint.h> for the
- # definitions of types such as uint8_t. On other systems like Solaris, these
- # are in <sys/types.h>, and you should uncomment this line.
--#CFLAGS += -DUSE_SYS_TYPES_H
-+CFLAGS += -DUSE_SYS_TYPES_H
-
- # On Solaris, it is necessary to link against -lposix4 for the definition of
- # nanosleep; uncomment the below.
-@@ -51,7 +51,7 @@
-
- # added 20020604 edobbs
- # On BSD systems, may need to use /usr/local/include
--#CFLAGS += -I/usr/local/include
-+CFLAGS += -I/usr/local/include
-
-
- #
diff --git a/net-mgmt/driftnet/files/patch-driftnet.c b/net-mgmt/driftnet/files/patch-driftnet.c
deleted file mode 100644
index fce26e723f95..000000000000
--- a/net-mgmt/driftnet/files/patch-driftnet.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- driftnet.c.orig Tue Jul 9 21:26:41 2002
-+++ driftnet.c Tue Aug 20 02:30:35 2002
-@@ -254,8 +254,8 @@
- "\n"
- " -h Display this help message.\n"
- " -v Verbose operation.\n"
--" -i interface Select the interface on which to listen (default: all\n"
--" interfaces).\n"
-+" -i interface Select the interface on which to listen (default: first\n"
-+" available interface).\n"
- " -p Do not put the listening interface into promiscuous mode.\n"" -a Adjunct mode: do not display images on screen, but save\n"
- " them to a temporary directory and announce their names on\n"
- " standard output.\n"
-@@ -313,7 +313,7 @@
- void setup_signals(void) {
- int *p;
- /* Signals to ignore. */
-- int ignore_signals[] = {SIGPIPE, 0};
-+ int ignore_signals[] = {SIGPIPE, SIGCONT, SIGHUP, 0};
- /* Signals which mean we should quit, killing the display child if
- * applicable. */
- int terminate_signals[] = {SIGTERM, SIGINT, /*SIGSEGV,*/ SIGBUS, SIGCHLD, 0};
diff --git a/net-mgmt/driftnet/pkg-descr b/net-mgmt/driftnet/pkg-descr
deleted file mode 100644
index 2b2e853684ca..000000000000
--- a/net-mgmt/driftnet/pkg-descr
+++ /dev/null
@@ -1,14 +0,0 @@
-EtherPEG was a program that sniffed for JPEGs passing by on the AirPort
-networks at MacHack, and showed them on the huge screen to shame people
-into a) turning the 802.11 encryption on, or b) reducing amount of pr0n
-they download at weirdo Mac conventions. DRIFTNET can do the same for
-*your* office, and make an attractive desktop accessory to boot. The
-program promiscuously sniffs and decodes any JPEG downloaded by anyone
-on your LAN, displaying it in an attractive, ever changing mosaic of
-fluffy kittens, oversized navigation buttons, and blurred images of Big
-Brother Elizabeth fiddling. It's UNIX only. Your sysadmin is undoubtedly
-running it already. So stop that. Now.
-
-WWW: http://www.ex-parrot.com/~chris/driftnet/
-
-- Simon 'corecode' Schubert
diff --git a/net-mgmt/driftnet/pkg-plist b/net-mgmt/driftnet/pkg-plist
deleted file mode 100644
index b1525af7a32a..000000000000
--- a/net-mgmt/driftnet/pkg-plist
+++ /dev/null
@@ -1 +0,0 @@
-bin/driftnet