aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ettercap/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2004-02-27 11:30:18 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2004-02-27 11:30:18 +0000
commit7b0e707504cde970619299578b7dc39c2ea97865 (patch)
tree0e4935e1c52757da39d818575202598e6fb29a14 /net-mgmt/ettercap/Makefile
parente2f95292ea4ad9e19a77a899cd36acd515db2825 (diff)
downloadports-7b0e707504cde970619299578b7dc39c2ea97865.tar.gz
ports-7b0e707504cde970619299578b7dc39c2ea97865.zip
- Obey PTHREAD_LIBS also when libpthread exists.
- Use/respect DATADIR and DOCSDIR. Submitted by: Marius Strobl <marius@alchemy.franken.de>
Notes
Notes: svn path=/head/; revision=102284
Diffstat (limited to 'net-mgmt/ettercap/Makefile')
-rw-r--r--net-mgmt/ettercap/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index dda95b04ddc2..55471b6f4034 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ettercap
PORTVERSION= 0.6.b
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net-mgmt security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@@ -53,10 +53,18 @@ INSTALL_TARGET= install plug-ins_install
INSTALL_TARGET+= install-doc
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+post-extract:
@${MV} -f ${WRKSRC}/share/lc-converter.c ${WRKSRC}
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -E -e 's|(^DATADIR.+=).+|\1 ${DATADIR}|; \
+ s|(^DOCDIR.+=).+|\1 ${DOCSDIR}|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|@prefix@\/share\/@PROG@|${DATADIR}|; \
+ s|@prefix@\/doc\/@PROG@-@VERSION@|${DOCSDIR}|' \
+ ${WRKSRC}/ettercap.8.in
+
post-build:
${CC} ${CFLAGS} -o ${WRKSRC}/lc-converter ${WRKSRC}/lc-converter.c