aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/flow-extract/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 11:15:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-28 11:15:22 +0000
commite972bdbe8784db29a8d725136fe30b563b2b40de (patch)
tree77617b8ce520489ce5dcc43e0e4b446d1935ceb3 /net-mgmt/flow-extract/Makefile
parent10b6d47e0a8ddea34c49f264fbd217f4643dedae (diff)
downloadports-e972bdbe8784db29a8d725136fe30b563b2b40de.tar.gz
ports-e972bdbe8784db29a8d725136fe30b563b2b40de.zip
net/flow-extract: new port
This tool complements existing net/flow-tools port. PR: ports/50005 Submitted by: Marcin Cieslak <saper@system.pl>
Notes
Notes: svn path=/head/; revision=87886
Diffstat (limited to 'net-mgmt/flow-extract/Makefile')
-rw-r--r--net-mgmt/flow-extract/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-mgmt/flow-extract/Makefile b/net-mgmt/flow-extract/Makefile
new file mode 100644
index 000000000000..d0f3a3d02be9
--- /dev/null
+++ b/net-mgmt/flow-extract/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: flow-extract
+# Date created: 2003 Mar 14
+# Whom: Marcin Cieslak <saper@system.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flow-extract
+PORTVERSION= 2.4
+CATEGORIES= net
+MASTER_SITES= http://security.uchicago.edu/tools/net-forensics/files/
+DISTNAME= flowextract-${PORTVERSION}
+EXTRACT_SUFX= .cpio.gz
+
+MAINTAINER= saper@system.pl
+COMMENT= Cisco NetFlow awk-like extracting tool
+
+BUILD_DEPENDS= flow-cat:${PORTSDIR}/net/flow-tools
+
+USE_REINPLACE= yes
+EXTRACT_AFTER_ARGS= | cpio -idmu
+
+post-patch: patch-makefile
+
+patch-makefile:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/flow-extract ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/flow-extract.1 ${PREFIX}/man/man1
+
+MAN1= flow-extract.1
+
+.include <bsd.port.mk>