aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/fprobe
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-24 07:23:24 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-24 07:23:24 +0000
commitaf5235870a1c1ee222c83a79b2f885097f0223ad (patch)
tree8e200e9aa5542c85ced5f7b777e574e1f3a4d2b8 /net-mgmt/fprobe
parente0910925e9adb2427f4904a684272fbb2dd2a8c1 (diff)
downloadports-af5235870a1c1ee222c83a79b2f885097f0223ad.tar.gz
ports-af5235870a1c1ee222c83a79b2f885097f0223ad.zip
- Apply rcfile
- Bump PORTREVISION PR: ports/104466 Submitted by: maintainer (Gea-Suan Lin)
Notes
Notes: svn path=/head/; revision=177952
Diffstat (limited to 'net-mgmt/fprobe')
-rw-r--r--net-mgmt/fprobe/Makefile10
-rw-r--r--net-mgmt/fprobe/files/fprobe.sh.in28
2 files changed, 34 insertions, 4 deletions
diff --git a/net-mgmt/fprobe/Makefile b/net-mgmt/fprobe/Makefile
index 491a8ea19d37..166a900d2952 100644
--- a/net-mgmt/fprobe/Makefile
+++ b/net-mgmt/fprobe/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fprobe
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,18 +15,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool that collects network traffic data
-GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
+PLIST_FILES= sbin/fprobe
+PORTDOCS= ChangeLog README
+SUB_LIST= NAME=${PORTNAME}
USE_BZIP2= yes
+USE_RC_SUBR= fprobe.sh
MAN8= fprobe.8
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
-PORTDOCS= ChangeLog README
-PLIST_FILES= sbin/fprobe
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/net-mgmt/fprobe/files/fprobe.sh.in b/net-mgmt/fprobe/files/fprobe.sh.in
new file mode 100644
index 000000000000..c24715b6fc7e
--- /dev/null
+++ b/net-mgmt/fprobe/files/fprobe.sh.in
@@ -0,0 +1,28 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: fprobe
+# REQUIRE: NETWORKING
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable %%NAME%%:
+#
+#%%NAME%%_enable="YES"
+#
+# See fprobe(8) for %%NAME%%_flags
+#
+
+. "%%RC_SUBR%%"
+
+name="%%NAME%%"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/sbin/fprobe"
+command_args="-i lo0 127.0.0.1:2055"
+pidfile="/var/run/$name.pid"
+
+load_rc_config "$name"
+: ${fprobe_enable="NO"}
+
+run_rc_command "$1"