aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2016-08-25 19:23:08 +0000
committerLars Engels <lme@FreeBSD.org>2016-08-25 19:23:08 +0000
commit1dd2f515a30094f2bbd168f0e86fb3a66ef3c543 (patch)
tree9721a9ba3c734316fa26ffdebd61bf31dbd23111 /net-mgmt/icinga2
parent0ae98084bb5e2699fde7958707d68e3f66b911a3 (diff)
downloadports-1dd2f515a30094f2bbd168f0e86fb3a66ef3c543.tar.gz
ports-1dd2f515a30094f2bbd168f0e86fb3a66ef3c543.zip
net-mgmt/icinga2:
Remove bogus dependency on devel/libconfig. Some time ago I added this because the ports tree's Q/A check warned that the icinga2 binary is linked against libconfig. However this is a private library shipped with Icinga 2. With version 2.5.1 USES=ssl was added to the port's Makefile which added rpath=${LOCALBASE}/openssl when Icinga 2 gets built and {Open,Libre}SSL from ports was installed. The result was that ld picked up libconfig.so from the devel/libconfig port instead of Icinga 2's private library. To prevent this, the following CMAKE_ARGS were added: CMAKE_{EXE,MODULE,SHARED,STATIC}_LINKER_FLAGS=${PREFIX}/lib/icinga2 At the moment only EXE_ and SHARED_ linker flags are really needed, to be prepared for future changes the other flags were also set. Thanks to mat and Gunnar Beutner (upstream developer) for the insights on the ports and Icinga 2's build system. - Re-add USES=ssl - Bump PORTREVSION
Notes
Notes: svn path=/head/; revision=420876
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index d2b2e76f75c0..a8d8a4c4265e 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
DISTVERSION= 2.5.3
+PORTREVISION= 1
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
@@ -11,8 +12,7 @@ COMMENT= Monitoring and management system for hosts, services and networks
LICENSE= GPLv2
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
- libyajl.so:devel/yajl \
- libconfig.so:devel/libconfig
+ libyajl.so:devel/yajl
RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
BROKEN_powerpc64= Does not build
@@ -20,7 +20,7 @@ BROKEN_powerpc64= Does not build
USE_GITHUB= yes
GH_ACCOUNT= icinga
-USES= alias bison cmake execinfo libedit
+USES= alias bison cmake execinfo libedit ssl
USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
@@ -56,6 +56,10 @@ CMAKE_ARGS+= -DICINGA2_USER=${ICINGA2USER} \
-DCMAKE_INSTALL_SYSCONFDIR=${PREFIX}/etc \
-DCMAKE_INSTALL_LOCALSTATEDIR=${LOCALSTATEDIR} \
-DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
+ -DCMAKE_EXE_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
+ -DCMAKE_MODULE_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
+ -DCMAKE_SHARED_LINKER_FLAGS=${PREFIX}/lib/icinga2 \
+ -DCMAKE_STATIC_LINKER_FLAGS=${PREFIX}/lib/icinga2
SUB_LIST= ICINGA2LOGDIR=${ICINGA2LOGDIR} \
ICINGA2USER=${ICINGA2USER} \