aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2014-07-30 16:17:39 +0000
committerLars Engels <lme@FreeBSD.org>2014-07-30 16:17:39 +0000
commit383100cfc77306991405b112a8c0f02123b9355e (patch)
tree74d0d1de659d01e72b576f7a1d7a025ac88e8359 /net-mgmt/icinga2
parent6a69f7c6fcf07ffc32a16a8b310f2736986c1bdd (diff)
downloadports-383100cfc77306991405b112a8c0f02123b9355e.tar.gz
ports-383100cfc77306991405b112a8c0f02123b9355e.zip
- Add OPTIONS to either depend on plugins from nagios-plugins.org, monitoring-plugins.org or neither at all
- Bump PORTREVISION Approved by: mat (implicit)
Notes
Notes: svn path=/head/; revision=363492
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index 14163313812b..d6daa07c6bb5 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= icinga2
DISTVERSION= 2.0.1
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://github.com/Icinga/${PORTNAME}/archive/v${DISTVERSION}.tar.gz?dummy=/
@@ -12,8 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
libexecinfo.so:${PORTSDIR}/devel/libexecinfo # for better debugging
-RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/monitoring-plugins \
- ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
USES= bison cmake
USE_LDCONFIG= yes
@@ -21,10 +21,15 @@ USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME}
OPTIONS_DEFINE= DOCS
-OPTIONS_SINGLE= BACKEND
-OPTIONS_SINGLE_BACKEND= MYSQL PGSQL
+OPTIONS_MULTI= BACKEND
+OPTIONS_MULTI_BACKEND= MYSQL PGSQL
+OPTIONS_RADIO= PLUGINS
+OPTIONS_RADIO_PLUGINS= MONPLUGINS NAGPLUGINS
-OPTIONS_DEFAULT= MYSQL
+OPTIONS_DEFAULT= MYSQL MONPLUGINS
+
+MONPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/monitoring-plugins
+NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
MYSQL_CMAKE_ON= -DWITH_MYSQL:BOOL=true
PGSQL_CMAKE_ON= -DWITH_PGSQL:BOOL=true