aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2015-09-11 04:59:14 +0000
committerLars Engels <lme@FreeBSD.org>2015-09-11 04:59:14 +0000
commitb68e14dc2095d4a78f58634956ddb6bba7cc74ab (patch)
tree8e0eb613fba8de4eb12b6d4cf67ad77fc6b2e00b /net-mgmt/icinga2
parentea85f829b85ccc173c5d5fd406973b986ceb6eae (diff)
downloadports-b68e14dc2095d4a78f58634956ddb6bba7cc74ab.tar.gz
ports-b68e14dc2095d4a78f58634956ddb6bba7cc74ab.zip
- Update to 2.3.10
- Re-enable start_precmd in the rc script, creating needed directories in /var
Notes
Notes: svn path=/head/; revision=396647
Diffstat (limited to 'net-mgmt/icinga2')
-rw-r--r--net-mgmt/icinga2/Makefile2
-rw-r--r--net-mgmt/icinga2/distinfo4
-rw-r--r--net-mgmt/icinga2/files/icinga2.in36
3 files changed, 23 insertions, 19 deletions
diff --git a/net-mgmt/icinga2/Makefile b/net-mgmt/icinga2/Makefile
index fb076025abbf..aed2910e6198 100644
--- a/net-mgmt/icinga2/Makefile
+++ b/net-mgmt/icinga2/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icinga2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.9
+DISTVERSION= 2.3.10
CATEGORIES= net-mgmt
MAINTAINER= lme@FreeBSD.org
diff --git a/net-mgmt/icinga2/distinfo b/net-mgmt/icinga2/distinfo
index b6272b7dfd42..58c531685867 100644
--- a/net-mgmt/icinga2/distinfo
+++ b/net-mgmt/icinga2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (icinga-icinga2-v2.3.9_GH0.tar.gz) = af6aa49ac9ce90e2ecf331b092624f5d6462d31ca5b4458db1c3d974391183c3
-SIZE (icinga-icinga2-v2.3.9_GH0.tar.gz) = 829706
+SHA256 (icinga-icinga2-v2.3.10_GH0.tar.gz) = d29880b1adfd21d650a72e04a36e4dadb899b8452c4917e25e7ec3c5e65582c1
+SIZE (icinga-icinga2-v2.3.10_GH0.tar.gz) = 830680
diff --git a/net-mgmt/icinga2/files/icinga2.in b/net-mgmt/icinga2/files/icinga2.in
index b2f74fe607f3..64bdc8b7da38 100644
--- a/net-mgmt/icinga2/files/icinga2.in
+++ b/net-mgmt/icinga2/files/icinga2.in
@@ -78,22 +78,26 @@ reload_precmd() {
}
start_precmd() {
-# # Create necessary directories / change ownership
-# for d in "${icinga2_logdir}" "${icinga2_logdir}/compat" \
-# "${icinga2_logdir}/compat/archives" "${icinga2_libdir}" \
-# "${icinga2_spooldir}" "${icinga2_spooldir}/tmp" \
-# "${icinga2_rundir}" "${icinga2_cachedir}"; do
-# if [ ! -d "${d}" ]; then
-# install -d -o ${icinga2_user} -g ${icinga2_group} "${d}"
-# else
-# chown ${icinga2_user}:${icinga2_group} "${d}"
-# fi
-# done
-#
-# install -d -o ${icinga2_user} -g %%WWWGRP%% "${icinga2_rundir}/cmd"
-#
-# chown -R ${icinga2_user}:${icinga2_user} "${icinga2_libdir}"
-# chown -R ${icinga2_user}:${icinga2_user} "${icinga2_spooldir}"
+ # Create necessary directories / change ownership
+ #
+ # While this is also done through pkg-plist, /var might be on a ramdisk,
+ # so make sure all needed files and directories are created before starting
+ # Icinga.
+ for d in "${icinga2_logdir}" "${icinga2_logdir}/compat" \
+ "${icinga2_logdir}/compat/archives" "${icinga2_libdir}" \
+ "${icinga2_spooldir}" "${icinga2_spooldir}/tmp" \
+ "${icinga2_rundir}" "${icinga2_cachedir}"; do
+ if [ ! -d "${d}" ]; then
+ install -d -o ${icinga2_user} -g ${icinga2_group} "${d}"
+ else
+ chown ${icinga2_user}:${icinga2_group} "${d}"
+ fi
+ done
+
+ install -d -o ${icinga2_user} -g %%WWWGRP%% "${icinga2_rundir}/cmd"
+
+ chown -R ${icinga2_user}:${icinga2_user} "${icinga2_libdir}"
+ chown -R ${icinga2_user}:${icinga2_user} "${icinga2_spooldir}"
if ! icinga2_checkconfig; then
return 1