aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:12:35 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-17 06:12:35 +0000
commit46c6877a4a150b8a708675a333110c1effbc512e (patch)
treecb5f589849208faeb4439a9e84ed872d37762a4e /net-mgmt/nagios/Makefile
parentb470510cdfb40beffcd9dee843714d519c7e4d72 (diff)
downloadports-46c6877a4a150b8a708675a333110c1effbc512e.tar.gz
ports-46c6877a4a150b8a708675a333110c1effbc512e.zip
Convert to new perl framework
Submitted by: az
Notes
Notes: svn path=/head/; revision=327450
Diffstat (limited to 'net-mgmt/nagios/Makefile')
-rw-r--r--net-mgmt/nagios/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index acf818fdec86..a0fd923d3263 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -14,8 +14,8 @@ LICENSE= GPLv2
LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
-USES= iconv
-USE_PERL5_BUILD=yes
+USES= iconv perl5
+USE_PERL5= build
USE_AUTOTOOLS= autoconf libltdl
USE_PHP= yes
USE_RC_SUBR= nagios
@@ -86,7 +86,7 @@ UNHANDLED_HACK_DESC= Display passive checks in unhandled queries
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMBEDDED_PERL}
-USE_PERL5= yes
+USE_PERL5+= run
CONFIGURE_ARGS+=--enable-embedded-perl \
--with-perlcache
PLIST_SUB+= EMBEDDED_PERL=""