aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:16:14 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:16:14 +0000
commit99a390f50bab457f60aec3050c18c4b5c5fb7023 (patch)
treefb6e1d6bcf31a0efb7675597b7fa4f423710c0bb /net-mgmt/nagios
parent31f779fa09467bfcb2c12e2ad95525a75e526bc8 (diff)
downloadports-99a390f50bab457f60aec3050c18c4b5c5fb7023.tar.gz
ports-99a390f50bab457f60aec3050c18c4b5c5fb7023.zip
o Change library name from libgd to libgd1.
o Do not install everything except headers and libraries (to avoid conflicting with graphics/gd2) o Fix dependency on new libgd1(for many ports). PR: ports/54100 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=84696
Diffstat (limited to 'net-mgmt/nagios')
-rw-r--r--net-mgmt/nagios/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 7ef95c86f584..f427cd1dfd07 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -17,15 +17,15 @@ COMMENT= Extremely powerful network monitoring system
.if defined(WITH_GD2)
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
.endif
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net/nagios-plugins
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${INCGD} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} ${INCGD} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${LIBGD} -lgnugetopt"
CONFIGURE_ARGS= --with-command-user=nagios \
--with-command-grp=www \
--with-nagios-user=nagios \
@@ -40,6 +40,14 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=/var/spool/nagios \
--prefix=${PREFIX}
+.if defined(WITH_GD2)
+INCGD= -I${LOCALBASE}/include
+LIBGD= -lgd
+.else
+INCGD= -I${LOCALBASE}/include/gd
+LIBGD= -lgd1
+.endif
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \