aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nat
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-29 15:54:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-29 15:54:11 +0000
commit69b9bce8116687d5e7a2bc6cf5050c4ebedf1d8b (patch)
treef50601272c8acdf98e8c62da09fd2a18631b65bf /net-mgmt/nat
parent1d2ced0bb75b9491b8a16da835719cb1ff886f26 (diff)
downloadports-69b9bce8116687d5e7a2bc6cf5050c4ebedf1d8b.tar.gz
ports-69b9bce8116687d5e7a2bc6cf5050c4ebedf1d8b.zip
add nat
NetBIOS auditing tool PR: 27607 Submitted by: Roman Shterenzon <roman@xpert.com>
Notes
Notes: svn path=/head/; revision=43271
Diffstat (limited to 'net-mgmt/nat')
-rw-r--r--net-mgmt/nat/Makefile31
-rw-r--r--net-mgmt/nat/distinfo1
-rw-r--r--net-mgmt/nat/pkg-comment1
-rw-r--r--net-mgmt/nat/pkg-descr2
-rw-r--r--net-mgmt/nat/pkg-plist4
5 files changed, 39 insertions, 0 deletions
diff --git a/net-mgmt/nat/Makefile b/net-mgmt/nat/Makefile
new file mode 100644
index 000000000000..5b218dea0752
--- /dev/null
+++ b/net-mgmt/nat/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: nat
+# Date created: May 24 2001
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nat
+PORTVERSION= 20
+CATEGORIES= net security
+MASTER_SITES= http://www.tux.org/pub/security/secnet/tools/nat20beta/ \
+ ftp://ftp.cert.dfn.de/pub/tools/net/nat/nat20beta/ \
+ ftp://ftp.spin.ad.jp/pub/Security/nat/nat20beta/
+DISTNAME= ${PORTNAME}${PORTVERSION}.freebsd
+
+MAINTAINER= roman@xpert.com
+
+NO_PACKAGE= "Redistribution prohibited by the license"
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+MAN1= nat.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/nat ${LOCALBASE}/bin
+ ${INSTALL_MAN} ${WRKSRC}/nat.1 ${LOCALBASE}/man/man1
+ ${MKDIR} ${LOCALBASE}/share/nat
+ ${INSTALL_DATA} ${WRKSRC}/passlist.txt ${LOCALBASE}/share/nat
+ ${INSTALL_DATA} ${WRKSRC}/userlist.txt ${LOCALBASE}/share/nat
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nat/distinfo b/net-mgmt/nat/distinfo
new file mode 100644
index 000000000000..601c3a6ed3a6
--- /dev/null
+++ b/net-mgmt/nat/distinfo
@@ -0,0 +1 @@
+MD5 (nat20.freebsd.tar.gz) = 20174dc3e5f4cc6802369a298fec7cd1
diff --git a/net-mgmt/nat/pkg-comment b/net-mgmt/nat/pkg-comment
new file mode 100644
index 000000000000..c4815e0b599a
--- /dev/null
+++ b/net-mgmt/nat/pkg-comment
@@ -0,0 +1 @@
+NetBIOS auditing tool
diff --git a/net-mgmt/nat/pkg-descr b/net-mgmt/nat/pkg-descr
new file mode 100644
index 000000000000..6cbeedae7cd3
--- /dev/null
+++ b/net-mgmt/nat/pkg-descr
@@ -0,0 +1,2 @@
+SMB/CIFS server and file share auditing tool used to gather information and
+identify misconfigurations in security critical environments.
diff --git a/net-mgmt/nat/pkg-plist b/net-mgmt/nat/pkg-plist
new file mode 100644
index 000000000000..079578f7687b
--- /dev/null
+++ b/net-mgmt/nat/pkg-plist
@@ -0,0 +1,4 @@
+bin/nat
+share/nat/passlist.txt
+share/nat/userlist.txt
+@dirrm %D/share/nat