aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-02-15 01:09:56 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-02-15 01:09:56 +0000
commit0c6f2b1256d6d877b5fedbd491649d4285f0d618 (patch)
treee9dad95dfe07c3d4ccf721a12af103088eedc59e /net-mgmt/net-snmp
parent5fee4ed56bb1af7b9f4d4e75c338ab676e144e3e (diff)
downloadports-0c6f2b1256d6d877b5fedbd491649d4285f0d618.tar.gz
ports-0c6f2b1256d6d877b5fedbd491649d4285f0d618.zip
o Add WITH_SNMP_DISKIO knob to collect diskio statistics (will turn on by
default after some period). o Support 4.x and 5.x for host/hr_disk.c. o Add simple patch to wrap function decraration in HAVE_LPSTAT correctly.
Notes
Notes: svn path=/head/; revision=54717
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile4
-rw-r--r--net-mgmt/net-snmp/files/patch-diskio.c31
-rw-r--r--net-mgmt/net-snmp/files/patch-hr_disk.c12
-rw-r--r--net-mgmt/net-snmp/files/patch-hr_print.c12
4 files changed, 59 insertions, 0 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index e9b22d22dd51..88821e689cd5 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ucd-snmp
PORTVERSION= 4.2.3
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ucd-snmp.ucdavis.edu/ \
@@ -62,6 +63,9 @@ STARTUP_FILE= ${PREFIX}/etc/rc.d/snmpd.sh
.if ${OSVERSION} >= 400014
CONFIGURE_ARGS+= --enable-ipv6
.endif
+.if defined(WITH_SNMP_DISKIO)
+CONFIGURE_ARGS+=--with-mib-modules="ucd-snmp/diskio" --with-libs="-ldevstat"
+.endif
SHLIB_VERSION= 4
PLIST_SUB+= shlib=${SHLIB_VERSION}
diff --git a/net-mgmt/net-snmp/files/patch-diskio.c b/net-mgmt/net-snmp/files/patch-diskio.c
new file mode 100644
index 000000000000..1c68911c67b7
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-diskio.c
@@ -0,0 +1,31 @@
+--- agent/mibgroup/ucd-snmp/diskio.c.orig Mon Sep 17 06:49:41 2001
++++ agent/mibgroup/ucd-snmp/diskio.c Wed Feb 13 22:22:45 2002
+@@ -46,10 +46,10 @@
+ #include <sys/diskstats.h>
+ #endif /* bsdi */
+
+-#if defined (freebsd4)
++#if __FreeBSD__ >= 4
+ #include <sys/dkstat.h>
+ #include <devstat.h>
+-#endif /* freebsd */
++#endif /* __FreeBSD__ */
+
+
+ /*********************
+@@ -298,7 +298,7 @@
+ }
+ #endif /* bsdi */
+
+-#if defined(freebsd4)
++#if __FreeBSD__ >= 4
+ static int ndisk;
+ static struct statinfo *stat;
+
+@@ -377,5 +377,5 @@
+ }
+ return NULL;
+ }
+-#endif /* freebsd4 */
++#endif /* __FreeBSD__ >= 4 */
+
diff --git a/net-mgmt/net-snmp/files/patch-hr_disk.c b/net-mgmt/net-snmp/files/patch-hr_disk.c
new file mode 100644
index 000000000000..ea1ed0adf096
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-hr_disk.c
@@ -0,0 +1,12 @@
+--- agent/mibgroup/host/hr_disk.c.orig Mon Nov 19 13:48:10 2001
++++ agent/mibgroup/host/hr_disk.c Tue Feb 12 22:37:43 2002
+@@ -178,6 +178,9 @@
+ #elif defined(solaris2)
+ Add_HR_Disk_entry ( "/dev/rdsk/c%dt%dd0s%d", 0, 1, 0, 15, "/dev/rdsk/c%dt%dd0s0", 0, 7 );
+ Add_HR_Disk_entry ( "/dev/rdsk/c%dd%ds%d", 0, 1, 0, 15, "/dev/rdsk/c%dd%ds0", 0, 7 );
++#elif defined(__FreeBSD__) && __FreeBSD__ >= 4
++ Add_HR_Disk_entry ( "/dev/ad%ds%d%c", 0, 1, 1, 4, "/dev/ad%ds%d", 'a', 'h');
++ Add_HR_Disk_entry ( "/dev/da%ds%d%c", 0, 1, 1, 4, "/dev/da%ds%d", 'a', 'h');
+ #elif defined(freebsd3)
+ Add_HR_Disk_entry ( "/dev/wd%ds%d%c", 0, 1, 1, 4, "/dev/wd%ds%d", 'a', 'h');
+ Add_HR_Disk_entry ( "/dev/sd%ds%d%c", 0, 1, 1, 4, "/dev/sd%ds%d", 'a', 'h');
diff --git a/net-mgmt/net-snmp/files/patch-hr_print.c b/net-mgmt/net-snmp/files/patch-hr_print.c
new file mode 100644
index 000000000000..ba8192ef59f5
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-hr_print.c
@@ -0,0 +1,12 @@
+--- agent/mibgroup/host/hr_print.c.orig Wed Oct 3 00:02:07 2001
++++ agent/mibgroup/host/hr_print.c Wed Feb 13 01:02:53 2002
+@@ -30,7 +30,9 @@
+ int printer_detail_status(int);
+ int printer_errors(int);
+ int header_hrprint (struct variable *,oid *, size_t *, int, size_t *, WriteMethod **);
++#ifdef HAVE_LPSTAT
+ FILE * run_lpstat(void);
++#endif
+
+
+ /*********************