aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Cisco-Reconfig
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 07:05:59 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-28 07:05:59 +0000
commitbd96c5b32c7081f134a76398afa48d532fe8bb1c (patch)
treecad66dce5979e1f0685efcb6249cb94a2c6d835c /net-mgmt/p5-Cisco-Reconfig
parent49c0e39450bc4cc37b9846750165e51a6912b379 (diff)
downloadports-bd96c5b32c7081f134a76398afa48d532fe8bb1c.tar.gz
ports-bd96c5b32c7081f134a76398afa48d532fe8bb1c.zip
Add p5-Cisco-Reconfig 0.8, parse and generate Cisco configuration files.
PR: ports/102490 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=174021
Diffstat (limited to 'net-mgmt/p5-Cisco-Reconfig')
-rw-r--r--net-mgmt/p5-Cisco-Reconfig/Makefile31
-rw-r--r--net-mgmt/p5-Cisco-Reconfig/distinfo3
-rw-r--r--net-mgmt/p5-Cisco-Reconfig/pkg-descr15
-rw-r--r--net-mgmt/p5-Cisco-Reconfig/pkg-plist7
4 files changed, 56 insertions, 0 deletions
diff --git a/net-mgmt/p5-Cisco-Reconfig/Makefile b/net-mgmt/p5-Cisco-Reconfig/Makefile
new file mode 100644
index 000000000000..a652e62eb11c
--- /dev/null
+++ b/net-mgmt/p5-Cisco-Reconfig/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Cisco-Reconfig
+# Date created: 2006-08-25
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cisco-Reconfig
+PORTVERSION= 0.8
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cisco
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Parse and generate Cisco configuration files
+
+RUN_DEPENDS= ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Cisco::Reconfig.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/p5-Cisco-Reconfig/distinfo b/net-mgmt/p5-Cisco-Reconfig/distinfo
new file mode 100644
index 000000000000..98aaa770870d
--- /dev/null
+++ b/net-mgmt/p5-Cisco-Reconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cisco-Reconfig-0.8.tar.gz) = 803dbcb4e7a8c180c7017983188c7f33
+SHA256 (Cisco-Reconfig-0.8.tar.gz) = 841093c752deb0df10bf5bc013b83058f60f709119f2c2f76d1ce383e71bd025
+SIZE (Cisco-Reconfig-0.8.tar.gz) = 17996
diff --git a/net-mgmt/p5-Cisco-Reconfig/pkg-descr b/net-mgmt/p5-Cisco-Reconfig/pkg-descr
new file mode 100644
index 000000000000..51e663be74fe
--- /dev/null
+++ b/net-mgmt/p5-Cisco-Reconfig/pkg-descr
@@ -0,0 +1,15 @@
+Cisco::Reconfig makes it easier to write programs to generate changes
+to Cisco configuration files.
+
+Cisco::Reconfig is a module that parses Cisco router configuration
+files. It doesn't have any real understanding of Cisco configurations
+so it might be useful for other similar configuration languages. It
+knows that nesting is shown by indentation. It knows that ! means a
+comment. It knows that no may proceed a line without changing where
+that line exists in the hierarchy. It doesn't know much else.
+
+Cisco::Reconfig can be used to modify configurations. The set() method
+will check the current configruation and return commands to change it
+if it is other than what is wanted (as passed to the set() method).
+
+WWW: http://search.cpan.org/dist/Cisco-Reconfig/
diff --git a/net-mgmt/p5-Cisco-Reconfig/pkg-plist b/net-mgmt/p5-Cisco-Reconfig/pkg-plist
new file mode 100644
index 000000000000..9641b1028519
--- /dev/null
+++ b/net-mgmt/p5-Cisco-Reconfig/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/Reconfig/.packlist
+%%SITE_PERL%%/Cisco/Reconfig.pm
+%%SITE_PERL%%/Cisco/Reconfig.pod
+@dirrmtry %%SITE_PERL%%/Cisco
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/Reconfig
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco