aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Net-IP/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-06-13 10:42:49 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-06-13 10:42:49 +0000
commit91176fb826137db9d1eccd90f40c183905b64f99 (patch)
treeef6ab9c3f5e8035018f634d750d9101fcebc8918 /net-mgmt/p5-Net-IP/Makefile
parentf79f718185fd811dd3f8dd8fc14b7bf0844b09cf (diff)
downloadports-91176fb826137db9d1eccd90f40c183905b64f99.tar.gz
ports-91176fb826137db9d1eccd90f40c183905b64f99.zip
Add p5-Net-IP 1.11, a perl extension for manipulating IPv4/IPv6
addresses. PR: 38738 Submitted by: Kimura Fuyuki <fuyuki@hadaly.org>
Notes
Notes: svn path=/head/; revision=61202
Diffstat (limited to 'net-mgmt/p5-Net-IP/Makefile')
-rw-r--r--net-mgmt/p5-Net-IP/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mgmt/p5-Net-IP/Makefile b/net-mgmt/p5-Net-IP/Makefile
new file mode 100644
index 000000000000..514fa74016e0
--- /dev/null
+++ b/net-mgmt/p5-Net-IP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IP
+# Date created: 30 May 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IP
+PORTVERSION= 1.11
+CATEGORIES= net perl5 ipv6
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fuyuki@hadaly.org
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::IP.3
+
+post-patch:
+ ${PERL} -pi -e 's,/usr/local/ncc/bin,${PREFIX}/bin,' ${WRKSRC}/Makefile.PL
+ ${PERL} -pi -e 's,/usr/local/bin/perl5.6.0,${PERL},' ${WRKSRC}/ipcount
+
+.include <bsd.port.mk>