aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmp++
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-08 14:39:51 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-08 14:39:51 +0000
commit00ac6f2705c187d83a6da5b39d12117188fd9071 (patch)
tree3e7938ba5818648503a20f2816bbe44fff12805d /net-mgmt/snmp++
parent055fbd52e4f3aae3d0083d47a59b08a0a0de2f5e (diff)
downloadports-00ac6f2705c187d83a6da5b39d12117188fd9071.tar.gz
ports-00ac6f2705c187d83a6da5b39d12117188fd9071.zip
Do not assume the compiler is g++
While here stage MFH: 2014Q1
Notes
Notes: svn path=/head/; revision=339140
Diffstat (limited to 'net-mgmt/snmp++')
-rw-r--r--net-mgmt/snmp++/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-mgmt/snmp++/Makefile b/net-mgmt/snmp++/Makefile
index 77f42d626598..15970bd26c8d 100644
--- a/net-mgmt/snmp++/Makefile
+++ b/net-mgmt/snmp++/Makefile
@@ -13,14 +13,15 @@ COMMENT= SNMP C++ library with V3 support
MAKEFILE= Makefile.FreeBSD
WRKSRC= ${WRKDIR}/${PORTNAME}/src
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
+MAKE_ARGS= CC="${CXX}"
-NO_STAGE= yes
post-extract:
${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
post-install:
- ${LN} -sf ${PREFIX}/lib/libsnmp++.so.2.0.0 ${PREFIX}/lib/libsnmp++.so
+ ${LN} -sf ${PREFIX}/lib/libsnmp++.so.2.0.0 ${STAGEDIR}${PREFIX}/lib/libsnmp++.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsnmp++.so.2.0.0
.include <bsd.port.mk>