aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/vidalia/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-09 10:08:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-09 10:08:58 +0000
commit7589c1d5224a71b3df6dfa1ce20cdb3e8f164636 (patch)
treec3fd98c729117c8b70d7cf7080b93a1372633867 /net-mgmt/vidalia/Makefile
parent31de7a68a4ce76e36226a5fca68961cde2b46e9d (diff)
downloadports-7589c1d5224a71b3df6dfa1ce20cdb3e8f164636.tar.gz
ports-7589c1d5224a71b3df6dfa1ce20cdb3e8f164636.zip
Vidalia is a graphical Tor controller based on Qt 4.x.
WWW: http://www.vidalia-project.net/ Authors: Matt Edman and Justin Hipple PR: ports/110034 Submitted by: Fabian Keil <fk at fabiankeil.de>
Notes
Notes: svn path=/head/; revision=186975
Diffstat (limited to 'net-mgmt/vidalia/Makefile')
-rw-r--r--net-mgmt/vidalia/Makefile59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-mgmt/vidalia/Makefile b/net-mgmt/vidalia/Makefile
new file mode 100644
index 000000000000..b4e8b65a2ad1
--- /dev/null
+++ b/net-mgmt/vidalia/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: vidalia
+# Date created: 2007-02-19
+# Whom: Fabian Keil <fk@fabiankeil.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vidalia
+PORTVERSION= 0.0.11
+CATEGORIES= net-mgmt security
+MASTER_SITES= http://vidalia-project.net:8001/\
+ http://tor.eff.org/dist/vidalia-bundles/
+
+MAINTAINER= fk@fabiankeil.de
+COMMENT= A graphical Tor controller based on Qt 4.x
+
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+HAS_CONFIGURE= yes
+
+USE_GMAKE= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui moc qmake rcc uic network xml linguist
+
+OPTIONS= TOR_DEVEL "Depend on tor-devel" On \
+ TOR "Depend on tor" Off
+
+HAVE_TOR_DEVEL!= if pkg_info -I tor-devel\* >/dev/null 2>&1 ; then ${ECHO} YES; fi
+.if (${HAVE_TOR_DEVEL} == "YES")
+OPTIONS= TOR_DEVEL "Depend on tor-devel (already installed)" On
+.else
+HAVE_TOR_DEVEL!= if pkg_info -I tor-\* >/dev/null 2>&1 ; then ${ECHO} YES; fi
+.endif
+.if (defined(HAVE_TOR) && ${HAVE_TOR} == "YES")
+OPTIONS= TOR "Depend on tor (already installed)" On
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_TOR_DEVEL)
+.if defined(WITH_TOR)
+IGNORE= cannot depend on tor and tor-devel at the same time
+.endif
+RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor-devel
+.elif defined(WITH_TOR)
+RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor
+.endif
+
+pre-extract:
+ @${CAT} ${PKGMESSAGE}
+
+post-configure:
+.if defined(TOR_CONTROL_ADDR)
+ ${REINPLACE_CMD} -e 's@127\.0\.0\.1@${TOR_CONTROL_ADDR}@' ${WRKSRC}/src/config/torsettings.cpp
+.endif
+ ${REINPLACE_CMD} -E -e 's@(INCPATH +=)@\1 -I${X11BASE}/include@' ${WRKSRC}/Makefile
+
+.include <bsd.port.post.mk>