aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-27 15:50:15 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-10-27 15:50:15 +0000
commit0f3e6d516dbc28721a6d7e46b6ceaa9138d17c7f (patch)
tree341393f18b2a678c3d023a904d1edc07b35b6285 /net-mgmt
parent0c86929baf622755d3968dd2bec2df0f1c8a4d9f (diff)
downloadports-0f3e6d516dbc28721a6d7e46b6ceaa9138d17c7f.tar.gz
ports-0f3e6d516dbc28721a6d7e46b6ceaa9138d17c7f.zip
- Update to 3.0.0
- Fix LICENSE and add LICENSE_FILE - Reformat pkg-descr Changes: https://github.com/rfinnie/2ping/commits/master
Notes
Notes: svn path=/head/; revision=400268
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/2ping/Makefile21
-rw-r--r--net-mgmt/2ping/distinfo4
-rw-r--r--net-mgmt/2ping/files/patch-twoping_crc32.py20
-rw-r--r--net-mgmt/2ping/pkg-descr7
4 files changed, 31 insertions, 21 deletions
diff --git a/net-mgmt/2ping/Makefile b/net-mgmt/2ping/Makefile
index 18773d807ab9..8ff5cde73dfa 100644
--- a/net-mgmt/2ping/Makefile
+++ b/net-mgmt/2ping/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= 2ping
-PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTVERSION= 3.0.0
CATEGORIES= net-mgmt perl5
MASTER_SITES= http://www.finnie.org/software/2ping/ \
LOCAL/sunpoet
@@ -10,20 +9,12 @@ MASTER_SITES= http://www.finnie.org/software/2ping/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Bi-directional ping utility
-LICENSE= GPLv2
-
-BUILD_DEPENDS= p5-Digest-CRC>=0:${PORTSDIR}/security/p5-Digest-CRC \
- p5-IO-Socket-INET6>=0:${PORTSDIR}/net/p5-IO-Socket-INET6
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
NO_ARCH= yes
-USE_PERL5= configure
-USES= perl5
-
-PLIST_FILES= bin/2ping \
- %%PERL5_MAN1%%/2ping.1.gz
-
-post-patch:
- @${REINPLACE_CMD} -e 's|2ping.1p|2ping.1|' ${WRKSRC}/Makefile.PL
+USE_PYTHON= autoplist concurrent distutils
+USES= python
.include <bsd.port.mk>
diff --git a/net-mgmt/2ping/distinfo b/net-mgmt/2ping/distinfo
index 09e0b82cc1d9..8e0817294c9c 100644
--- a/net-mgmt/2ping/distinfo
+++ b/net-mgmt/2ping/distinfo
@@ -1,2 +1,2 @@
-SHA256 (2ping-2.1.1.tar.gz) = 20fc09dbbc7fa37b90bfa415bad801697bd56c16c653cda551bfadbad3936f65
-SIZE (2ping-2.1.1.tar.gz) = 27232
+SHA256 (2ping-3.0.0.tar.gz) = 8a8f071ea87414a5a7b8503ee75529e81b04f4d6251f96f3ead2140998a10c31
+SIZE (2ping-3.0.0.tar.gz) = 37263
diff --git a/net-mgmt/2ping/files/patch-twoping_crc32.py b/net-mgmt/2ping/files/patch-twoping_crc32.py
new file mode 100644
index 000000000000..02d4ad50f6c3
--- /dev/null
+++ b/net-mgmt/2ping/files/patch-twoping_crc32.py
@@ -0,0 +1,20 @@
+--- twoping/crc32.py.orig 2015-10-25 05:57:43 UTC
++++ twoping/crc32.py
+@@ -69,7 +69,7 @@ if __name__ == '__main__':
+ c = new()
+ for line in sys.stdin.readlines():
+ c.update(line)
+- print c.hexdigest()
++ print(c.hexdigest())
+ else:
+ for file in files:
+ with open(file) as f:
+@@ -77,6 +77,6 @@ if __name__ == '__main__':
+ for line in f.readlines():
+ c.update(line)
+ if len(files) > 1:
+- print '%s\t%s' % (c.hexdigest(), file)
++ print('%s\t%s' % (c.hexdigest(), file))
+ else:
+- print c.hexdigest()
++ print(c.hexdigest())
diff --git a/net-mgmt/2ping/pkg-descr b/net-mgmt/2ping/pkg-descr
index 418204e71023..d63e1e0bffe7 100644
--- a/net-mgmt/2ping/pkg-descr
+++ b/net-mgmt/2ping/pkg-descr
@@ -1,6 +1,5 @@
-2ping is a bi-directional ping utility. It uses 3-way pings (akin to
-TCP SYN, SYN/ACK, ACK) and after-the-fact state comparison between a
-2ping listener and a 2ping client to determine which direction packet
-loss occurs.
+2ping is a bi-directional ping utility. It uses 3-way pings (akin to TCP SYN,
+SYN/ACK, ACK) and after-the-fact state comparison between a 2ping listener and a
+2ping client to determine which direction packet loss occurs.
WWW: http://www.finnie.org/software/2ping/