aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-09-03 21:07:17 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-09-03 21:07:17 +0000
commit0090808295dbe0366733c7871468f154c19d17e8 (patch)
treecdbc504d12ee8db825712bef5ec2e47a54174d4a /net-mgmt
parentf9d68c28cd5becf26206cdaa9e2ed8c717c3f5b3 (diff)
downloadports-0090808295dbe0366733c7871468f154c19d17e8.tar.gz
ports-0090808295dbe0366733c7871468f154c19d17e8.zip
Allow staging as a regular user
Notes
Notes: svn path=/head/; revision=367236
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/arpwatch/Makefile9
-rw-r--r--net-mgmt/arpwatch/files/patch-Makefile.in19
-rw-r--r--net-mgmt/arpwatch/pkg-plist2
3 files changed, 15 insertions, 15 deletions
diff --git a/net-mgmt/arpwatch/Makefile b/net-mgmt/arpwatch/Makefile
index 957182230f51..9bf0f6ffb1ee 100644
--- a/net-mgmt/arpwatch/Makefile
+++ b/net-mgmt/arpwatch/Makefile
@@ -16,7 +16,6 @@ LICENSE= BSD3CLAUSE
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --quiet
-MAKE_ENV+= BINOWN="${BINOWN}" BINGRP="${BINGRP}"
INSTALL_TARGET= install install-man
SUB_FILES= pkg-message
@@ -27,13 +26,7 @@ MAKE_ARGS= ARPDIR=${ARPDIR}
.endif
post-install:
- if [ ! -d ${STAGEDIR}${PREFIX}/arpwatch ]; then \
- ${MKDIR} ${STAGEDIR}${PREFIX}/arpwatch; \
- ${CHMOD} 755 ${STAGEDIR}${PREFIX}/arpwatch; \
- ${CHOWN} root:operator ${STAGEDIR}${PREFIX}/arpwatch; \
- fi
- ${TOUCH} ${STAGEDIR}${PREFIX}/arpwatch/arp.dat
- ${CHMOD} 644 ${STAGEDIR}${PREFIX}/arpwatch/arp.dat
+ ${MKDIR} ${STAGEDIR}${PREFIX}/arpwatch
for files in ethercodes.dat d.awk duplicates.awk euppertolower.awk e.awk p.awk; do \
${INSTALL_DATA} ${WRKSRC}/$$files ${STAGEDIR}${PREFIX}/arpwatch; \
done
diff --git a/net-mgmt/arpwatch/files/patch-Makefile.in b/net-mgmt/arpwatch/files/patch-Makefile.in
index e9e2f747c050..b5f40ae58f9f 100644
--- a/net-mgmt/arpwatch/files/patch-Makefile.in
+++ b/net-mgmt/arpwatch/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Thu Jun 15 02:39:55 2000
-+++ Makefile.in Tue Nov 14 15:28:00 2006
+--- Makefile.in.orig 2000-06-15 00:39:55 UTC
++++ Makefile.in
@@ -31,7 +31,7 @@
# Pathname of directory to install the man page
MANDEST = @mandir@
@@ -18,14 +18,21 @@
# Standard CFLAGS
CFLAGS = $(CCOPT) $(DEFS) $(INCLS)
-@@ -110,8 +110,8 @@
+@@ -110,13 +110,13 @@
$(CC) $(CFLAGS) -o $@ zap.o intoa.o -lutil
install: force
- $(INSTALL) -m 555 -o bin -g bin arpwatch $(DESTDIR)$(BINDEST)
- $(INSTALL) -m 555 -o bin -g bin arpsnmp $(DESTDIR)$(BINDEST)
-+ $(INSTALL) -s -m 555 -o $(BINOWN) -g $(BINGRP) arpwatch $(DESTDIR)$(BINDEST)
-+ $(INSTALL) -s -m 555 -o $(BINOWN) -g $(BINGRP) arpsnmp $(DESTDIR)$(BINDEST)
++ $(BSD_INSTALL_PROGRAM) arpwatch $(DESTDIR)$(BINDEST)
++ $(BSD_INSTALL_PROGRAM) arpsnmp $(DESTDIR)$(BINDEST)
install-man: force
- $(INSTALL) -m 444 -o bin -g bin $(srcdir)/arpwatch.8 \
+- $(INSTALL) -m 444 -o bin -g bin $(srcdir)/arpwatch.8 \
++ $(BSD_INSTALL_MAN) $(srcdir)/arpwatch.8 \
+ $(DESTDIR)$(MANDEST)/man8
+- $(INSTALL) -m 444 -o bin -g bin $(srcdir)/arpsnmp.8 \
++ $(BSD_INSTALL_MAN) $(srcdir)/arpsnmp.8 \
+ $(DESTDIR)$(MANDEST)/man8
+
+ lint: $(GENSRC) force
diff --git a/net-mgmt/arpwatch/pkg-plist b/net-mgmt/arpwatch/pkg-plist
index 91455458ac9a..3ff0bc9759e6 100644
--- a/net-mgmt/arpwatch/pkg-plist
+++ b/net-mgmt/arpwatch/pkg-plist
@@ -12,4 +12,4 @@ sbin/arpsnmp
sbin/arpwatch
@unexec test -f %D/arpwatch/arp.dat && test -s %D/arpwatch/arp.dat || rm -f %D/arpwatch/arp.dat
@exec test -f %D/arpwatch/arp.dat || touch %D/arpwatch/arp.dat
-@dirrm arpwatch
+@dirrm(,operator,0755) arpwatch