aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-06-09 23:35:21 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-06-09 23:35:21 +0000
commit167d67714435c7cda231c22dd0ff00ae840bfb34 (patch)
tree3370ad621000b8fe13d4a324b4fe58d52cbab4c3 /net-mgmt
parent9c88911ece590ff87fa984dad92e782bca109bf3 (diff)
downloadports-167d67714435c7cda231c22dd0ff00ae840bfb34.tar.gz
ports-167d67714435c7cda231c22dd0ff00ae840bfb34.zip
- Fix config with both sflow and netflow
- Bump PORTREVISION PR: ports/168230 Submitted by: Vincent Hoffman <vince@unsane.co.uk> Approved by: maintainer (timeout, 15 days)
Notes
Notes: svn path=/head/; revision=298890
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/nfsen/Makefile2
-rw-r--r--net-mgmt/nfsen/files/patch-libexec__NFSenRC.pm32
2 files changed, 33 insertions, 1 deletions
diff --git a/net-mgmt/nfsen/Makefile b/net-mgmt/nfsen/Makefile
index 291cbd62005d..11314aca9bd4 100644
--- a/net-mgmt/nfsen/Makefile
+++ b/net-mgmt/nfsen/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nfsen
PORTVERSION= 1.3.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION} \
http://nfsen.sourceforge.net/
diff --git a/net-mgmt/nfsen/files/patch-libexec__NFSenRC.pm b/net-mgmt/nfsen/files/patch-libexec__NFSenRC.pm
new file mode 100644
index 000000000000..9d63727d5a85
--- /dev/null
+++ b/net-mgmt/nfsen/files/patch-libexec__NFSenRC.pm
@@ -0,0 +1,32 @@
+--- libexec/NfSenRC.pm 2010-09-09 07:56:05.000000000 +0200
++++ libexec/NfSenRC.pm.patched 2011-03-09 13:09:32.000000000 +0100
+@@ -54,22 +54,21 @@
+ print "[no collector]";
+ return;
+ }
+-
+ my @SourceList;
+ my $type = undef;
+ foreach my $source ( sort keys %NfConf::sources ) {
+ my $_port = $NfConf::sources{$source}{'port'};
+ if ( $_port == $port ) {
+ push @SourceList, $source;
+- }
+- my $_type = exists $NfConf::sources{$source}{'type'} ? $NfConf::sources{$source}{'type'}: 'netflow';
+- if ( defined $type ) {
+- if ( $type ne $_type ) {
+- print "Can not start different type '$type' and '$_type' on same port!\n";
+- return;
++ my $_type = exists $NfConf::sources{$source}{'type'} ? $NfConf::sources{$source}{'type'}: 'netflow';
++ if ( defined $type ) {
++ if ( $type ne $_type ) {
++ print "Can not start different type '$type' and '$_type' on same port!\n";
++ return;
++ }
++ } else {
++ $type = $_type;
+ }
+- } else {
+- $type = $_type;
+ }
+ }