aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-10-14 16:01:11 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-10-14 16:01:11 +0000
commit890fe437394db53d6cf723f88b9b4da5ea0c6516 (patch)
tree79a18fe58ae3c1faf7cd356d1fbfda0a5566e6ab /net-mgmt
parent23a445abcc9dd15f1c63303324204d3dc6121aec (diff)
downloadports-890fe437394db53d6cf723f88b9b4da5ea0c6516.tar.gz
ports-890fe437394db53d6cf723f88b9b4da5ea0c6516.zip
Update to 0.6.b.
- gtk2 support - new sniffing method was added as a plugin - three new plugins - bumb PORTEPOCH, otherwise 0.6.b (they mean hex B) wouldn't be recognised as newer by pkg_version etc. - add 'security' as a second category (as nmap and friends are mainly there) - respect CFLAGS, PTHREAD_CFLAGS and PTHREAD_LIBS - make SSL-support optional - base compilation of gnome frontend on autodetection of installed gtk20, use gnome-PKGNAMESUFFIX - disable auto-download of new version via wget (saves dependency on wget, FreeBSD-users should update via the ports-collection anyway) - enable compilation and installation of the plug-ins - compile lc-converter (an application port IMO should not install sources) - don't install ettercap.fr.8.in Submitted by: Marius Strobl <marius@alchemy.franken.de> PR: 51898 Approved by: maintainer timeout (~5 months)
Notes
Notes: svn path=/head/; revision=91214
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ettercap/Makefile49
-rw-r--r--net-mgmt/ettercap/distinfo2
-rw-r--r--net-mgmt/ettercap/files/patch-aa39
-rw-r--r--net-mgmt/ettercap/files/patch-ab90
-rw-r--r--net-mgmt/ettercap/files/patch-plugins::H03_hydra1::Makefile.in11
-rw-r--r--net-mgmt/ettercap/files/patch-plugins::Makefile.in11
-rw-r--r--net-mgmt/ettercap/pkg-plist37
7 files changed, 217 insertions, 22 deletions
diff --git a/net-mgmt/ettercap/Makefile b/net-mgmt/ettercap/Makefile
index 5e3bd97529be..23a4bd9a46df 100644
--- a/net-mgmt/ettercap/Makefile
+++ b/net-mgmt/ettercap/Makefile
@@ -6,8 +6,9 @@
#
PORTNAME= ettercap
-PORTVERSION= 0.6.7
-CATEGORIES= net
+PORTVERSION= 0.6.b
+PORTEPOCH= 1
+CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_PACKETSTORM:S:%SUBDIR%:sniffers/ettercap:}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +16,50 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= greid@FreeBSD.org
COMMENT= A network sniffer/interceptor/injector/logger for switched LANs
+USE_REINPLACE= yes
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+.endif
GNU_CONFIGURE= yes
+WANT_GNOME= yes
+
+MAN8= ettercap.8
+.include <bsd.port.pre.mk>
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+CONFIGURE_TARGET= -build=${ARCH}-portbld-freebsd${OSREL}
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS= --without-openssl
+PLIST_SUB+= SSL="@comment "
+.else
+CONFIGURE_ARGS= --with-openssl=${OPENSSLBASE}
+PLIST_SUB+= SSL=""
+.endif
+.if ${HAVE_GNOME:Mgtk20}!=""
+USE_GNOME+= gtk20
+PKGNAMESUFFIX= -gnome
+.else
+CONFIGURE_ARGS+= --disable-gtk
+.endif
+CONFIGURE_ENV= WGET_PATH=""
+
+ALL_TARGET= all plug-ins
+
+INSTALL_TARGET= install plug-ins_install
.if !defined(NOPORTDOCS)
-INSTALL_TARGET= install install-doc
+INSTALL_TARGET+= install-doc
.endif
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${MV} -f ${WRKSRC}/share/lc-converter.c ${WRKSRC}
-MAN8= ettercap.8
+post-build:
+ ${CC} ${CFLAGS} -o ${WRKSRC}/lc-converter ${WRKSRC}/lc-converter.c
+
+post-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/lc-converter ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/ettercap/distinfo b/net-mgmt/ettercap/distinfo
index 5ca3899f184e..238865f791af 100644
--- a/net-mgmt/ettercap/distinfo
+++ b/net-mgmt/ettercap/distinfo
@@ -1 +1 @@
-MD5 (ettercap-0.6.7.tar.gz) = 0a4796e9cfab826f27ddfef479c37a62
+MD5 (ettercap-0.6.b.tar.gz) = f665cf82347a91f216184537f8f2c4bd
diff --git a/net-mgmt/ettercap/files/patch-aa b/net-mgmt/ettercap/files/patch-aa
index 0e8d4b4087e3..c38436d908ad 100644
--- a/net-mgmt/ettercap/files/patch-aa
+++ b/net-mgmt/ettercap/files/patch-aa
@@ -1,25 +1,46 @@
--- Makefile.in.orig Thu Jun 27 19:27:33 2002
+++ Makefile.in Wed Jul 17 17:06:29 2002
-@@ -70,10 +70,7 @@
+@@ -25,10 +25,10 @@
+ DOC = COPYING README README.PLUGINS README.WIN32 CHANGELOG HISTORY \
+ AUTHORS TODO TODO.WIN32 THANKS KNOWN-BUGS PORTINGS INSTALL \
+ ./plugins/H01_zaratan/ZARATAN.HOWTO ./plugins/H09_roper/ROPER.HOWTO \
+- ./plugins/H03_hydra1/HYDRA.HOWTO
++ ./plugins/H03_hydra1/HYDRA.HOWTO ./plugins/confusion/CONFUSION.HOWTO
+
+ DEBUG = @DEBUG@
+-CFLAG = @E_CFLAGS@
++CFLAG = @CFLAGS@
+ COPTS = -I. -Isrc/include @COPTS@ @GTK_CFLAGS@
+
+ PROG = @PROG@
+@@ -74,12 +74,7 @@
$(INSTALL) -m 644 ./etter.filter.ssh $(DESTDIR)$(DATADIR)
$(INSTALL) -m 644 ./etter.passive.os.fp $(DESTDIR)$(DATADIR)
$(INSTALL) -m 644 ./etter.ssl.crt $(DESTDIR)$(DATADIR)
- $(INSTALL) -d $(DESTDIR)$(DOCDIR)
- $(INSTALL) -m 644 $(DOC) $(DESTDIR)$(DOCDIR)
+- $(INSTALL) -m 644 ./THANKS $(DESTDIR)$(DATADIR)
+- $(INSTALL) -m 644 ./AUTHORS $(DESTDIR)$(DATADIR)
-$(INSTALL) -m 644 ./share/[a-z]* $(DESTDIR)$(DATADIR)
- -$(INSTALL) -m 644 ./docs/[a-z]*/[a-z]* $(DESTDIR)$(DOCDIR)
$(INSTALL) -d $(DESTDIR)$(MANDIR)/man8
$(INSTALL) -m 644 $(PROG).8 $(DESTDIR)$(MANDIR)/man8/$(PROG).8
@echo
-@@ -86,6 +83,11 @@
- @echo
- @echo "=============================================================="
- @echo
+@@ -88,6 +83,17 @@
+ @echo "@SB@ $(PROG)@EB@ installed in @SB@$(DESTDIR)$(BINDIR) @EB@"
+ @echo "@SB@ shared files@EB@ installed in @SB@$(DESTDIR)$(DATADIR) @EB@"
+ @echo "@SB@ man pages@EB@ installed in @SB@$(DESTDIR)$(MANDIR)/man8/ @EB@"
++ @echo
++ @echo "=============================================================="
++ @echo
+
+install-doc:
+ $(INSTALL) -d $(DESTDIR)$(DOCDIR)
+ $(INSTALL) -m 644 $(DOC) $(DESTDIR)$(DOCDIR)
-+ -$(INSTALL) -m 644 ./docs/[a-z]*/[a-z]* $(DESTDIR)$(DOCDIR)
-
- plug-ins: src/include/ec_install_path.h
- @if test "@MAKEPLUG@" = "0"; then \
++ -$(INSTALL) -m 644 ./docs/development/[a-z]* $(DESTDIR)$(DOCDIR)
++ @echo
++ @echo "=============================================================="
++ @echo
+ @echo "@SB@ DOCS@EB@ installed in @SB@$(DESTDIR)$(DOCDIR) @EB@"
+ @echo
+ @echo "=============================================================="
diff --git a/net-mgmt/ettercap/files/patch-ab b/net-mgmt/ettercap/files/patch-ab
index d74dd04de9cd..d7876586b364 100644
--- a/net-mgmt/ettercap/files/patch-ab
+++ b/net-mgmt/ettercap/files/patch-ab
@@ -1,19 +1,99 @@
--- configure.orig Fri Jun 14 18:53:14 2002
+++ configure Wed Jul 17 17:09:18 2002
-@@ -8554,14 +8554,14 @@
+@@ -3924,27 +3924,27 @@
+ if test "${ac_cv_path_WGET_PATH+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+- case $WGET_PATH in
+- [\\/]* | ?:[\\/]*)
++# case $WGET_PATH in
++# [\\/]* | ?:[\\/]*)
+ ac_cv_path_WGET_PATH="$WGET_PATH" # Let the user override the test with a path.
+- ;;
+- *)
+- as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $PATH
+-do
+- IFS=$as_save_IFS
+- test -z "$as_dir" && as_dir=.
+- for ac_exec_ext in '' $ac_executable_extensions; do
+- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
+- ac_cv_path_WGET_PATH="$as_dir/$ac_word$ac_exec_ext"
+- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
+- break 2
+- fi
+-done
+-done
++# ;;
++# *)
++# as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
++#for as_dir in $PATH
++#do
++# IFS=$as_save_IFS
++# test -z "$as_dir" && as_dir=.
++# for ac_exec_ext in '' $ac_executable_extensions; do
++# if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
++# ac_cv_path_WGET_PATH="$as_dir/$ac_word$ac_exec_ext"
++# echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
++# break 2
++# fi
++#done
++#done
+
+- ;;
+-esac
++# ;;
++#esac
+ fi
+ WGET_PATH=$ac_cv_path_WGET_PATH
+
+@@ -6735,7 +6735,6 @@
+ echo "$as_me:$LINENO: checking whether $CC accepts -pthread" >&5
+ echo $ECHO_N "checking whether $CC accepts -pthread... $ECHO_C" >&6
+ CFLAGS_store="$CFLAGS"
+- CFLAGS="$CFLAGS -pthread"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ /* confdefs.h. */
+@@ -9656,14 +9655,14 @@
;;
no) echo "$as_me:$LINENO: result: no." >&5
echo "${ECHO_T}no." >&6
-- E_CFLAGS="-O3 -funroll-loops -fomit-frame-pointer -Wall"
-+# E_CFLAGS="-O3 -funroll-loops -fomit-frame-pointer -Wall"
+- E_CFLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
++# E_CFLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
ac_cv_ec_debug=no
;;
esac
else
echo "$as_me:$LINENO: result: no. disabled by default." >&5
echo "${ECHO_T}no. disabled by default." >&6
-- E_CFLAGS="-O3 -funroll-loops -fomit-frame-pointer -Wall"
-+# E_CFLAGS="-O3 -funroll-loops -fomit-frame-pointer -Wall"
+- E_CFLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
++# E_CFLAGS="-O2 -funroll-loops -fomit-frame-pointer -Wall"
ac_cv_ec_debug=no
fi;
+@@ -10085,6 +10084,8 @@
+ if test $ac_cv_ec_ssh = "yes"; then
+ CYGWINLIB="$CYGWINLIB cygcrypto.dll cygssl.dll"
+ echo "Dissector_ssh" >> ./src/ec_add.def
++ else
++ PLUGINS_SOURCES=`echo $PLUGINS_SOURCES | sed 's/.\/plugins\/H03_hydra1\/H03_hydra1.c//g'`
+ fi
+
+
+@@ -10238,9 +10239,15 @@
+ if test "$ac_cv_ec_plugin" = "yes"; then
+
+ PLUGINS=`ls ./plugins | grep -v Make | grep -v CVS | awk ' { printf "%s ", $1 } '`
++ if test $ac_cv_ec_ssh = "no"; then
++ PLUGINS=`echo $PLUGINS | sed 's/H03_hydra1//g'`
++ fi
+
+
+ makeplug=`ls ./plugins | grep -v Make | grep -v CVS | awk '{ printf("plugins/%s/Makefile ", $1) }'`
++ if test $ac_cv_ec_ssh = "no"; then
++ makeplug=`echo $makeplug | sed 's/plugins\/H03_hydra1\/Makefile//g'`
++ fi
+ makeplug="plugins/Makefile $makeplug"
+ MAKEPLUG="1"
+ else
diff --git a/net-mgmt/ettercap/files/patch-plugins::H03_hydra1::Makefile.in b/net-mgmt/ettercap/files/patch-plugins::H03_hydra1::Makefile.in
new file mode 100644
index 000000000000..fe888fe1146b
--- /dev/null
+++ b/net-mgmt/ettercap/files/patch-plugins::H03_hydra1::Makefile.in
@@ -0,0 +1,11 @@
+--- plugins/H03_hydra1/Makefile.in.orig Sun May 4 18:58:02 2003
++++ plugins/H03_hydra1/Makefile.in Sun May 4 18:58:37 2003
+@@ -3,7 +3,7 @@
+ DEFS = @PICFLAG@ @DEFS@ -D@OS@
+
+ CFLAG = @CFLAGS@
+-COPTS = -I../..
++COPTS = -I../.. @COPTS@
+
+ PROG = H03_hydra1
+
diff --git a/net-mgmt/ettercap/files/patch-plugins::Makefile.in b/net-mgmt/ettercap/files/patch-plugins::Makefile.in
new file mode 100644
index 000000000000..efc2b4ff39dd
--- /dev/null
+++ b/net-mgmt/ettercap/files/patch-plugins::Makefile.in
@@ -0,0 +1,11 @@
+--- plugins/Makefile.in.orig Sun May 4 01:59:51 2003
++++ plugins/Makefile.in Sun May 4 02:00:18 2003
+@@ -13,7 +13,7 @@
+ make -C $$plug; \
+ done
+
+-install: plugins
++install:
+ for plug in $(PLUGINS); do \
+ $(INSTALL) -d $(DESTDIR)$(PLUGDIR) ; \
+ $(INSTALL) -m 700 ./$$plug/ec_$$plug.so $(DESTDIR)$(PLUGDIR) ; \
diff --git a/net-mgmt/ettercap/pkg-plist b/net-mgmt/ettercap/pkg-plist
index 54b61479a6e8..5cf3cd1a356e 100644
--- a/net-mgmt/ettercap/pkg-plist
+++ b/net-mgmt/ettercap/pkg-plist
@@ -1,7 +1,9 @@
%%PORTDOCS%%share/doc/ettercap/AUTHORS
%%PORTDOCS%%share/doc/ettercap/CHANGELOG
+%%PORTDOCS%%share/doc/ettercap/CONFUSION.HOWTO
%%PORTDOCS%%share/doc/ettercap/COPYING
%%PORTDOCS%%share/doc/ettercap/HISTORY
+%%PORTDOCS%%share/doc/ettercap/HYDRA.HOWTO
%%PORTDOCS%%share/doc/ettercap/INSTALL
%%PORTDOCS%%share/doc/ettercap/KNOWN-BUGS
%%PORTDOCS%%share/doc/ettercap/PORTINGS
@@ -15,8 +17,40 @@
%%PORTDOCS%%share/doc/ettercap/ZARATAN.HOWTO
%%PORTDOCS%%share/doc/ettercap/debug.txt
%%PORTDOCS%%share/doc/ettercap/errors.txt
-%%PORTDOCS%%share/doc/ettercap/ettercap.fr.8.in
%%PORTDOCS%%share/doc/ettercap/threads.txt
+bin/lc-converter
+lib/ettercap/ec_H00_lurker.so
+lib/ettercap/ec_H01_zaratan.so
+lib/ettercap/ec_H02_troll.so
+%%SSL%%lib/ettercap/ec_H03_hydra1.so
+lib/ettercap/ec_H04_hydra2.so
+lib/ettercap/ec_H05_hydra3.so
+lib/ettercap/ec_H06_hydra4.so
+lib/ettercap/ec_H07_hydra5.so
+lib/ettercap/ec_H08_hydra6.so
+lib/ettercap/ec_H09_roper.so
+lib/ettercap/ec_H10_phantom.so
+lib/ettercap/ec_H12_giant1.so
+lib/ettercap/ec_H13_giant2.so
+lib/ettercap/ec_H20_dwarf.so
+lib/ettercap/ec_H30_thief.so
+lib/ettercap/ec_H99_dummy.so
+lib/ettercap/ec_arpcop.so
+lib/ettercap/ec_banshee.so
+lib/ettercap/ec_basilisk.so
+lib/ettercap/ec_beholder.so
+lib/ettercap/ec_confusion.so
+lib/ettercap/ec_dummy.so
+lib/ettercap/ec_golem.so
+lib/ettercap/ec_hunter.so
+lib/ettercap/ec_imp.so
+lib/ettercap/ec_lamia.so
+lib/ettercap/ec_leech.so
+lib/ettercap/ec_ooze.so
+lib/ettercap/ec_phantom.so
+lib/ettercap/ec_shadow.so
+lib/ettercap/ec_spectre.so
+lib/ettercap/ec_triton.so
sbin/ettercap
share/ettercap/etter.conf
share/ettercap/etter.dns
@@ -28,5 +62,6 @@ share/ettercap/etter.ssl.crt
share/ettercap/mac-fingerprints
share/ettercap/nmap-os-fingerprints
share/ettercap/services
+@dirrm lib/ettercap
@dirrm share/ettercap
%%PORTDOCS%%@dirrm share/doc/ettercap