aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:16:14 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-11 18:16:14 +0000
commit99a390f50bab457f60aec3050c18c4b5c5fb7023 (patch)
treefb6e1d6bcf31a0efb7675597b7fa4f423710c0bb /net-mgmt
parent31f779fa09467bfcb2c12e2ad95525a75e526bc8 (diff)
downloadports-99a390f50bab457f60aec3050c18c4b5c5fb7023.tar.gz
ports-99a390f50bab457f60aec3050c18c4b5c5fb7023.zip
o Change library name from libgd to libgd1.
o Do not install everything except headers and libraries (to avoid conflicting with graphics/gd2) o Fix dependency on new libgd1(for many ports). PR: ports/54100 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=84696
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/mrtg/Makefile9
-rw-r--r--net-mgmt/mrtg/files/patch-configure120
-rw-r--r--net-mgmt/nagios/Makefile16
-rw-r--r--net-mgmt/nagios12/Makefile16
-rw-r--r--net-mgmt/nagios2/Makefile16
5 files changed, 163 insertions, 14 deletions
diff --git a/net-mgmt/mrtg/Makefile b/net-mgmt/mrtg/Makefile
index 9129659de996..c0784deb2d99 100644
--- a/net-mgmt/mrtg/Makefile
+++ b/net-mgmt/mrtg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mrtg
PORTVERSION= 2.9.29
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://people.ee.ethz.ch/~oetiker/webtools/mrtg/pub/ \
@@ -25,7 +25,7 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
--with-gd-inc=${LOCALBASE}/include
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
--with-gd-inc=${LOCALBASE}/include/gd
.endif
@@ -43,6 +43,11 @@ MAN1= cfgmaker.1 contrib.1 faq.1 forum.1 indexmaker.1 logfile.1 \
post-patch:
${RM} ${WRKSRC}/lib/mrtg2/BER.pm ${WRKSRC}/lib/mrtg2/SNMP_*.pm
+.if defined(WITH_GD2)
+ ${PERL} -pi -e 's:%%GD%%:-lgd:g' ${WRKSRC}/configure
+.else
+ ${PERL} -pi -e 's:%%GD%%:-lgd1:g' ${WRKSRC}/configure
+.endif
do-install:
${MKDIR} -m 755 ${PREFIX}/etc/mrtg
diff --git a/net-mgmt/mrtg/files/patch-configure b/net-mgmt/mrtg/files/patch-configure
new file mode 100644
index 000000000000..4fe9b654edc6
--- /dev/null
+++ b/net-mgmt/mrtg/files/patch-configure
@@ -0,0 +1,120 @@
+--- configure.orig Sun Mar 9 02:17:40 2003
++++ configure Sat Jul 5 23:55:07 2003
+@@ -3159,13 +3159,13 @@
+ LDFLAGS="${LDFLAGS} ${MATHLIBS}"
+
+ GDEXTRALIB=""
+-echo "$as_me:$LINENO: checking for gdImageGif in -lgd" >&5
+-echo $ECHO_N "checking for gdImageGif in -lgd... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for gdImageGif in %%GD%%" >&5
++echo $ECHO_N "checking for gdImageGif in %%GD%%... $ECHO_C" >&6
+ if test "${ac_cv_lib_gd_gdImageGif+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgd -lgd ${MATHLIBS} $LIBS"
++LIBS="%%GD%% %%GD%% ${MATHLIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
+@@ -3211,20 +3211,20 @@
+ if test $ac_cv_lib_gd_gdImageGif = yes; then
+
+ GDFORM_EXT=gif
+- GLIBS="-lgd"
++ GLIBS="%%GD%%"
+
+ else
+ :
+ fi
+
+
+-echo "$as_me:$LINENO: checking for gdImagePng in -lgd" >&5
+-echo $ECHO_N "checking for gdImagePng in -lgd... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for gdImagePng in %%GD%%" >&5
++echo $ECHO_N "checking for gdImagePng in %%GD%%... $ECHO_C" >&6
+ if test "${ac_cv_lib_gd_gdImagePng+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgd -lgd -lpng -lz ${MATHLIBS} $LIBS"
++LIBS="%%GD%% %%GD%% -lpng -lz ${MATHLIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
+@@ -3270,20 +3270,20 @@
+ if test $ac_cv_lib_gd_gdImagePng = yes; then
+
+ GDFORM_EXT=png
+- GLIBS="-lgd -lpng -lz"
++ GLIBS="%%GD%% -lpng -lz"
+
+ else
+ :
+ fi
+
+
+-echo "$as_me:$LINENO: checking for gdImagePng_jpg in -lgd" >&5
+-echo $ECHO_N "checking for gdImagePng_jpg in -lgd... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for gdImagePng_jpg in %%GD%%" >&5
++echo $ECHO_N "checking for gdImagePng_jpg in %%GD%%... $ECHO_C" >&6
+ if test "${ac_cv_lib_gd_gdImagePng_jpg+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgd -lgd -lpng -lz -ljpeg ${MATHLIBS} $LIBS"
++LIBS="%%GD%% %%GD%% -lpng -lz -ljpeg ${MATHLIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
+@@ -3329,20 +3329,20 @@
+ if test $ac_cv_lib_gd_gdImagePng_jpg = yes; then
+
+ GDFORM_EXT=png
+- GLIBS="-lgd -lpng -lz -ljpeg"
++ GLIBS="%%GD%% -lpng -lz -ljpeg"
+
+ else
+ :
+ fi
+
+
+-echo "$as_me:$LINENO: checking for gdImagePng_jpg_ft in -lgd" >&5
+-echo $ECHO_N "checking for gdImagePng_jpg_ft in -lgd... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for gdImagePng_jpg_ft in %%GD%%" >&5
++echo $ECHO_N "checking for gdImagePng_jpg_ft in %%GD%%... $ECHO_C" >&6
+ if test "${ac_cv_lib_gd_gdImagePng_jpg_ft+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgd -lgd -lpng -lz -ljpeg -lfreetype ${MATHLIBS} $LIBS"
++LIBS="%%GD%% %%GD%% -lpng -lz -ljpeg -lfreetype ${MATHLIBS} $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
+@@ -3388,7 +3388,7 @@
+ if test $ac_cv_lib_gd_gdImagePng_jpg_ft = yes; then
+
+ GDFORM_EXT=png
+- GLIBS="-lgd -lpng -lz -ljpeg -lfreetype"
++ GLIBS="%%GD%% -lpng -lz -ljpeg -lfreetype"
+
+ else
+ :
+@@ -3399,13 +3399,13 @@
+ CPPFLAGS="$CPPFLAGS -DGFORM_GD=gdImageGif"
+ fi
+
+-echo "$as_me:$LINENO: checking for gdImageGd in -lgd" >&5
+-echo $ECHO_N "checking for gdImageGd in -lgd... $ECHO_C" >&6
++echo "$as_me:$LINENO: checking for gdImageGd in %%GD%%" >&5
++echo $ECHO_N "checking for gdImageGd in %%GD%%... $ECHO_C" >&6
+ if test "${ac_cv_lib_gd_gdImageGd+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lgd -Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic $LIBS"
++LIBS="%%GD%% -Wl,-Bstatic ${GLIBS} -Wl,-Bdynamic $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ #line $LINENO "configure"
+ #include "confdefs.h"
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 7ef95c86f584..f427cd1dfd07 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -17,15 +17,15 @@ COMMENT= Extremely powerful network monitoring system
.if defined(WITH_GD2)
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
.endif
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net/nagios-plugins
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${INCGD} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} ${INCGD} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${LIBGD} -lgnugetopt"
CONFIGURE_ARGS= --with-command-user=nagios \
--with-command-grp=www \
--with-nagios-user=nagios \
@@ -40,6 +40,14 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=/var/spool/nagios \
--prefix=${PREFIX}
+.if defined(WITH_GD2)
+INCGD= -I${LOCALBASE}/include
+LIBGD= -lgd
+.else
+INCGD= -I${LOCALBASE}/include/gd
+LIBGD= -lgd1
+.endif
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
diff --git a/net-mgmt/nagios12/Makefile b/net-mgmt/nagios12/Makefile
index 7ef95c86f584..f427cd1dfd07 100644
--- a/net-mgmt/nagios12/Makefile
+++ b/net-mgmt/nagios12/Makefile
@@ -17,15 +17,15 @@ COMMENT= Extremely powerful network monitoring system
.if defined(WITH_GD2)
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
.endif
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net/nagios-plugins
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${INCGD} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} ${INCGD} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${LIBGD} -lgnugetopt"
CONFIGURE_ARGS= --with-command-user=nagios \
--with-command-grp=www \
--with-nagios-user=nagios \
@@ -40,6 +40,14 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=/var/spool/nagios \
--prefix=${PREFIX}
+.if defined(WITH_GD2)
+INCGD= -I${LOCALBASE}/include
+LIBGD= -lgd
+.else
+INCGD= -I${LOCALBASE}/include/gd
+LIBGD= -lgd1
+.endif
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \
diff --git a/net-mgmt/nagios2/Makefile b/net-mgmt/nagios2/Makefile
index 7ef95c86f584..f427cd1dfd07 100644
--- a/net-mgmt/nagios2/Makefile
+++ b/net-mgmt/nagios2/Makefile
@@ -17,15 +17,15 @@ COMMENT= Extremely powerful network monitoring system
.if defined(WITH_GD2)
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd2
.else
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd1.2:${PORTSDIR}/graphics/gd
.endif
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net/nagios-plugins
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
+CONFIGURE_ENV= CPPFLAGS="${INCGD} -I${LOCALBASE}/include" \
+ CFLAGS="${CFLAGS} ${INCGD} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib ${LIBGD} -lgnugetopt"
CONFIGURE_ARGS= --with-command-user=nagios \
--with-command-grp=www \
--with-nagios-user=nagios \
@@ -40,6 +40,14 @@ CONFIGURE_ARGS= --with-command-user=nagios \
--localstatedir=/var/spool/nagios \
--prefix=${PREFIX}
+.if defined(WITH_GD2)
+INCGD= -I${LOCALBASE}/include
+LIBGD= -lgd
+.else
+INCGD= -I${LOCALBASE}/include/gd
+LIBGD= -lgd1
+.endif
+
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
CONFIGURE_ARGS+=--with-mysql-lib=${LOCALBASE}/lib/mysql \