aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2010-06-30 19:43:40 +0000
committerStefan Walter <stefan@FreeBSD.org>2010-06-30 19:43:40 +0000
commitd6de5eda748967b8b9ceb21e45e3bca9aa155799 (patch)
tree96783bbcc8734ce6921ef17d3186cb50f751067f /net-mgmt
parent8b744dea34c33a4f7ce1af1b8b3c993c9e2574b9 (diff)
downloadports-d6de5eda748967b8b9ceb21e45e3bca9aa155799.tar.gz
ports-d6de5eda748967b8b9ceb21e45e3bca9aa155799.zip
Add optional IPMI support.
PR: 146581 Submitted by: Alex Deiter <alex.deiter@gmail.com> Approved by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=257225
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/zabbix-server/Makefile6
-rw-r--r--net-mgmt/zabbix2-server/Makefile6
2 files changed, 12 insertions, 0 deletions
diff --git a/net-mgmt/zabbix-server/Makefile b/net-mgmt/zabbix-server/Makefile
index 6f7832e88539..f9c1ad5f84cc 100644
--- a/net-mgmt/zabbix-server/Makefile
+++ b/net-mgmt/zabbix-server/Makefile
@@ -60,6 +60,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
SQLITE "Use SQLite backend" off \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
+ IPMI "Support for IPMI" off \
JABBER "Use jabber media type" on \
FPING "Use fping for pinging hosts" on \
SSH "Use libssh2 for SSH-based checks" off
@@ -87,6 +88,11 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+.ifdef WITH_IPMI
+LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+CONFIGURE_ARGS+= --with-openipmi
+.endif
+
.ifndef WITHOUT_JABBER
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index 6f7832e88539..f9c1ad5f84cc 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -60,6 +60,7 @@ OPTIONS= MYSQL "Use MySQL backend" on \
SQLITE "Use SQLite backend" off \
IPV6 "Support for IPv6" on \
LDAP "Support for checking LDAP servers" on \
+ IPMI "Support for IPMI" off \
JABBER "Use jabber media type" on \
FPING "Use fping for pinging hosts" on \
SSH "Use libssh2 for SSH-based checks" off
@@ -87,6 +88,11 @@ USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap
.endif
+.ifdef WITH_IPMI
+LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+CONFIGURE_ARGS+= --with-openipmi
+.endif
+
.ifndef WITHOUT_JABBER
LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber