aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-11-01 06:13:45 +0000
committerWen Heping <wen@FreeBSD.org>2010-11-01 06:13:45 +0000
commit4f504d1db5a61c0888f8f6862a02469130396340 (patch)
tree24ca79e2e68778b277148f4fe81dce88e68730c6 /net-mgmt
parentfc36e27d3ee3eec95f57c441490d3714f5b6a653 (diff)
downloadports-4f504d1db5a61c0888f8f6862a02469130396340.tar.gz
ports-4f504d1db5a61c0888f8f6862a02469130396340.zip
- Update to 4.9.3
- Add BIND DBI OPENVPN options PR: ports/151464 Submitted by: Krzysztof Stryjek <ports@bsdserwis.com> (maintainer)
Notes
Notes: svn path=/head/; revision=263874
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile51
-rw-r--r--net-mgmt/collectd/distinfo6
-rw-r--r--net-mgmt/collectd/pkg-plist12
-rw-r--r--net-mgmt/collectd5/Makefile51
-rw-r--r--net-mgmt/collectd5/distinfo6
-rw-r--r--net-mgmt/collectd5/pkg-plist12
6 files changed, 112 insertions, 26 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 76c2a17863e1..ba332840e1cc 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= collectd
-PORTVERSION= 4.9.2
-PORTREVISION= 2
+PORTVERSION= 4.9.3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -20,15 +19,18 @@ USE_AUTOTOOLS= libltdl:22
WANT_GNOME= yes
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
+ BIND "Enable BIND 9.5+ statistics" On \
DEBUG "Enable debugging" Off \
APACHE "Input: Apache mod_status (libcurl)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
CURL "Input: CURL generic web statistics" Off \
+ DBI "Input: database abstraction library" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
MYSQL "Input: MySQL" Off \
NGINX "Input: Nginx" Off \
+ OPENVPN "Input: OpenVPN statistics" Off \
PDNS "Input: PowerDNS" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
@@ -67,19 +69,17 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-apple_sensors \
--disable-ascent \
--disable-battery \
- --disable-bind \
--disable-conntrack \
--disable-contextswitch \
--disable-cpufreq \
--disable-curl_json \
- --disable-dbi \
--disable-disk \
--disable-entropy \
--disable-fscache \
--disable-gmond \
--disable-hddtemp \
- --disable-iptables \
--disable-ipmi \
+ --disable-iptables \
--disable-ipvs \
--disable-irq \
--disable-java \
@@ -99,7 +99,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-notify_email \
--disable-olsrd \
--disable-onewire \
- --disable-openvpn \
--disable-oracle \
--disable-perl \
--disable-python \
@@ -114,6 +113,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-target_replace \
--disable-target_scale \
--disable-target_set \
+ --disable-teamspeak2 \
--disable-ted \
--disable-thermal \
--disable-tokyotyrant \
@@ -138,6 +138,25 @@ PLIST_SUB+= CGI=""
PLIST_SUB+= CGI="@comment "
.endif
+.if defined(WITH_BIND)
+.if ${OSVERSION} < 800000
+BROKEN= Need bind 9.5+
+.endif
+# check if MK_BIND is set to no (by /etc/src.conf or /etc/make.conf)
+.if exists(${DESTDIR}/usr/lib/libbind9.a) || exists(${LOCALBASE}/lib/libbind9.a)
+CONFIGURE_ARGS+=--enable-bind
+PLIST_SUB+= BIND=""
+.else
+# libind9 does not exists
+CONFIGURE_ARGS+=--disable-bind
+PLIST_SUB+= BIND="@comment "
+.endif
+.else
+# WITHOUT_BIND
+CONFIGURE_ARGS+=--disable-bind
+PLIST_SUB+= BIND="@comment "
+.endif
+
.if defined(WITH_APACHE)
CONFIGURE_ARGS+=--enable-apache
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
@@ -165,6 +184,15 @@ CONFIGURE_ARGS+=--disable-curl
PLIST_SUB+= CURL="@comment "
.endif
+.if defined(WITH_DBI)
+CONFIGURE_ARGS+=--enable-dbi --with-libdbi=${LOCALBASE}
+LIB_DEPENDS+= dbi.0:${PORTSDIR}/databases/libdbi
+PLIST_SUB+= DBI=""
+.else
+CONFIGURE_ARGS+=--disable-dbi
+PLIST_SUB+= DBI="@comment "
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
@@ -187,7 +215,7 @@ PLIST_SUB+= INTERFACE="@comment "
.if defined(WITH_MBMON)
CONFIGURE_ARGS+=--enable-mbmon
-RUN_DEPENDS+= ${LOCALBASE}/sbin/mbmond:${PORTSDIR}/sysutils/mbmon
+RUN_DEPENDS+= ${LOCALBASE}/bin/mbmon:${PORTSDIR}/sysutils/mbmon
PLIST_SUB+= MBMON=""
.else
CONFIGURE_ARGS+=--disable-mbmon
@@ -213,6 +241,15 @@ CONFIGURE_ARGS+=--disable-nginx
PLIST_SUB+= NGINX="@comment "
.endif
+.if defined(WITH_OPENVPN)
+CONFIGURE_ARGS+=--enable-openvpn
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvpn:${PORTSDIR}/security/openvpn
+PLIST_SUB+= OPENVPN=""
+.else
+CONFIGURE_ARGS+=--disable-openvpn
+PLIST_SUB+= OPENVPN="@comment "
+.endif
+
.if defined(WITH_PDNS)
USE_PDNS= yes
CONFIGURE_ARGS+=--enable-powerdns
diff --git a/net-mgmt/collectd/distinfo b/net-mgmt/collectd/distinfo
index ba957ae32ec2..cffcff0f910d 100644
--- a/net-mgmt/collectd/distinfo
+++ b/net-mgmt/collectd/distinfo
@@ -1,3 +1,3 @@
-MD5 (collectd-4.9.2.tar.gz) = 2734f272753bfa8523dfed133866ae04
-SHA256 (collectd-4.9.2.tar.gz) = a171adf3f94136df3f56148084531e786ed72bda807dc0b3d9fb2bebe53b904d
-SIZE (collectd-4.9.2.tar.gz) = 1691127
+MD5 (collectd-4.9.3.tar.gz) = f56848e9293efa601ba95c208c6dcba9
+SHA256 (collectd-4.9.3.tar.gz) = 65983b428015ebdb5bd982c4d4d7fe7fa33e91f0d622e41cd1e7ea230b22ca05
+SIZE (collectd-4.9.3.tar.gz) = 1692985
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index 34cfb4a6af84..202a92bda827 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -20,6 +20,9 @@ lib/libcollectdclient.so.0
%%APCUPS%%lib/collectd/apcups.a
%%APCUPS%%lib/collectd/apcups.la
%%APCUPS%%lib/collectd/apcups.so
+%%BIND%%lib/collectd/bind.a
+%%BIND%%lib/collectd/bind.la
+%%BIND%%lib/collectd/bind.so
lib/collectd/cpu.a
lib/collectd/cpu.la
lib/collectd/cpu.so
@@ -29,6 +32,9 @@ lib/collectd/csv.so
%%CURL%%lib/collectd/curl.a
%%CURL%%lib/collectd/curl.la
%%CURL%%lib/collectd/curl.so
+%%DBI%%lib/collectd/dbi.a
+%%DBI%%lib/collectd/dbi.la
+%%DBI%%lib/collectd/dbi.so
lib/collectd/df.a
lib/collectd/df.la
lib/collectd/df.so
@@ -77,6 +83,9 @@ lib/collectd/network.so
lib/collectd/ntpd.a
lib/collectd/ntpd.la
lib/collectd/ntpd.so
+%%OPENVPN%%lib/collectd/openvpn.a
+%%OPENVPN%%lib/collectd/openvpn.la
+%%OPENVPN%%lib/collectd/openvpn.so
%%PGSQL%%lib/collectd/postgresql.a
%%PGSQL%%lib/collectd/postgresql.la
%%PGSQL%%lib/collectd/postgresql.so
@@ -107,9 +116,6 @@ lib/collectd/tail.a
lib/collectd/tcpconns.so
lib/collectd/tcpconns.la
lib/collectd/tcpconns.a
-lib/collectd/teamspeak2.so
-lib/collectd/teamspeak2.la
-lib/collectd/teamspeak2.a
lib/collectd/unixsock.a
lib/collectd/unixsock.la
lib/collectd/unixsock.so
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 76c2a17863e1..ba332840e1cc 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= collectd
-PORTVERSION= 4.9.2
-PORTREVISION= 2
+PORTVERSION= 4.9.3
CATEGORIES= net-mgmt
MASTER_SITES= http://collectd.org/files/
@@ -20,15 +19,18 @@ USE_AUTOTOOLS= libltdl:22
WANT_GNOME= yes
OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
+ BIND "Enable BIND 9.5+ statistics" On \
DEBUG "Enable debugging" Off \
APACHE "Input: Apache mod_status (libcurl)" Off \
APCUPS "Input: APC UPS (apcupsd)" Off \
CURL "Input: CURL generic web statistics" Off \
+ DBI "Input: database abstraction library" Off \
NUTUPS "Input: NUT UPS daemon" Off \
INTERFACE "Input: Network interfaces (libstatgrab)" On \
MBMON "Input: MBMon" Off \
MYSQL "Input: MySQL" Off \
NGINX "Input: Nginx" Off \
+ OPENVPN "Input: OpenVPN statistics" Off \
PDNS "Input: PowerDNS" Off \
PGSQL "Input: PostgreSQL" Off \
PING "Input: Network latency (liboping)" On \
@@ -67,19 +69,17 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-apple_sensors \
--disable-ascent \
--disable-battery \
- --disable-bind \
--disable-conntrack \
--disable-contextswitch \
--disable-cpufreq \
--disable-curl_json \
- --disable-dbi \
--disable-disk \
--disable-entropy \
--disable-fscache \
--disable-gmond \
--disable-hddtemp \
- --disable-iptables \
--disable-ipmi \
+ --disable-iptables \
--disable-ipvs \
--disable-irq \
--disable-java \
@@ -99,7 +99,6 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-notify_email \
--disable-olsrd \
--disable-onewire \
- --disable-openvpn \
--disable-oracle \
--disable-perl \
--disable-python \
@@ -114,6 +113,7 @@ CONFIGURE_ARGS= --localstatedir=/var \
--disable-target_replace \
--disable-target_scale \
--disable-target_set \
+ --disable-teamspeak2 \
--disable-ted \
--disable-thermal \
--disable-tokyotyrant \
@@ -138,6 +138,25 @@ PLIST_SUB+= CGI=""
PLIST_SUB+= CGI="@comment "
.endif
+.if defined(WITH_BIND)
+.if ${OSVERSION} < 800000
+BROKEN= Need bind 9.5+
+.endif
+# check if MK_BIND is set to no (by /etc/src.conf or /etc/make.conf)
+.if exists(${DESTDIR}/usr/lib/libbind9.a) || exists(${LOCALBASE}/lib/libbind9.a)
+CONFIGURE_ARGS+=--enable-bind
+PLIST_SUB+= BIND=""
+.else
+# libind9 does not exists
+CONFIGURE_ARGS+=--disable-bind
+PLIST_SUB+= BIND="@comment "
+.endif
+.else
+# WITHOUT_BIND
+CONFIGURE_ARGS+=--disable-bind
+PLIST_SUB+= BIND="@comment "
+.endif
+
.if defined(WITH_APACHE)
CONFIGURE_ARGS+=--enable-apache
LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
@@ -165,6 +184,15 @@ CONFIGURE_ARGS+=--disable-curl
PLIST_SUB+= CURL="@comment "
.endif
+.if defined(WITH_DBI)
+CONFIGURE_ARGS+=--enable-dbi --with-libdbi=${LOCALBASE}
+LIB_DEPENDS+= dbi.0:${PORTSDIR}/databases/libdbi
+PLIST_SUB+= DBI=""
+.else
+CONFIGURE_ARGS+=--disable-dbi
+PLIST_SUB+= DBI="@comment "
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
@@ -187,7 +215,7 @@ PLIST_SUB+= INTERFACE="@comment "
.if defined(WITH_MBMON)
CONFIGURE_ARGS+=--enable-mbmon
-RUN_DEPENDS+= ${LOCALBASE}/sbin/mbmond:${PORTSDIR}/sysutils/mbmon
+RUN_DEPENDS+= ${LOCALBASE}/bin/mbmon:${PORTSDIR}/sysutils/mbmon
PLIST_SUB+= MBMON=""
.else
CONFIGURE_ARGS+=--disable-mbmon
@@ -213,6 +241,15 @@ CONFIGURE_ARGS+=--disable-nginx
PLIST_SUB+= NGINX="@comment "
.endif
+.if defined(WITH_OPENVPN)
+CONFIGURE_ARGS+=--enable-openvpn
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvpn:${PORTSDIR}/security/openvpn
+PLIST_SUB+= OPENVPN=""
+.else
+CONFIGURE_ARGS+=--disable-openvpn
+PLIST_SUB+= OPENVPN="@comment "
+.endif
+
.if defined(WITH_PDNS)
USE_PDNS= yes
CONFIGURE_ARGS+=--enable-powerdns
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
index ba957ae32ec2..cffcff0f910d 100644
--- a/net-mgmt/collectd5/distinfo
+++ b/net-mgmt/collectd5/distinfo
@@ -1,3 +1,3 @@
-MD5 (collectd-4.9.2.tar.gz) = 2734f272753bfa8523dfed133866ae04
-SHA256 (collectd-4.9.2.tar.gz) = a171adf3f94136df3f56148084531e786ed72bda807dc0b3d9fb2bebe53b904d
-SIZE (collectd-4.9.2.tar.gz) = 1691127
+MD5 (collectd-4.9.3.tar.gz) = f56848e9293efa601ba95c208c6dcba9
+SHA256 (collectd-4.9.3.tar.gz) = 65983b428015ebdb5bd982c4d4d7fe7fa33e91f0d622e41cd1e7ea230b22ca05
+SIZE (collectd-4.9.3.tar.gz) = 1692985
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index 34cfb4a6af84..202a92bda827 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -20,6 +20,9 @@ lib/libcollectdclient.so.0
%%APCUPS%%lib/collectd/apcups.a
%%APCUPS%%lib/collectd/apcups.la
%%APCUPS%%lib/collectd/apcups.so
+%%BIND%%lib/collectd/bind.a
+%%BIND%%lib/collectd/bind.la
+%%BIND%%lib/collectd/bind.so
lib/collectd/cpu.a
lib/collectd/cpu.la
lib/collectd/cpu.so
@@ -29,6 +32,9 @@ lib/collectd/csv.so
%%CURL%%lib/collectd/curl.a
%%CURL%%lib/collectd/curl.la
%%CURL%%lib/collectd/curl.so
+%%DBI%%lib/collectd/dbi.a
+%%DBI%%lib/collectd/dbi.la
+%%DBI%%lib/collectd/dbi.so
lib/collectd/df.a
lib/collectd/df.la
lib/collectd/df.so
@@ -77,6 +83,9 @@ lib/collectd/network.so
lib/collectd/ntpd.a
lib/collectd/ntpd.la
lib/collectd/ntpd.so
+%%OPENVPN%%lib/collectd/openvpn.a
+%%OPENVPN%%lib/collectd/openvpn.la
+%%OPENVPN%%lib/collectd/openvpn.so
%%PGSQL%%lib/collectd/postgresql.a
%%PGSQL%%lib/collectd/postgresql.la
%%PGSQL%%lib/collectd/postgresql.so
@@ -107,9 +116,6 @@ lib/collectd/tail.a
lib/collectd/tcpconns.so
lib/collectd/tcpconns.la
lib/collectd/tcpconns.a
-lib/collectd/teamspeak2.so
-lib/collectd/teamspeak2.la
-lib/collectd/teamspeak2.a
lib/collectd/unixsock.a
lib/collectd/unixsock.la
lib/collectd/unixsock.so