aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-11-24 01:54:22 +0000
committerSteve Wills <swills@FreeBSD.org>2012-11-24 01:54:22 +0000
commit7e70655152f4caedd1418cbac034be28d9640fb7 (patch)
treefbcb8f900c91e98c5a161f510cb92febf11b5aa6 /net-mgmt
parent3b115a1ff071fc6d2c6cc1757a62d62d76edf13d (diff)
downloadports-7e70655152f4caedd1418cbac034be28d9640fb7.tar.gz
ports-7e70655152f4caedd1418cbac034be28d9640fb7.zip
- Add patch that fixes memory usage reporting in FreeBSD 8.x and newer due to
syntax changes in sysctl vm.vmtotal - Assign maintainer to submitter PR: ports/173607 Submitted by: Mark Felder <feld@feld.me> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307698
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/xymon-server/Makefile4
-rw-r--r--net-mgmt/xymon-server/files/patch-xymond-client-freebsd.c20
2 files changed, 22 insertions, 2 deletions
diff --git a/net-mgmt/xymon-server/Makefile b/net-mgmt/xymon-server/Makefile
index d6ef12785915..8bfbf9c6a060 100644
--- a/net-mgmt/xymon-server/Makefile
+++ b/net-mgmt/xymon-server/Makefile
@@ -2,13 +2,13 @@
PORTNAME= xymon
PORTVERSION= 4.3.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
MASTER_SITES= SF/xymon/Xymon/${PORTVERSION}
PKGNAMESUFFIX= -server${PKGNAMESUFFIX2}
DIST_SUBDIR= repacked
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= feld@feld.me
COMMENT= System for monitoring servers and networks
LICENSE= GPLv2
diff --git a/net-mgmt/xymon-server/files/patch-xymond-client-freebsd.c b/net-mgmt/xymon-server/files/patch-xymond-client-freebsd.c
new file mode 100644
index 000000000000..5af6cfb2f787
--- /dev/null
+++ b/net-mgmt/xymon-server/files/patch-xymond-client-freebsd.c
@@ -0,0 +1,20 @@
+--- xymond/client/freebsd.c.orig 2012-11-13 07:48:19.217106974 -0600
++++ xymond/client/freebsd.c 2012-11-13 07:49:45.416552261 -0600
+@@ -85,8 +85,16 @@
+ if (vmtotalstr) {
+ p = strstr(vmtotalstr, "\nFree Memory Pages:");
+ if (p) {
+- memphysfree = atol(p + 18);
++ memphysfree = atol(p + 19)/1024;
++ memphysused = memphystotal - memphysfree;
+ found++;
++ } else {
++ p = strstr(vmtotalstr, "\nFree Memory:");
++ if (p) {
++ memphysfree = atol(p + 13)/1024;
++ memphysused = memphystotal - memphysfree;
++ found++;
++ }
+ }
+ }
+