aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1995-02-21 17:07:49 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1995-02-21 17:07:49 +0000
commitb0a4922be975b041a8c5225b40324e37863706aa (patch)
tree154a4f7760b14e29a6143788f94df090a6eb2dc9 /net-mgmt
parent0c494b31d5bc9617b2b8e047a1011fc2edbe7c8d (diff)
downloadports-b0a4922be975b041a8c5225b40324e37863706aa.tar.gz
ports-b0a4922be975b041a8c5225b40324e37863706aa.zip
Scotty port.
Submitted by: Gennady Sorokopud <gena@netvision.net.il>
Notes
Notes: svn path=/head/; revision=1011
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/scotty3/Makefile40
-rw-r--r--net-mgmt/scotty3/distinfo3
-rw-r--r--net-mgmt/scotty3/pkg-comment2
-rw-r--r--net-mgmt/scotty3/pkg-descr43
-rw-r--r--net-mgmt/scotty3/pkg-plist14
5 files changed, 102 insertions, 0 deletions
diff --git a/net-mgmt/scotty3/Makefile b/net-mgmt/scotty3/Makefile
new file mode 100644
index 000000000000..31dc8ef9e76c
--- /dev/null
+++ b/net-mgmt/scotty3/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: scotty
+# Version required: 1.2.0
+# Date created: 18 Februar 1995
+# Whom: gena
+#
+# $Id: Makefile,v 1.0 1995/02/18 13:41:00 gena Exp $
+#
+
+DISTNAME= scotty-1.2.0
+DISTFILES= scotty-1.2.0.tar.gz scotty-1.2.0-1.2.1.diff.gz \
+ scotty-1.2.1-1.2.2.diff.gz
+
+EXTRACT_ONLY= scotty-1.2.0.tar.gz
+MASTER_SITES= ftp://ftp.ibr.cs.tu-bs.de/pub/local/tkined/
+HAS_CONFIGURE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+LIB_DEPENDS= tk\\.3\\.:${PORTSDIR}/x11/tk \
+ tclx\\.a:${PORTSDIR}/lang/tclX \
+ tcl\\.7\\.:${PORTSDIR}/lang/tcl
+CONFIGURE_ARGS= --with-x --prefix=${PREFIX} --with-tcl-include=${PORTSDIR}/lang/tcl/work/tcl7.3 --with-tcl-library=${PORTSDIR}/lang/tcl/work/tcl7.3 --with-tk-include=${PORTSDIR}/x11/tk/work/tk3.6 --with-tk-library=${PORTSDIR}/x11/tk/work/tk3.6 --with-blt-library=${PORTSDIR}/lang/tclX/work/tclX7.3b/tclmaster/lib
+
+pre-patch:
+ @echo "===> Pre-patching for ${DISTNAME}"
+ @if [ ! -f ${CONFIGURE_COOKIE} ]; then \
+ ln -s ${WRKSRC} ${WRKDIR}/scotty-1.2.1; \
+ ln -s ${WRKSRC} ${WRKDIR}/scotty-1.2.2; \
+ zcat ${DISTDIR}/scotty-1.2.0-1.2.1.diff.gz | \
+ patch --quiet -E -p0 -d ${WRKDIR}; \
+ zcat ${DISTDIR}/scotty-1.2.1-1.2.2.diff.gz | \
+ patch --quiet -E -p0 -d ${WRKDIR}; \
+ rm -f ${WRKDIR}/scotty-1.2.1; \
+ rm -f ${WRKDIR}/scotty-1.2.2; \
+ fi
+
+pre-install:
+ @echo "===> Pre-installing for ${DISTNAME}"
+ @cd ${WRKSRC};make sinstall
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/scotty3/distinfo b/net-mgmt/scotty3/distinfo
new file mode 100644
index 000000000000..c33c771a111c
--- /dev/null
+++ b/net-mgmt/scotty3/distinfo
@@ -0,0 +1,3 @@
+MD5 (scotty-1.2.0.tar.gz) = bbbb9204559865e4faf3e874c66d2bb6
+MD5 (scotty-1.2.0-1.2.1.diff.gz) = b79a0aa88eaa40290d80c71e1f12da46
+MD5 (scotty-1.2.1-1.2.2.diff.gz) = 35eea98bd4696718c73422cce462d038
diff --git a/net-mgmt/scotty3/pkg-comment b/net-mgmt/scotty3/pkg-comment
new file mode 100644
index 000000000000..551533bf4844
--- /dev/null
+++ b/net-mgmt/scotty3/pkg-comment
@@ -0,0 +1,2 @@
+scotty - network management extensions to tcl v1.2.0
+patched to v1.2.2
diff --git a/net-mgmt/scotty3/pkg-descr b/net-mgmt/scotty3/pkg-descr
new file mode 100644
index 000000000000..39adf5504333
--- /dev/null
+++ b/net-mgmt/scotty3/pkg-descr
@@ -0,0 +1,43 @@
+
+ scotty - network management extensions to tcl
+
+
+scotty is a tcl extension which allows to set up TCP and UDP
+connections, to send various ICMP packets, to query the domain name
+system (DNS), to check clock screw using the NTP protocol and to query
+various SUN RPC services (like rstat and mountd).
+
+Included in this package is an interface to SNMPv1 and SNMPv2. The
+SNMP stack was written from scratch to provide an efficient and
+portable tcl SNMP extension. MIB extensions can be written in tcl by
+running the scotty extension as an SNMP agent. This allows you to
+implement your own specific MIB without getting in contact with the
+lowlevel ASN.1/BER stuff.
+
+The scotty package includes scripts for the tkined network editor to
+troubleshoot your IP network (ping, traceroute, finger, query tcp
+services, query RPC services), for monitoring network status plus
+scripts to discover and layout the topology of your IP network. SNMP
+based scripts can be used to dump routing tables, to query interface
+status and to monitor SNMP variables. There is also a MIB browser to
+inspect the MIB hierarchy.
+
+More information is available via WWW under the URL:
+
+ http://www.cs.tu-bs.de/ibr/projects/nm/scotty/
+
+If you have problems installing scotty or if you have made any changes
+to run scotty on your hardware or if you have found any bugs, please
+contact us. Discussion about scotty is currently done on the tkined
+mailing list. To join, send a request to
+
+ tkined-request@ibr.cs.tu-bs.de.
+
+Messages to the list should be send to tkined@ibr.cs.tu-bs.de.
+
+ Juergen
+
+---
+Juergen Schoenwaelder (schoenw@ibr.cs.tu-bs.de) http://www.cs.tu-bs.de/~schoenw
+Technical University Braunschweig, Dept. Operating Systems & Computer Networks
+Bueltenweg 74/75, D-38106 Braunschweig, Germany. (Tel. +49 531 / 391-3249)
diff --git a/net-mgmt/scotty3/pkg-plist b/net-mgmt/scotty3/pkg-plist
new file mode 100644
index 000000000000..55c4f13ebaa0
--- /dev/null
+++ b/net-mgmt/scotty3/pkg-plist
@@ -0,0 +1,14 @@
+@cwd /usr/local
+@mode 755
+bin/scotty
+bin/scwish
+bin/straps
+bin/ntping
+@mode 444
+man/man1/scotty.1
+man/man1/scwish.1
+man/man8/ntping.8
+man/man8/straps.8
+@mode 644
+lib/tkined
+lib/scotty