aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/eiskaltdcpp-gtk
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2011-11-28 16:30:44 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2011-11-28 16:30:44 +0000
commitf9d30cef273d9fe616b51fbf95f59cee60814f50 (patch)
treec4fc50cd8c6f14438d9ba60889d8c21c7180b4e4 /net-p2p/eiskaltdcpp-gtk
parent2aab16394932f1853fc7d6f512a99c4e8d4c19a7 (diff)
downloadports-f9d30cef273d9fe616b51fbf95f59cee60814f50.tar.gz
ports-f9d30cef273d9fe616b51fbf95f59cee60814f50.zip
PR: 162340
Submitted by: gelraen.ua@gmail.com Reviewed by: Approved by: gabor (mentor) Obtained from: MFC after: Security: Feature safe: yes On some machines resulting binaries contains "/usr/lib" before "/usr/local/lib/gcc45" in rpath and user gets something like this if tries to launch that binary: /libexec/ld-elf.so.1: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.10 required by /usr/local/bin/eiskaltdcpp-gtk not found Attached patch adds BUILD_DEPENDS on devel/chrpath, which is used to overwrite rpath in built binaries (-DCMAKE_INSTALL_RPATH only aappends directories to rpath)
Notes
Notes: svn path=/head/; revision=286584
Diffstat (limited to 'net-p2p/eiskaltdcpp-gtk')
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index fdef42c04d6e..3c472873af5e 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eiskaltdcpp-gtk
PORTVERSION= 2.2.4
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
@@ -18,6 +19,7 @@ LICENSE= GPLv3
RUN_DEPENDS= ${LOCALBASE}/share/eiskaltdcpp/keep_me:${PORTSDIR}/net-p2p/eiskaltdcpp-data
LIB_DEPENDS= eiskaltdcpp:${PORTSDIR}/net-p2p/eiskaltdcpp-lib
+BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
@@ -73,4 +75,9 @@ CMAKE_ARGS+= -DUSE_LIBNOTIFY:BOOL=OFF
USE_OPENSSL_PORT=yes
.endif
+GCC_LIBS= "${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}"
+
+post-build:
+ ${LOCALBASE}/bin/chrpath -r "${GCC_LIBS}" "${WRKSRC}/${PORTNAME}/${PORTNAME}"
+
.include <bsd.port.mk>