aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/mldonkey-gui-devel/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-26 18:30:30 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-26 18:30:30 +0000
commitbbc70c45fa152d56f3ad139deb57be9e4e62bbc9 (patch)
tree6752e3b8da7985a96c06e4bc8c8821ecce637225 /net-p2p/mldonkey-gui-devel/Makefile
parent8f66818e0f1d5ff949c4aa16acb4c2f7f88e0288 (diff)
downloadports-bbc70c45fa152d56f3ad139deb57be9e4e62bbc9.tar.gz
ports-bbc70c45fa152d56f3ad139deb57be9e4e62bbc9.zip
o After being repo copied from mldonkey port:
- update to 2.02.0 - only install the mldonkey GUI (leave the core for the mldonkey port) - update all informational files to reflect this change Approved by: portmgr (myself & no objections) Repo copied by: joe Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=74039
Diffstat (limited to 'net-p2p/mldonkey-gui-devel/Makefile')
-rw-r--r--net-p2p/mldonkey-gui-devel/Makefile55
1 files changed, 20 insertions, 35 deletions
diff --git a/net-p2p/mldonkey-gui-devel/Makefile b/net-p2p/mldonkey-gui-devel/Makefile
index db104e3308f5..205fbaf8d975 100644
--- a/net-p2p/mldonkey-gui-devel/Makefile
+++ b/net-p2p/mldonkey-gui-devel/Makefile
@@ -1,62 +1,47 @@
# New ports collection makefile for: mldonkey
-# Date created: 21 August 2002
+# Date created: 19 December 2002
# Whom: Holger Lamm <holger@e-gitt.net>
#
# $FreeBSD$
#
PORTNAME= mldonkey
-PORTVERSION= 1.16
+PORTVERSION= 2.02.0
CATEGORIES= net
-MASTER_SITES= http://www.schraegerpunkt.de/ \
- http://ernie.eit.uni-kl.de/mldonkey/
-
-DISTNAME= ${PORTNAME}-${PORTVERSION}.static.${ARCH}-FreeBSD
+MASTER_SITES= http://ernie.eit.uni-kl.de/mldonkey/ \
+ http://savannah.nongnu.org/download/mldonkey/stable/contributed/
+PKGNAMESUFFIX= -gui
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/.0$/-0/}.shared.${ARCH}-${OPSYS}
MAINTAINER= holger@e-gitt.net
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 alpha
USE_BZIP2= yes
-USE_PERL5= yes
-USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-distrib
+WRKSRC= ${WRKDIR}/${PORTNAME}-distrib-${PORTVERSION}
DIRNAME= ${HOME}/.mldonkey
-# do not strip, it breaks OCAML binaries
-STRIP=
-
-post-patch:
- @${SED} -e "s|%%PREFIX%%|${PREFIX}|" ${FILESDIR}/wrapper.sh > \
- ${WRKDIR}/wrapper.sh
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/kill_mldonkey
-
-pre-install:
-# we can strip the GTK binary
- @${STRIP_CMD} ${WRKSRC}/mldonkey_gui
-
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey ${PREFIX}/bin/mldonkey-real
@${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/kill_mldonkey ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/mldonkey_previewer ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh ${PREFIX}/bin/mldonkey
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/Readme.txt ${DOCSDIR}
-.endif
+ @${INSTALL_PROGRAM} ${WRKSRC}/mldonkey_gui2 ${PREFIX}/bin
post-install:
- @${SED} -e 's|/usr/local/|${PREFIX}/|' ${PKGMESSAGE}
+ @${FMT} < ${PKGMESSAGE}
.include <bsd.port.pre.mk>
install-user: extract
- @${TEST} -d ${DIRNAME} || ${MKDIR} ${DIRNAME}
- @${CP} ${WRKSRC}/servers.ini ${DIRNAME}/
+.if !defined(LANG)
+ @${ECHO_MSG} "Please call as: make install-user LANG=<lang>"
+ @${ECHO_MSG} "with <lang> one of en,de,fr,fr.noaccents !"
+.else
+ @${CP} ${WRKSRC}/i18n/gui_messages.ini.${LANG}\
+ ${HOME}/.mldonkey_gui_messages.ini
+.endif
.include <bsd.port.post.mk>