aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/opendchub
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-13 11:24:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-02-13 11:24:54 +0000
commit1bca823dd30e7e6389f3b40b31534bc8c7f81061 (patch)
tree340eb2294a215e8707f366be24932ab1783ed00f /net-p2p/opendchub
parentd534e1a494d8f7070bf5b1cb6ba9fe331aa740e9 (diff)
downloadports-1bca823dd30e7e6389f3b40b31534bc8c7f81061.tar.gz
ports-1bca823dd30e7e6389f3b40b31534bc8c7f81061.zip
- Fix buffer overflow [1]
- Fix telnet vulnerability [2] - Unbreak and unforbid - Bump PORTREVISION VuXML: cdf14b68-3ff9-11d9-8405-00065be4b5b6 [1] Obtained from: Gentoo CVS [1] project's patch tracker at sf.net [2]
Notes
Notes: svn path=/head/; revision=128685
Diffstat (limited to 'net-p2p/opendchub')
-rw-r--r--net-p2p/opendchub/Makefile6
-rw-r--r--net-p2p/opendchub/files/patch-buffer_overflow_fix11
-rw-r--r--net-p2p/opendchub/files/patch-telnet_chat_fix11
3 files changed, 23 insertions, 5 deletions
diff --git a/net-p2p/opendchub/Makefile b/net-p2p/opendchub/Makefile
index e090c1df9f6f..418101c52d92 100644
--- a/net-p2p/opendchub/Makefile
+++ b/net-p2p/opendchub/Makefile
@@ -7,7 +7,7 @@
PORTNAME= opendchub
PORTVERSION= 0.7.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +21,6 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include"
-FORBIDDEN= "http://vuxml.freebsd.org/cdf14b68-3ff9-11d9-8405-00065be4b5b6.html"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${FORBIDDEN}
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/net-p2p/opendchub/files/patch-buffer_overflow_fix b/net-p2p/opendchub/files/patch-buffer_overflow_fix
new file mode 100644
index 000000000000..305b6c5d9558
--- /dev/null
+++ b/net-p2p/opendchub/files/patch-buffer_overflow_fix
@@ -0,0 +1,11 @@
+--- src/commands.c.orig Sun Feb 13 17:16:37 2005
++++ src/commands.c Sun Feb 13 17:17:18 2005
+@@ -2842,7 +2842,7 @@
+ {
+ char move_string[MAX_HOST_LEN+20];
+
+- sprintf(move_string, "$ForceMove %s", buf);
++ snprintf(move_string, MAX_HOST_LEN, "$ForceMove %s", buf);
+
+ send_to_humans(move_string, REGULAR | REGISTERED | OP, user);
+ remove_all(UNKEYED | NON_LOGGED | REGULAR | REGISTERED | OP, 1, 1);
diff --git a/net-p2p/opendchub/files/patch-telnet_chat_fix b/net-p2p/opendchub/files/patch-telnet_chat_fix
new file mode 100644
index 000000000000..79ade0c6ef26
--- /dev/null
+++ b/net-p2p/opendchub/files/patch-telnet_chat_fix
@@ -0,0 +1,11 @@
+--- src/main.c.orig Sun Feb 13 16:54:21 2005
++++ src/main.c Sun Feb 13 16:55:31 2005
+@@ -1056,7 +1056,7 @@
+ /* The chat command, starts with <nick> */
+ else if(*temp == '<')
+ {
+- if((user->type & (SCRIPT | UNKEYED | LINKED | NON_LOGGED)) == 0)
++ if((user->type & (SCRIPT | UNKEYED | LINKED | NON_LOGGED | NON_LOGGED_ADM)) == 0)
+ chat(temp, user);
+ }
+