aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-08-12 00:52:00 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-08-12 00:52:00 +0000
commit38d5dff616594ad3e5e70d4c38e2c7ca175ea7d1 (patch)
tree1e85430a3349cdc0e50ff1edd428b5631bfbbc9c /net-p2p/qbittorrent
parentfa4379932d169c8b52c488a88c7fb7449b850a49 (diff)
downloadports-38d5dff616594ad3e5e70d4c38e2c7ca175ea7d1.tar.gz
ports-38d5dff616594ad3e5e70d4c38e2c7ca175ea7d1.zip
* Thu Aug 09 2012 - Christophe Dumez <chris@qbittorrent.org> - v3.0.0
- FEATURE: Brand new torrent addition dialog - FEATURE: Add the ability to choose the save path when using magnet links (mutoso) - FEATURE: Add support for adding multiple local torrents at once (Web UI) - COSMETIC: Improve style of left panel - BUGFIX: Lower panels no longer gets disabled - BUGFIX: Major code refactoring and various optimizations. - BUGFIX: No longer strip root folder from torrent files For the port: - Move to unversioned directory. The last few major releases have been stable upgrades, so there is no reason to maintain different versions.
Notes
Notes: svn path=/head/; revision=302421
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile60
-rw-r--r--net-p2p/qbittorrent/distinfo2
-rw-r--r--net-p2p/qbittorrent/pkg-descr22
-rw-r--r--net-p2p/qbittorrent/pkg-message5
-rw-r--r--net-p2p/qbittorrent/pkg-plist39
5 files changed, 128 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
new file mode 100644
index 000000000000..6f5ed31e22e1
--- /dev/null
+++ b/net-p2p/qbittorrent/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: qbittorrent
+# Date created: 11 August 2012
+# Whom: Doug Barton <dougb@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= qbittorrent
+PORTVERSION= 3.0.0
+PORTREVISION?= 0
+CATEGORIES= net-p2p ipv6
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
+
+# lib versions specified on purpose
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo \
+ torrent-rasterbar.6:${PORTSDIR}/net-p2p/libtorrent-rasterbar-16
+
+MAKE_JOBS_SAFE= yes
+
+CONFLICTS= qbittorrent-2.* qbittorrent-4.[0-9].*
+
+USE_QT4= corelib network qmake_build moc_build rcc_build
+
+.if !defined(QB_NOX_SLAVE)
+.if defined(WITHOUT_X11)
+BROKEN= Use net-p2p/${PORTNAME}-nox11 for the non-GUI version
+.endif
+LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+OPTIONS= DBUS "Enable dbus support" off
+USE_QT4+= gui xml uic_build
+INSTALLS_ICONS= yes
+.else
+CONFIGURE_ARGS+= --disable-gui
+.endif
+
+QT_NONSTANDARD= yes
+HAS_CONFIGURE= yes
+
+MAN1?= qbittorrent.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_DBUS)
+USE_QT4+= dbus
+.else
+CONFIGURE_ARGS+= --disable-qt-dbus
+.endif
+
+post-install:
+.if !defined(QB_NOX_SLAVE)
+ @${STRIP_CMD} ${PREFIX}/bin/qbittorrent
+ @${CAT} ${PKGMESSAGE}
+.else
+ @${STRIP_CMD} ${PREFIX}/bin/qbittorrent-nox
+ ${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent-nox.1 ${MANPREFIX}/man/man1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
new file mode 100644
index 000000000000..f79115a8918c
--- /dev/null
+++ b/net-p2p/qbittorrent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (qbittorrent-3.0.0.tar.gz) = 6999ce802724f5620b14a237f4616305e8b3956d5058cbfd153684a8af3f47c6
+SIZE (qbittorrent-3.0.0.tar.gz) = 3625280
diff --git a/net-p2p/qbittorrent/pkg-descr b/net-p2p/qbittorrent/pkg-descr
new file mode 100644
index 000000000000..7bca781c4859
--- /dev/null
+++ b/net-p2p/qbittorrent/pkg-descr
@@ -0,0 +1,22 @@
+qBittorrent is the closest open source (GNU GPL v2 license) equivalent
+to uTorrent. It is based on the Qt4 toolkit and libtorrent-rasterbar.
+
+Features:
+
+ Well-integrated and extensible Search Engine
+ Simultaneous search in most famous BitTorrent search sites
+ Per-category-specific search requests (e.g. Books, Music, Movies)
+ All Bittorrent extensions
+ * DHT, Peer Exchange, Full encryption, Magnet URI, uTP
+ Remote control through a Web user interface
+ * Nearly identical to the regular UI, all in Ajax
+ Advanced control over trackers, peers and torrents
+ * Torrents queueing and prioritizing
+ * Torrent content selection and prioritizing
+ UPnP / NAT-PMP port forwarding support
+ Available in ~25 languages (Unicode support)
+ uTorrent spoofing to bypass private trackers whitelisting
+ Advanced RSS support with download filters (inc. regex)
+ IP Filtering (eMule and PeerGuardian compatible)
+
+WWW: http://www.qbittorrent.org/
diff --git a/net-p2p/qbittorrent/pkg-message b/net-p2p/qbittorrent/pkg-message
new file mode 100644
index 000000000000..157ed5b528c6
--- /dev/null
+++ b/net-p2p/qbittorrent/pkg-message
@@ -0,0 +1,5 @@
+
+****************************************************************************
+* To change the appearance of the interface use misc/qt4-qtconfig *
+****************************************************************************
+
diff --git a/net-p2p/qbittorrent/pkg-plist b/net-p2p/qbittorrent/pkg-plist
new file mode 100644
index 000000000000..dcd1b5c55a5f
--- /dev/null
+++ b/net-p2p/qbittorrent/pkg-plist
@@ -0,0 +1,39 @@
+bin/qbittorrent
+share/applications/qBittorrent.desktop
+share/icons/hicolor/128x128/apps/qbittorrent.png
+share/icons/hicolor/16x16/apps/qbittorrent.png
+share/icons/hicolor/192x192/apps/qbittorrent.png
+share/icons/hicolor/22x22/apps/qbittorrent.png
+share/icons/hicolor/24x24/apps/qbittorrent.png
+share/icons/hicolor/32x32/apps/qbittorrent.png
+share/icons/hicolor/36x36/apps/qbittorrent.png
+share/icons/hicolor/48x48/apps/qbittorrent.png
+share/icons/hicolor/64x64/apps/qbittorrent.png
+share/icons/hicolor/72x72/apps/qbittorrent.png
+share/icons/hicolor/96x96/apps/qbittorrent.png
+share/pixmaps/qbittorrent.png
+@dirrmtry share/icons/hicolor/96x96/apps
+@dirrmtry share/icons/hicolor/96x96
+@dirrmtry share/icons/hicolor/72x72/apps
+@dirrmtry share/icons/hicolor/72x72
+@dirrmtry share/icons/hicolor/64x64/apps
+@dirrmtry share/icons/hicolor/64x64
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor/36x36/apps
+@dirrmtry share/icons/hicolor/36x36
+@dirrmtry share/icons/hicolor/32x32/apps
+@dirrmtry share/icons/hicolor/32x32
+@dirrmtry share/icons/hicolor/24x24/apps
+@dirrmtry share/icons/hicolor/24x24
+@dirrmtry share/icons/hicolor/22x22/apps
+@dirrmtry share/icons/hicolor/22x22
+@dirrmtry share/icons/hicolor/192x192/apps
+@dirrmtry share/icons/hicolor/192x192
+@dirrmtry share/icons/hicolor/16x16/apps
+@dirrmtry share/icons/hicolor/16x16
+@dirrmtry share/icons/hicolor/128x128/apps
+@dirrmtry share/icons/hicolor/128x128
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications