aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-14 22:32:25 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-14 22:32:25 +0000
commit11650531cef5c08dfa250f7203a7acf7e525a03e (patch)
treec67e8aefd4a28e72701ffb253b68d4bd91522ac7 /net-p2p/qbittorrent
parent46e360a642237d99e5e177a4f351493b8a6d7ea4 (diff)
downloadports-11650531cef5c08dfa250f7203a7acf7e525a03e.tar.gz
ports-11650531cef5c08dfa250f7203a7acf7e525a03e.zip
net-p2p/qbittorrent: Update to 3.3.3
This update includes the new options QT4/QT5 to allow the user to choose the Qt version. PR: 206510
Notes
Notes: svn path=/head/; revision=411126
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile39
-rw-r--r--net-p2p/qbittorrent/distinfo4
-rw-r--r--net-p2p/qbittorrent/files/patch-configure11
3 files changed, 32 insertions, 22 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 95c3782e55f1..b80a8bffc4b6 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.2.3
+PORTVERSION= 3.3.3
DISTVERSIONPREFIX= release-
CATEGORIES= net-p2p ipv6
@@ -20,38 +20,59 @@ GH_ACCOUNT= qBittorrent
GH_PROJECT= qBittorrent
USES= compiler:c++11-lang execinfo pkgconfig tar:xz
-USE_QT4= corelib network qmake_build linguisttools_build moc_build \
- rcc_build uic_build
+QT4_USE= QT4=corelib,network,qmake_build,linguisttools_build,moc_build,rcc_build,uic_build
+QT5_USE= QT5=core,concurrent,network,widgets,qmake_build,buildtools_build,linguisttools_build
QT_NONSTANDARD= yes
DESTDIRNAME= INSTALL_ROOT
.if !defined(SLAVE_PORT)
LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
USES+= desktop-file-utils
-USE_QT4+= gui xml
+QT4_USE+= QT4=gui,xml
+QT5_USE+= QT5=gui,xml
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DBUS
.endif
PORTDOCS= AUTHORS Changelog README.md
-OPTIONS_DEFINE= DEBUG DOCS DBUS
+OPTIONS_DEFINE= DEBUG DOCS DBUS
+OPTIONS_RADIO= QT
+OPTIONS_RADIO_QT= QT4 QT5
+OPTIONS_DEFAULT= QT4
+OPTION_QT= ${SELECTED_OPTIONS:MQT*}
DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
-DBUS_USE= QT4=dbus
+
+.include <bsd.port.options.mk>
+
+# Qt4 fails to detect base clang features, this section corrects it
+.if ${PORT_OPTIONS:MQT4}
+CXXFLAGS+= -DQ_COMPILER_INITIALIZER_LISTS
+.endif
+
+.if ${PORT_OPTIONS:MDBUS}
+USE_${OPTION_QT}+= dbus
+.endif
+
+CXXFLAGS+= -DBOOST_ASIO_DYN_LINK
CONFIGURE_ENV+= zlib_CFLAGS=-I/usr/include
CONFIGURE_ENV+= zlib_LIBS=-lz
-CONFIGURE_ARGS+= CXXFLAGS=-DBOOST_ASIO_DYN_LINK
+CONFIGURE_ARGS+= CXXFLAGS="${CXXFLAGS}"
+CONFIGURE_ARGS+= --with-${OPTION_QT:tl}
GNU_CONFIGURE= yes
USE_OPENSSL= yes
post-patch:
+.if ${PORT_OPTIONS:MQT4}
${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/bin/qmake-qt4,' \
${WRKSRC}/${CONFIGURE_SCRIPT}
-
-.include <bsd.port.options.mk>
+.else
+ ${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/lib/qt5/bin/qmake,' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
.if !defined(SLAVE_PORT) || ${SLAVE_PORT:tl} != "no"
CONFIGURE_ARGS+= --disable-gui
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index c2bb982e1015..5b0a42e2d4e5 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qBittorrent-qBittorrent-release-3.2.3_GH0.tar.gz) = 816d611a0af50c469f52946c94b88c003f908ee031ee0e55a45273e4c64897c5
-SIZE (qBittorrent-qBittorrent-release-3.2.3_GH0.tar.gz) = 4601930
+SHA256 (qBittorrent-qBittorrent-release-3.3.3_GH0.tar.gz) = 04f03623be427294238f119d1ab3311e8560a091778f12df03cc9380fad2c6d9
+SIZE (qBittorrent-qBittorrent-release-3.3.3_GH0.tar.gz) = 4984105
diff --git a/net-p2p/qbittorrent/files/patch-configure b/net-p2p/qbittorrent/files/patch-configure
deleted file mode 100644
index 4a55e94bd1b0..000000000000
--- a/net-p2p/qbittorrent/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure 2015-08-02 13:18:04 UTC
-+++ configure 2015-08-19 00:00:14 -0400
-@@ -5809,7 +5809,7 @@
- fi
-
- # Convert " -" to "\n" if not between quotes and remove possible leading white spaces
-- string=$(echo " $*" | $SED -e 's: -:\n:g' -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g" -e 's/^[:space:]*//')
-+ string=$(echo " $*" | tr ' -' '\n' | $SED -e 's: -:\n:g' -e 's:"\(.*\)\n\(.*\)":\"\1 -\2":g' -e "s:'\(.*\)\n\(.*\)':\'\1 -\2':g" -e 's/^[:space:]*//')
- SAVEIFS=$IFS
- IFS=$(printf "\n\b")
- for i in $string; do