aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/qbittorrent
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-10-19 18:40:32 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-10-19 18:40:32 +0000
commitf0b6ef65d6d8b23b7509e4c9230099ede2ec227b (patch)
treec076409420ad78795c3ff5afaf309a6d077ad328 /net-p2p/qbittorrent
parent91c5c7bcc323a6028943ed983803508ce11aa95d (diff)
downloadports-f0b6ef65d6d8b23b7509e4c9230099ede2ec227b.tar.gz
ports-f0b6ef65d6d8b23b7509e4c9230099ede2ec227b.zip
net-p2p/qbittorrent: update 3.3.3 -> 3.3.7
- Lots of changes, see link to the Changes - Fixed QT option (RADIO->SINGLE), see details in PR#208038 - Changed Qt default to Qt5 PR: 209132 Changes: http://www.qbittorrent.org/news.php Submitted by: Yuri Victorovich <yuri@rawbw.com> (maintainer), mi, matthew@reztek.cz
Notes
Notes: svn path=/head/; revision=424281
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/Makefile84
-rw-r--r--net-p2p/qbittorrent/distinfo5
-rw-r--r--net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp31
3 files changed, 70 insertions, 50 deletions
diff --git a/net-p2p/qbittorrent/Makefile b/net-p2p/qbittorrent/Makefile
index 5dfc415e6c64..4b26e5d9d46c 100644
--- a/net-p2p/qbittorrent/Makefile
+++ b/net-p2p/qbittorrent/Makefile
@@ -2,86 +2,74 @@
# $FreeBSD$
PORTNAME= qbittorrent
-PORTVERSION= 3.3.3
-DISTVERSIONPREFIX= release-
+PORTVERSION= 3.3.7
CATEGORIES= net-p2p ipv6
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= yuri@rawbw.com
-COMMENT?= Bittorrent client using Qt4 and libtorrent-rasterbar
+COMMENT?= Bittorrent client using Qt4/5 and libtorrent-rasterbar
LICENSE= GPLv2
-BROKEN= fails to build
-
-# ABI versions specified on purpose for libtorrent-rasterbar
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
libboost_system.so:devel/boost-libs
-USE_GITHUB= yes
-GH_ACCOUNT= qBittorrent
-GH_PROJECT= qBittorrent
-
-USES= compiler:c++11-lang execinfo pkgconfig tar:xz
-QT4_USE= QT4=corelib,network,qmake_build,linguisttools_build,moc_build,rcc_build,uic_build
-QT5_USE= QT5=core,concurrent,network,widgets,qmake_build,buildtools_build,linguisttools_build
+USES= compiler:c++11-lib execinfo pkgconfig tar:xz
+QT4_USE= QT4=corelib,network,xml,qmake_build,linguisttools_build,moc_build,rcc_build,uic_build
+QT5_USE= QT5=core,network,xml,qmake_build,buildtools_build,linguisttools_build
QT_NONSTANDARD= yes
DESTDIRNAME= INSTALL_ROOT
-
-.if !defined(SLAVE_PORT)
-LIB_DEPENDS+= libGeoIP.so:net/GeoIP
-USES+= desktop-file-utils
-QT4_USE+= QT4=gui,xml
-QT5_USE+= QT5=gui,xml
-INSTALLS_ICONS= yes
-OPTIONS_DEFINE= DBUS
-.endif
+GNU_CONFIGURE= yes
PORTDOCS= AUTHORS Changelog README.md
-OPTIONS_DEFINE= DEBUG DOCS DBUS
-OPTIONS_RADIO= QT
-OPTIONS_RADIO_QT= QT4 QT5
-OPTIONS_DEFAULT= QT4
+.if !defined(SLAVE_PORT) || ${SLAVE_PORT:tl} == "no"
+WITH_GUI:= yes
+.else
+WITH_GUI:= no
+.endif
+
+OPTIONS_DEFINE= DBUS DEBUG DOCS
+OPTIONS_SINGLE= QT
+OPTIONS_SINGLE_QT= QT4 QT5
+OPTIONS_DEFAULT= QT5
OPTION_QT= ${SELECTED_OPTIONS:MQT*}
DEBUG_CONFIGURE_ENABLE= debug
DBUS_CONFIGURE_ENABLE= qt-dbus
+QT4_CONFIGURE_ON= --with-qt4
+
+.if ${WITH_GUI} == "yes"
+LIB_DEPENDS+= libGeoIP.so:net/GeoIP
+USES+= desktop-file-utils
+QT4_USE+= QT4=gui
+QT5_USE+= QT5=concurrent,gui,widgets GL=gl
+OPTIONS_DEFAULT+= DBUS
+.else
+CONFIGURE_ARGS+= --disable-gui
+.endif
-.include <bsd.port.options.mk>
+BROKEN_FreeBSD_9= needs more C++11 support than 9.x offers
-# Qt4 fails to detect base clang features, this section corrects it
-.if ${PORT_OPTIONS:MQT4}
-CXXFLAGS+= -DQ_COMPILER_INITIALIZER_LISTS
-.endif
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDBUS}
USE_${OPTION_QT}+= dbus
.endif
-CXXFLAGS+= -DBOOST_ASIO_DYN_LINK
-CONFIGURE_ENV+= zlib_CFLAGS=-I/usr/include
-CONFIGURE_ENV+= zlib_LIBS=-lz
-CONFIGURE_ARGS+= CXXFLAGS="${CXXFLAGS}"
-CONFIGURE_ARGS+= --with-${OPTION_QT:tl}
-
-GNU_CONFIGURE= yes
-USE_OPENSSL= yes
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
post-patch:
.if ${PORT_OPTIONS:MQT4}
- ${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/bin/qmake-qt4,' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
+ ${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/bin/qmake-qt4,' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.else
- ${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/lib/qt5/bin/qmake,' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
-
-.if !defined(SLAVE_PORT) || ${SLAVE_PORT:tl} != "no"
-CONFIGURE_ARGS+= --disable-gui
+ ${REINPLACE_CMD} 's,^\$$QT_QMAKE,${LOCALBASE}/lib/qt5/bin/qmake,' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
.endif
post-install:
-.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "no"
+.if ${WITH_GUI} == "yes"
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/qbittorrent
${INSTALL_MAN} ${WRKSRC}/doc/qbittorrent.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1/
diff --git a/net-p2p/qbittorrent/distinfo b/net-p2p/qbittorrent/distinfo
index 5b0a42e2d4e5..9bcbd5e5a99b 100644
--- a/net-p2p/qbittorrent/distinfo
+++ b/net-p2p/qbittorrent/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qBittorrent-qBittorrent-release-3.3.3_GH0.tar.gz) = 04f03623be427294238f119d1ab3311e8560a091778f12df03cc9380fad2c6d9
-SIZE (qBittorrent-qBittorrent-release-3.3.3_GH0.tar.gz) = 4984105
+TIMESTAMP = 1473733537
+SHA256 (qbittorrent-3.3.7.tar.xz) = 72dc824a90fadc0825e6be6f1c215e38f976262c7f83b625061d542b2b664c40
+SIZE (qbittorrent-3.3.7.tar.xz) = 2884792
diff --git a/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
new file mode 100644
index 000000000000..429fc8a308dc
--- /dev/null
+++ b/net-p2p/qbittorrent/files/patch-src_base_utils_string.cpp
@@ -0,0 +1,31 @@
+--- src/base/utils/string.cpp.orig 2016-09-23 15:05:18 UTC
++++ src/base/utils/string.cpp
+@@ -37,7 +37,7 @@
+ #ifdef QBT_USES_QT5
+ #include <QCollator>
+ #endif
+-#ifdef Q_OS_MAC
++#if defined(Q_OS_MAC) || (defined(__FreeBSD__) && __FreeBSD_version < 1003506)
+ #include <QThreadStorage>
+ #endif
+
+@@ -146,7 +146,8 @@ bool Utils::String::naturalCompareCaseSe
+ {
+ // provide a single `NaturalCompare` instance for easy use
+ // https://doc.qt.io/qt-5/threads-reentrancy.html
+-#ifdef Q_OS_MAC // workaround for Apple xcode: https://stackoverflow.com/a/29929949
++#if defined(Q_OS_MAC) || (defined(__FreeBSD__) && __FreeBSD_version < 1003506)
++// workaround for Apple xcode: https://stackoverflow.com/a/29929949
+ static QThreadStorage<NaturalCompare> nCmp;
+ if (!nCmp.hasLocalData()) nCmp.setLocalData(NaturalCompare(true));
+ return (nCmp.localData())(left, right);
+@@ -160,7 +161,8 @@ bool Utils::String::naturalCompareCaseIn
+ {
+ // provide a single `NaturalCompare` instance for easy use
+ // https://doc.qt.io/qt-5/threads-reentrancy.html
+-#ifdef Q_OS_MAC // workaround for Apple xcode: https://stackoverflow.com/a/29929949
++#if defined(Q_OS_MAC) || (defined(__FreeBSD__) && __FreeBSD_version < 1003506)
++// workaround for Apple xcode: https://stackoverflow.com/a/29929949
+ static QThreadStorage<NaturalCompare> nCmp;
+ if (!nCmp.hasLocalData()) nCmp.setLocalData(NaturalCompare(false));
+ return (nCmp.localData())(left, right);