aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/rtorrent
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2008-11-10 12:09:38 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2008-11-10 12:09:38 +0000
commitabc94c1a565c8b7d82eb50744f218314a5acd151 (patch)
tree94275499cde8ed35a7fd27b0cf0c61b30d319f39 /net-p2p/rtorrent
parent6d6ad3a4523e392b4abb483f6527ff24d81e6546 (diff)
downloadports-abc94c1a565c8b7d82eb50744f218314a5acd151.tar.gz
ports-abc94c1a565c8b7d82eb50744f218314a5acd151.zip
- Use net/xmlrpc-c-devel instead of net/xmlrpc-c.
- Rename patch as it won't apply against new unstable version.
Notes
Notes: svn path=/head/; revision=222679
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/Makefile6
-rw-r--r--net-p2p/rtorrent/files/patch-src_command__network.cc23
2 files changed, 4 insertions, 25 deletions
diff --git a/net-p2p/rtorrent/Makefile b/net-p2p/rtorrent/Makefile
index b18868c93924..d9c621488084 100644
--- a/net-p2p/rtorrent/Makefile
+++ b/net-p2p/rtorrent/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= rtorrent
PORTVERSION?= 0.7.9
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= net-p2p
MASTER_SITES= http://libtorrent.rakshasa.no/downloads/ \
${MASTER_SITE_LOCAL}
@@ -27,6 +27,8 @@ MAN1= rtorrent.1
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug
+EXTRA_PATCHES?= ${.CURDIR}/files/stable-*
+
SUB_FILES= pkg-message
PORTDOCS= README
@@ -37,7 +39,7 @@ OPTIONS= XMLRPC "Compile with xmlrpc-c support" on
.if !defined(WITHOUT_XMLRPC)
CONFIGURE_ARGS+= --with-xmlrpc-c
-LIB_DEPENDS+= xmlrpc.9:${PORTSDIR}/net/xmlrpc-c
+LIB_DEPENDS+= xmlrpc.14:${PORTSDIR}/net/xmlrpc-c-devel
.else
CONFIGURE_ARGS+= --with-xmlrpc-c=no
.endif
diff --git a/net-p2p/rtorrent/files/patch-src_command__network.cc b/net-p2p/rtorrent/files/patch-src_command__network.cc
deleted file mode 100644
index 3fd848ae4e71..000000000000
--- a/net-p2p/rtorrent/files/patch-src_command__network.cc
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/command_network.cc.orig 2007-12-18 21:13:53.000000000 +0000
-+++ src/command_network.cc 2007-12-18 21:14:26.000000000 +0000
-@@ -224,6 +224,8 @@
- saPtr->set_port(port);
- control->scgi()->open_port(saPtr, saPtr->length(), rpc::call_command_value("get_scgi_dont_route"));
-
-+ rak::address_info::free_address_info(ai);
-+
- break;
-
- case 2:
-@@ -232,10 +234,8 @@
- break;
- }
-
-- rak::address_info::free_address_info(ai);
--
- } catch (torrent::local_error& e) {
-- rak::address_info::free_address_info(ai);
-+ //rak::address_info::free_address_info(ai);
-
- throw torrent::input_error(e.what());
- }