aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/transmission25-cli
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-08-10 19:59:17 +0000
committerChris Rees <crees@FreeBSD.org>2012-08-10 19:59:17 +0000
commite01c71c7b1be66fe9acf16d53d3b867b51fee053 (patch)
tree6601ec287b09d6b34b6c1e164de43603a1a0d116 /net-p2p/transmission25-cli
parent67dbda2115277e4457ee6fc8809d07e1263929c0 (diff)
downloadports-e01c71c7b1be66fe9acf16d53d3b867b51fee053.tar.gz
ports-e01c71c7b1be66fe9acf16d53d3b867b51fee053.zip
Create transmission25 ports and UPDATING entry to explain.
Sadly, Transmission has stopped supporting GTK 2.0 (it had to happen some day). They now require GTK 3.2.0 [1], which we currently lack, so for those who wish to use the GTK frontend need to stay on version 2.5 When our GTK is upgraded I'll make MOVED entries to make the transition back to 2.6 as seamless as possible. [1] http://tinyurl.com/cfchfp9
Notes
Notes: svn path=/head/; revision=302400
Diffstat (limited to 'net-p2p/transmission25-cli')
-rw-r--r--net-p2p/transmission25-cli/Makefile88
-rw-r--r--net-p2p/transmission25-cli/distinfo2
-rw-r--r--net-p2p/transmission25-cli/files/disable-web19
-rw-r--r--net-p2p/transmission25-cli/files/patch-fix_without_ipv611
-rw-r--r--net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp12
-rw-r--r--net-p2p/transmission25-cli/files/transmission.in45
-rw-r--r--net-p2p/transmission25-cli/pkg-descr9
-rw-r--r--net-p2p/transmission25-cli/pkg-plist9
8 files changed, 195 insertions, 0 deletions
diff --git a/net-p2p/transmission25-cli/Makefile b/net-p2p/transmission25-cli/Makefile
new file mode 100644
index 000000000000..bf51832f62f9
--- /dev/null
+++ b/net-p2p/transmission25-cli/Makefile
@@ -0,0 +1,88 @@
+# New ports collection makefile for: transmission
+# Date created: 08 October 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transmission
+PORTVERSION= 2.51
+PORTREVISION?= 0
+CATEGORIES?= net-p2p
+#MASTER_SITES= http://download.m0k.org/${PORTNAME}/files/ \
+MASTER_SITES= http://transmission.cachefly.net/
+PKGNAMESUFFIX?= -cli
+
+MAINTAINER?= crees@FreeBSD.org
+COMMENT?= The last version of Transmission that still supports GTK 2.0
+
+LATEST_LINK= ${PORTNAME}25${PKGNAMESUFFIX}
+CONFLICTS_INSTALL= ${PORTNAME}${PKGNAMESUFFIX}-2.6*
+
+SLAVEPORT?= cli
+.if ${SLAVEPORT}!="web"
+LIB_DEPENDS?= ${GEN_LIB_DEPENDS}
+
+# General dependencies
+GEN_LIB_DEPENDS=curl.6:${PORTSDIR}/ftp/curl \
+ event-2.0.6:${PORTSDIR}/devel/libevent2
+GEN_RUN_DEPENDS=${LOCALBASE}/share/transmission/web/index.html:${PORTSDIR}/www/transmission-web
+
+USE_GMAKE= yes
+USE_GNOME?= pkgconfig
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS=--with-zlib=/usr \
+ --disable-libappindicator \
+ --disable-gconf2 \
+ ${EXTRA_CONF_ARGS}
+EXTRA_CONF_ARGS?=--enable-cli \
+ --disable-daemon \
+ --without-gtk \
+ --disable-mac \
+ --disable-nls
+
+MAN1?= transmission-cli.1 transmission-create.1 transmission-edit.1 \
+ transmission-show.1
+EXTRA_PATCHES= ${PATCHDIR}/disable-web
+.endif
+
+USE_XZ= yes
+
+DOCS= AUTHORS COPYING NEWS README
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+general-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
+.if ${SLAVEPORT}!="gtk2"
+ @${REINPLACE_CMD} -e '/#define DISABLE_GETTEXT/s,/\* \(.*\) \*/,\1,' \
+ ${WRKSRC}/libtransmission/utils.h
+.endif
+ @${REINPLACE_CMD} -e \
+ 's|_pthread_flags=".*"|_pthread_flags="${PTHREAD_LIBS}"|g ; \
+ s|rt_clock_gettime=yes|rt_clock_gettime=no|g ; \
+ s|" == "|" = "|g ; s|$$with_ssl.*/usr;|${OPENSSLBASE};|g' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|doc \\| \\|g' \
+ ${WRKSRC}/Makefile.in
+.if ${SLAVEPORT}!="cli"
+ @${REINPLACE_CMD} -e 's|utils \\|\\|g' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+post-patch: general-patch
+
+general-install:
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+post-install: general-install
+
+.include <bsd.port.mk>
diff --git a/net-p2p/transmission25-cli/distinfo b/net-p2p/transmission25-cli/distinfo
new file mode 100644
index 000000000000..2ce4ace420c4
--- /dev/null
+++ b/net-p2p/transmission25-cli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (transmission-2.51.tar.xz) = 1c9a54864acf8fd0c7aa4132e9e69b454a7c72c305c96016a38551157af8858b
+SIZE (transmission-2.51.tar.xz) = 2784036
diff --git a/net-p2p/transmission25-cli/files/disable-web b/net-p2p/transmission25-cli/files/disable-web
new file mode 100644
index 000000000000..2c63c36e62a8
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/disable-web
@@ -0,0 +1,19 @@
+--- Makefile.in.orig 2010-10-23 15:56:02.000000000 -0500
++++ Makefile.in 2010-10-23 15:56:55.000000000 -0500
+@@ -303,15 +303,13 @@
+ @BUILD_GTK_TRUE@GTK_DIR = gtk po
+ @BUILD_MAC_TRUE@MAC_DIR = macosx
+ SUBDIRS = \
+- extras \
+ third-party \
+ libtransmission \
+ utils \
+ $(DAEMON_DIR) \
+ $(CLI_DIR) \
+ $(GTK_DIR) \
+- $(MAC_DIR) \
+- web
++ $(MAC_DIR)
+
+ EXTRA_DIST = \
+ qt \
diff --git a/net-p2p/transmission25-cli/files/patch-fix_without_ipv6 b/net-p2p/transmission25-cli/files/patch-fix_without_ipv6
new file mode 100644
index 000000000000..49e1c57a269a
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/patch-fix_without_ipv6
@@ -0,0 +1,11 @@
+--- libtransmission/fdlimit.c.orig 2011-02-27 15:34:55.000000000 -0600
++++ libtransmission/fdlimit.c 2011-02-27 15:35:12.000000000 -0600
+@@ -609,7 +609,7 @@
+
+ if( gFd->socket_count < session->peerLimit )
+ if(( s = socket( domain, type, 0 )) < 0 )
+- if( sockerrno != EAFNOSUPPORT )
++ if( sockerrno != EPROTONOSUPPORT )
+ tr_err( _( "Couldn't create socket: %s" ), tr_strerror( sockerrno ) );
+
+ if( s > -1 )
diff --git a/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp b/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp
new file mode 100644
index 000000000000..8f4b4866ad29
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/patch-third-party_libutp_utp.cpp
@@ -0,0 +1,12 @@
+--- third-party/libutp/utp.cpp.orig 2011-04-29 21:45:38.000000000 -0500
++++ third-party/libutp/utp.cpp 2011-04-29 21:47:05.000000000 -0500
+@@ -10,6 +10,9 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <limits.h> // for UINT_MAX
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+
+ #ifdef WIN32
+ #include "win32_inet_ntop.h"
diff --git a/net-p2p/transmission25-cli/files/transmission.in b/net-p2p/transmission25-cli/files/transmission.in
new file mode 100644
index 000000000000..def430c8b88b
--- /dev/null
+++ b/net-p2p/transmission25-cli/files/transmission.in
@@ -0,0 +1,45 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: transmission
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf to enable this service:
+#
+# transmission_enable: Set to NO by default. Set it to YES to enable it.
+# transmission_watch_dir: Directory for torrent files to download
+# automatically. Off by default unless you add
+# a path.
+# transmission_conf_dir: Directory where transmission configuration
+# data is stored.
+# Default: %%PREFIX%%/etc/transmission/home
+# transmission_download_dir: Directory to store downloaded data.
+# Default: %%PREFIX%%/etc/transmission/home/Downloads
+# transmission_user: The user account transmission daemon runs as what
+# you want it to be. It uses 'transmission' user by
+# default. Do not sets it as empty or it will run
+# as root.
+#
+
+. /etc/rc.subr
+
+name="transmission"
+rcvar=transmission_enable
+
+command=%%PREFIX%%/bin/transmission-daemon
+
+load_rc_config ${name}
+
+: ${transmission_enable:="NO"}
+: ${transmission_user:="transmission"}
+: ${transmission_conf_dir="%%PREFIX%%/etc/transmission/home"}
+: ${transmission_download_dir="%%PREFIX%%/etc/transmission/home/Downloads"}
+
+transmission_flags=" \
+ ${transmission_watch_dir:+-c ${transmission_watch_dir}} \
+ ${transmission_conf_dir:+-g ${transmission_conf_dir}} \
+ ${transmission_download_dir:+-w ${transmission_download_dir}} \
+ ${transmission_flags}"
+
+run_rc_command "$1"
diff --git a/net-p2p/transmission25-cli/pkg-descr b/net-p2p/transmission25-cli/pkg-descr
new file mode 100644
index 000000000000..5809e6716ef4
--- /dev/null
+++ b/net-p2p/transmission25-cli/pkg-descr
@@ -0,0 +1,9 @@
+A fast and lightweight CLI (command line) BitTorrent client.
+
+Transmission has been built from the ground up to be a lightweight, yet
+powerful BitTorrent client. Its simple, intuitive interface is designed
+to integrate tightly with whatever computing environment you choose to
+use. Transmission strikes a balance between providing useful functionality
+without feature bloat. Furthermore, it is free for anyone to use or modify.
+
+WWW: http://www.transmissionbt.com/
diff --git a/net-p2p/transmission25-cli/pkg-plist b/net-p2p/transmission25-cli/pkg-plist
new file mode 100644
index 000000000000..58ae01daf4a8
--- /dev/null
+++ b/net-p2p/transmission25-cli/pkg-plist
@@ -0,0 +1,9 @@
+bin/transmission-cli
+bin/transmission-create
+bin/transmission-edit
+bin/transmission-show
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%